Solved Vault Plugin Causing Saplings To Not Grow...

Discussion in 'Spigot Help' started by PiggiesGoSqueal, May 26, 2017.

  1. On my Skyblock server saplings aren't growing. All players are having this issue. I've tried everything and nothing has worked. http://prntscr.com/fcgaap

    Plugins: http://prntscr.com/fcgak6
    It's a Spigot 1.11.2 server

    Things that don't work:
    - Having plenty of space
    - Using bonemeal
    - Waiting
    - Water near the sapling
    - Lava (for light) near the sapling
    - Day/Night time
    - Torches near the sapling

    What is causing this issue and how can I fix it?

    Thanks!

    Edit: If you don't believe me and would like to try it out yourself the ip is: 192.99.1.114:25699

    Update:

    The server version is now 1.10.2. I ended up switching to 1.10.2 and deleting the world to see if it would fix the issue but it didn't.


    I removed all my plugins a few at a time then once saplings started growing I added the plugins back one at a time until finding the plugin causing the issue. Vault was the cause, as unlikely as it may seem. If you'd like to see my process it's here

    Now the current issue is: I need vault so how can I keep this sapling issue from happening?


    Vault works fine on thousands of servers.. I don't understand why it doesn't on mine. I've tried updating the plugin and using the exact version from my other server, neither of those worked.
     
    #1 PiggiesGoSqueal, May 26, 2017
    Last edited: May 28, 2017
  2. Could you please provide a list of plugins you have on you server?
     
  3. I did... It's in a screenshot that I linked..
     
  4. Double check that you haven't blocked anything with worldguard.

    Otherwise, since you don't have that many plugins, you can remove them 1 by 1 and keep trying to grow trees until you find the plugin that's messing it up.
     
    • Informative Informative x 1
  5. I checked the worldguard flags for __global__ but there was no option for sapling growth (that I could see).
     
  6. Alright, try removing plugins 1 by 1, I would try anything related to the world first: worldguard, worldedit, multiverse? etc.

    If you remove a plugin and the problem is still there, put the plugin back and take another one out until you find the one that is problematic.
     
  7. I didn't have multiverse installed while having the issue (I just installed it). I ended up switching back to 1.10 and am planning to remove my current world then make a new one. Hopefully that'll fix the issue. I have to fix some issues on my other server first but I'll update this later after trying it out. Thanks!
     
  8. @FireFlies Well... I admit I had some doubts haha but I removed plugins a few at a time then once it started to grow saplings again I re-added them 1 at a time until I found it. Turns out, Vault was causing the issue. Which is definitely not what I expected because it's used on so many servers and is required for a ton of plugins. I guess I'll try to update the plugin and see how that goes.

    Edit 2: Okay.. it's definitely vault causing the issue because I whenever I remove it, saplings start growing again and when I re-add it they stop growing. Now there's a new issue. I need vault because it's required for so many plugins, some of which I need to use. I've tried using an updated version and a version (+ folder) straight from my other server where Vault works fine. Neither of those worked.

    How can I fix this? Basically I need vault but it's the plugin causing saplings to not grow.
     
    #8 PiggiesGoSqueal, May 28, 2017
    Last edited: May 28, 2017
  9. Hmm very strange, never had a problem with vault like this. Are you sure it's ONLY vault causing the issue? No other plugins?
     
    • Agree Agree x 1
  10. Well without vault it works fine and with vault it doesn't work. There doesn't seem to be another explanation. I removed all other plugins at some point except for PermissionsEx and ASkyBlock.

    I updated the original post with the latest information. If you read my procedure keep in mind that any plugins not listed in it, I had already tried before I started to keep track of the plugins I was removing each restart.
     
  11. electronicboy

    IRC Staff

    Vault literally cannot cause that, it's more likely to be a plugin that uses vault for something, which without vault that plugin/plugin "feature" isn't getting enabled for some reason.
     
    • Agree Agree x 1
  12. Gaxan

    Supporter

    You are removing vault and it's working. Most likely its a plugin that uses Vault as a dependency. Vault has nothing to do with sapling growth.
    Install base plugins like Vault and permissions.
    Add the next plugin, check the console for errors. If no errors add the next.
    I know you arent checking errors, you have a dead plugin, in your plugin list.

    Alternatively, leave vault out, and start your server. Put the console start up log in pastebin and post it here.
     
    • Agree Agree x 1
    • Funny Funny x 1
  13. I've removed every other plugin though except PermissionsEx and ASkyBlock so if it wasn't vault then the sapling issue should have been fixed when I removed the other plugins.

    I agree, vault has nothing to do with sapling growth hence why I'm very confused. And I do check errors... Every startup..

    Plugins that rely on Vault based off the startup:
    - EnjinMinecraftPlugin
    - ASkyBlock
    - PermissionsEx
    - ServerSigns

    Startup without Vault:
    https://pastebin.com/DDMskQJQ
     
  14. Gaxan

    Supporter

    I've never used ASkyBlock. Anything in the config pertaining to saplings, trees or growth?
     
  15. electronicboy

    IRC Staff

    not all plugins are that badly designed that they won't start up at all without vault installed; many will start up but not use vault features
     
  16. Based off the server startup the two plugins mentioned that did start up but didn't use vault features were:
    - PermissionsEx
    - ServerSigns
     
  17. Not that I see besides nether trees which isn't important for this.
     
  18. Choco

    Moderator

    • Winner Winner x 1
    • Useful Useful x 1
  19. On islands. Islands are set to not be protected because of the type of server I'm trying to create. Is there any way to make them grow in not protected areas?

    Thanks!
     
  20. Choco

    Moderator

    I mean, the problem I see here is that there doesn't seem to be any programmed configuration option for this. I would ask @Tastybento to add in a configuration option or a permission node for that ^-^ (Thought I'd ping him to get his attention here. Hope he doesn't mind)
     
    #20 Choco, May 30, 2017
    Last edited: May 30, 2017
    • Like Like x 1