Spigot Vault 1.7.3

Vault is a Permissions, Chat, & Economy API to give plugins easy hooks into these systems.

  1. i have a plug that on 1.13 doent detect vault, on 1.12 it does...
     
  2. What plugin would that be?
     
  3. its a custom one not public yet
    Code (Text):
        private boolean setupEconomy() {
            if (getServer().getPluginManager().getPlugin("Vault") == null) {
                return false;
            }
            RegisteredServiceProvider<Economy> rsp = getServer().getServicesManager().getRegistration(Economy.class);
            if (rsp == null) {
                return false;
            }
            economy = rsp.getProvider();
            return economy != null;
        }
    with vault in place this returns null
     
    • Like Like x 1
  4. Sikatsu

    Patron

    I'm confused. I'm still using vault 1.5.6 from bukkit. What is this resource? An actual update or a rewrite from another developer? Will this work with all plugins just like 1.5.6 vault?
     
  5.  
    • Agree Agree x 1
  6. Plugin is to 1.13 ?
     
  7. Does this merge the changes that are needed to make it as efficient as possible for CMI?
     
  8. Is this build not stable lol jk, just getting this message at startup of console not a problem just might wanna change that below in next update... unless this build isn't stable?


    [19:45:46 INFO]: [Vault] Checking for Updates ...
    [19:45:48 INFO]: [Vault] Stable Version: 1.5.6 | Current Version: 1.6.7
     
    #29 Alter-Ego, Aug 18, 2018
    Last edited: Aug 18, 2018
  9. It's the same version with typo fixes and jerkin build fix. You can see the changes here. https://github.com/MilkBowl/Vault/commits/master

    Just disable update check if you are using 1.5.6

    Here is a bug you can try to fix it. https://github.com/MilkBowl/Vault/issues/735
     
  10. That error has nothing to do with Vault... its from React.... Vault doesn't use NMS
     
  11. Whops, sorry, I didn't see the below message. Thanks and sorry.
     
  12. No problem ;)
     
  13. I am a bit confused, is there an update of the official vault for 1.13.1, or is this the replacement for vault, and with 1.13.1 support?
    I don't quite understand which direction to go with - since so many 1.13.x plugins require vault, i dunno which 'vault' they refer to, or are using themselves.
    Maybe I should use @md_5's build? https://ci.md-5.net/job/Vault/
     
  14. You should be able to use this or that release you posted for 1.13.x and previous minecraft versions the jenkins versions seem to be more up to date so I'd go with that for now, I think they put the original there just as a reference or because these may be experimental builds and the original is maybe there as a stable version perhaps. But this new release doesn't mention anything about 1.13 in the recent changes. I had a problem a while back where vault wasn't loading up with certain plugins because I didn't have an economy plugin it could be that too, hope that helps unless I misunderstood hope not either way have a nice day:)
     
    • Informative Informative x 1
  15. Ill stick with old version for now :D
    upload_2018-9-11_13-25-15.png