Spigot Vehicles PlotSquared Protection Vehicles >= 9.5.2

Adds protection to your PlotSquared World for the plugin vehicles.

  1. pollitoyeye submitted a new resource:

    Vehicles Plot Squared Protection (Vehicles >= 9.5.2) - Adds protection to your PlotSquared World for the plugin vehicles.

    Read more about this resource...
     
  2. Hey!

    I bought your vehicles plugin and I am using this Addon on my server and its amazing but Plotsquared now is Premium and Updated to v5 with tons of fixes/features but sadly they changed the API so now every plugin that supported plotsquared need to update to the new API. Your plugin is one I use on my server and stopped Working because of it :(, I am still using Plots v4 for now, so My players can continue using it.

    Could you update when you have time?
    https://github.com/IntellectualSites/PlotSquared/wiki/API-Documentation

    Error when plugin loading:
    Code (Text):
    [14:09:34 INFO]: [VehiclesPlotSquared] Enabling VehiclesPlotSquared v1.0
    [14:09:34 ERROR]: [VehiclesPlotSquared] Plugin VehiclesPlotSquared v1.0 has failed to register events for class es.pollitoyeye.VehiclesPlotSquared.VehiclesPlotSquared because com/github/intellectualsites/plotsquared/plot/object/Location does not exist.
    [14:09:34 ERROR]: Error occurred while enabling VehiclesPlotSquared v1.0 (Is it up to date?)
    java.lang.NoClassDefFoundError: com/github/intellectualsites/plotsquared/api/PlotAPI
    at es.pollitoyeye.VehiclesPlotSquared.VehiclesPlotSquared.onEnable(VehiclesPlotSquared.java:52) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:483) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugin(CraftServer.java:470) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugins(CraftServer.java:384) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at net.minecraft.server.v1_15_R1.MinecraftServer.a(MinecraftServer.java:482) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at net.minecraft.server.v1_15_R1.DedicatedServer.init(DedicatedServer.java:299) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:885) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at java.lang.Thread.run(Thread.java:834) [?:?]
    Caused by: java.lang.ClassNotFoundException: com.github.intellectualsites.plotsquared.api.PlotAPI
    at java.net.URLClassLoader.findClass(URLClassLoader.java:471) ~[?:?]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:171) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:100) ~[patched_1.15.2.jar:git-Tuinity-"99854e9"]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:588) ~[?:?]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:521) ~[?:?]
    ... 10 more
    [14:09:34 INFO]: [VehiclesPlotSquared] Disabling VehiclesPlotSquared v1.0


    Thank you for your work.
     
  3. Updated.
     
  4. Just a suggestion, but would it be possible to add a preventative to how many vehicles can be placed in a plot? It's easy to spam vehicles all around and plotsquares auto trim feature is really buggy with vehicles. Maybe just a config option with a configure limit?

    Thanks