Spigot VentureChat 3.3.0

#1 Channels Chat plugin! Spigot + Bungee. Supports PlaceholderAPI + JSON formatting. New Hex Colors!

  1. That's what I did to fix the last issue. Even after doing it again just to be sure there is no change. It appears to be the fault of /messagetoggle defaulting to false.
     
  2. @Aust1n46 thanks, it worked. Another question, how do I get the prefixes from Jobs Reborn to work?

    Edit: Apologies, should have looked a little deeper in the jobs config file. Found it. Great plugin venturechat is

    Edit2:
    [​IMG]
    [​IMG]

    Edit3:
    I am using placeholder API
     
    #4702 hainkiwanki, Sep 17, 2016
    Last edited: Sep 17, 2016
  3. Hey, I am getting this error, when I use the latest version and try to write in chat:
    17.09 12:53:56 [Server] INFO ... 11 more 17.09 12:53:56 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_91] 17.09 12:53:56 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_91] 17.09 12:53:56 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_91] 17.09 12:53:56 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_91] 17.09 12:53:56 [Server] INFO at mineverse.Aust1n46.chat.listeners.ChatListener.onAsyncPlayerChatEvent(ChatListener.java:530) ~[?:?] 17.09 12:53:56 [Server] INFO at mineverse.Aust1n46.chat.utilities.FormatTags.ChatFormat(FormatTags.java:137) ~[?:?] 17.09 12:53:56 [Server] INFO at java.lang.String.replace(String.java:2240) ~[?:1.8.0_91] 17.09 12:53:56 [Server] INFO Caused by: java.lang.NullPointerException 17.09 12:53:56 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_91] 17.09 12:53:56 [Server] INFO at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_91] 17.09 12:53:56 [Server] INFO at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_91] 17.09 12:53:56 [Server] INFO at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_91] 17.09 12:53:56 [Server] INFO at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_91] 17.09 12:53:56 [Server] INFO at net.minecraft.server.v1_8_R3.PacketPlayInChat$1.run(PacketPlayInChat.java:39) [spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:1022) [spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO at net.minecraft.server.v1_8_R3.PlayerConnection.chat(PlayerConnection.java:1084) [spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:484) [spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[spigot-1.8.8.jar:git-Spigot-db6de12-d3e0b6f] 17.09 12:53:56 [Server] INFO org.bukkit.event.EventException 17.09 12:53:56 [Server] ERROR Could not pass event AsyncPlayerChatEvent to VentureChat v2.10.0

    Any ideas on how to fix it ?

    Thanks in advance :)
     
  4. Would using the same Players.yml file for every server linked by a Bungee instance cause issues? And I don't mean copies, I mean using the exact same Players.yml for every server through symbolic links
     
  5. @InfinityAspire Yes, that would cause data to be lost because the data is stored in memory, so whatever servers saves first would set the data for all the servers. So if I muted a player on a server but another server saves the file, the mute is lost. The entire contents of the file are read into memory when the server loads (that's why you can mute offline players etc.). At worst you could have actual errors that prevent the plugin from loading. That is why I have the sync stuff to synchronize mutes and other data values.

    @hainkiwanki You need to download the PlaceholderAPI packs.
    Code (Text):
    /papi ecloud download Jobs
    @monjo44 Please us Pastebin and supply configs to help make a determination.
     
  6. Edit: SOLVED! The Venturechat.jar file wasn't installed on the bungeecord server itself

    When running a server with default venturechat configuration, all personal messages are silently ignored

    If i change to bungeecordmessaging: false, private messaging works as expected.

    setting loglevel: debug does't give any more information in the log. No errors, just silently ignorance

    This happens both on server behind bungee and not. Both recent spigot and latest paperspigot servers.

    Loaded plugins on example server:

    dynmap, Vault, Essentials, EssentialsSpawn, PlaceholderAPI, ProtocolLib, VentureChat, ASkyBlock, Dynmap-ASkyBlock
    commands i have tested that are affected are:

    tell
    whisper
    message
    reply

    I'm using version 2.10.0:
    > grep -i venture logs/latest.log
    [08:44:07 INFO]: [VentureChat] Enabling VentureChat v2.10.0
    [08:44:07 INFO]: [VentureChat] - Initializing...
    [08:44:07 INFO]: [VentureChat] - Config found! Loading file.
    [08:44:07 INFO]: [VentureChat] - Checking for Vault...
    [08:44:07 INFO]: [VentureChat] - Enabled Successfully
    [08:44:07 INFO]: [VentureChat] - Registering Listeners
    [08:44:07 INFO]: [VentureChat] - Attaching to Executors
    [08:44:07 INFO]: [VentureChat] - Establishing BungeeCord
    [08:44:07 INFO]: [VentureChat] - Enabling PlaceholderAPI Hook
    [08:44:07 INFO]: [VentureChat] - Added placeholders to PlaceholderAPI!
    [08:44:07 INFO]: [VentureChat] - Loading player data

    These are clean install of Venturechat, no upgrading,

    Playing with /messagagetoggle doesn't make things work

    Removing EssentialsX plugin doesn't make things work
     
    #4706 haugsvar, Sep 18, 2016
    Last edited: Sep 18, 2016
  7. #4709 hainkiwanki, Sep 22, 2016
    Last edited: Sep 25, 2016
  8. @hainkiwanki [​IMG]
    IF YOU HAVE QUESTIONS OR ISSUES USING VENTURECHAT, PLEASE ASK IN THE DISCUSSION, NOT IN THE REVIEWS SECTION!

    Include configs and logs with every error report! Use Pastebin!

    Please follow the reporting directions. I need configs.
     
  9. Don't know if it's a bug or something that can even be worked around, but when specifying an alias, it doesn't seem to work if the command belongs to a BungeeCord plugin.
    Also, it'd be nice to perhaps have per server alias' for Bungee servers.
     
    #4711 Sequacious, Sep 22, 2016
    Last edited: Sep 23, 2016
  10. @InfinityAspire It will never work because BungeeCord intercepts commands before Spigot ever gets them.
     
  11. There's no way to make that work even with the bungee side of the plugin?
     
  12. I really like a lot of the features I read about this plugin, but I still have a few questions:

    1) Does it have an auto-broadcast feature for server announcements and such?
    2) Does the configurable chat filer mute/block the messages or ** words out?
    3) Since this replaces EssentialsChat, would this plugin also support default chat colors for certain groups?

    Hopefully the answers to these weren't missed by me in the description. Thanks!
     
  13. Hello Austin,

    How do I make /me only appears in a specific channel? Is it possible with the alias system?
     
  14. Hi everyone !

    I've a little problem with VentureChat.
    Dependencies have been corectly instaled, but I've this error.

    [16:00:59] [Server thread/INFO]: [0;30;1m[[0;33;1mVentureChat[0;30;1m][0;33;1m - Registering Listeners[m
    [16:00:59] [Server thread/ERROR]: Error occurred while enabling VentureChat v2.10.0 (Is it up to date?)
    java.lang.RuntimeException: Failed to read JSON
    at com.comphenix.protocol.wrappers.ComponentParser.deserializeLegacy(ComponentParser.java:56) ~[?:?]
    at com.comphenix.protocol.wrappers.ComponentParser.deserialize(ComponentParser.java:40) ~[?:?]
    at com.comphenix.protocol.wrappers.WrappedChatComponent.deserialize(WrappedChatComponent.java:67) ~[?:?]
    at com.comphenix.protocol.wrappers.WrappedChatComponent.fromJson(WrappedChatComponent.java:93) ~[?:?]
    at mineverse.Aust1n46.chat.command.chat.Edit.<init>(Edit.java:24) ~[?:?]
    at mineverse.Aust1n46.chat.MineverseChat.onEnable(MineverseChat.java:354) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugin(CraftServer.java:356) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.enablePlugins(CraftServer.java:316) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.q(MinecraftServer.java:402) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.k(MinecraftServer.java:370) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.a(MinecraftServer.java:325) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:211) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [spigot.jar:git-Spigot-c3c767f-33d5de3]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]
    Caused by: java.lang.NoSuchMethodException: org.bukkit.craftbukkit.libs.com.google.gson.stream.JsonReader.<init>(java.io.StringReader)
    at java.lang.Class.getConstructor0(Class.java:3082) ~[?:1.8.0_101]
    at java.lang.Class.getConstructor(Class.java:1825) ~[?:1.8.0_101]
    at com.comphenix.protocol.wrappers.ComponentParser.deserializeLegacy(ComponentParser.java:48) ~[?:?]
    ... 16 more

    Who can help me ? :)

    PS : Sorry for my English, I'm Frensh ;)
     
  15. @AntCat17 This is a channels chat plugin; it doesn't just replace EssentialsChat. Each channel sets the chat color, but there is a "None" feature to use the last color from the format. If you want each person to have a chat color, people generally put a suffix placeholder at the end of the channel format, and give player groups color codes for suffixes.

    There is a chat filter, which is the first thing in the config, and it mentioned in the overview.

    There is no auto broadcast. There are already plugins that do that, so just use one in conjunction with VentureChat.

    @rosedragon It's not possible, my /me is a global emote command. Maybe I can add an option for per channel, but no guarantees at this moment.

    @Uni-Fight_FRANCE You have the wrong version of ProtocolLib for your server version, and VentureChat only works on 1.8.9 for the 1.8 versions I'm pretty sure. If you're using 1.8, you should use the latest version of it.
     
  16. @Aust1n46 I try to set a correct ProtocolLib version. Can I use the latest version of VentureChat ?
     
  17. @Aust1n46 maybe a command that kind of mimic /me but it can be anything else, I can always use alias. I saw on some server that can have local /me. Thanks!