Bukkit VentureChat 2.14.3

#1 Channels Chat plugin! Spigot + Bungee. Supports PlaceholderAPI + JSON formatting. Moderation GUI!

  1. @TheVicow {player}

    @Nyquest Pretty much as close as you're going to get for now. The JSON features are an essential part of the plugin.

    @Rhander Going to need configs like the overview page states. 99% of all errors are caused by mistakes in the config.

    @NOBUTSS That AFK plugin you use sends JSON (more than likely for no good reason) using the SpigotAPI method that can break my ProtocolLib packet listener. I'm pretty sure I had code in their setup to fix this, but I'll have to look again. I have no idea why they thought it would be a good idea to include a method that doesn't operate the same as normal Minecraft packets.... but they did.
     
    • Like Like x 2
  2. Hey there, I'm trying to setup VentureChat to display a player's Kingdom from the Kingdoms plugin. When I add the placeholder to the config, my chat seems to have a heart attack, and I can't get it to function correctly. Any help?

    channels:
    Global:
    color: white
    chatcolor: white
    mutable: true
    filter: false
    autojoin: true
    default: true
    distance: 0
    cooldown: 0
    bungeecord: false
    alias: g
    permissions: None
    format: '&7%kingdoms_kingdom% {suffix}{prefix}&7 {nickname}&8:&r'
    irc: false
    What my chat looks like after I add the placeholder: http://prnt.sc/f7jtch
     
  3. So if that plugin use NMS to send json, everything will be alright isn't it?
     
  4. @_DMK_ Bracket placeholders in chat. % symbols have always broken chat formatting when not escaped.

    @NOBUTSS I've tested it a bunch, even /tellraw doesn't break my listener, but the SpigotAPI looks like it still can in some circumstances. It's honestly not something people use often... but I'll have to see how to at the very least ignore those messages so they don't error.
     
    • Like Like x 1
    • Useful Useful x 1
  5. Does the ignore feature work? I type /ignore <player> and it says you are now ignoring <player>. but they do not show on ignore list or does it stop them from chatting with you.

    thanks for the help
     
  6. @CDSquirrel Yes, it works. You're probably using the /ignore from Essentials or something along with my messaging commands. You can either disable commands from one plugin, or just alias in the config file. I do recommend using my messaging commands over the Essentials ones because they have some neat features like sound alerts.
     
  7. @Aust1n46

    Thanks for your reply. All that is good. I found the problem.

    bungeecordmessaging: true - ignore does not work
    bungeecordmessaging: false - ignore works just fin
    e

    I will set bungeecordmessaging: false for the time being. I am sure they will still complain, they always complain :)


    PS. I have been using your plugin forever, thanks for all you do. I have had so many chat workarounds over time for one thing or another that sometimes I just need to make sure the feature I am using still exists. keep up the good work CDSquirrel
     
    #5327 CDSquirrel, May 15, 2017
    Last edited: May 15, 2017
    • Like Like x 1
  8. Hi, is there a way to disable this plugin on a world? I have a plugin which handles it's own chat, and I would like it to do just that. Thanks.
     
  9. i got this problem at my bungeecord console and at my spigot one

    Bungeecord Version 1.11 :

    15:37:36 [WARNING] Error enabling plugin VentureChat
    java.lang.UnsupportedClassVersionError: mineverse/Aust1n46/chat/bungee/MineverseChatBungee : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at net.md_5.bungee.api.plugin.PluginClassloader.loadClass0(PluginClassloader.java:34)
    at net.md_5.bungee.api.plugin.PluginClassloader.loadClass(PluginClassloader.java:27)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at net.md_5.bungee.api.plugin.PluginManager.enablePlugin(PluginManager.java:304)
    at net.md_5.bungee.api.plugin.PluginManager.loadPlugins(PluginManager.java:212)
    at net.md_5.bungee.BungeeCord.start(BungeeCord.java:264)
    at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:55)
    at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)

    Spigot 1.9 linked with viaversion:

    [15:44:36 WARN]: org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: mineverse/Aust1n46/chat/MineverseChat : Unsupported major.minor version 52.0
    [15:44:36 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135)
    [15:44:36 WARN]: at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329)
    [15:44:36 WARN]: at com.rylinaux.plugman.util.PluginUtil.load(PluginUtil.java:356)
    [15:44:36 WARN]: at com.rylinaux.plugman.command.LoadCommand.execute(LoadCommand.java:114)
    [15:44:36 WARN]: at com.rylinaux.plugman.PlugManCommandHandler.onCommand(PlugManCommandHandler.java:95)
    [15:44:36 WARN]: at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [15:44:36 WARN]: at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141)
    [15:44:36 WARN]: at org.bukkit.craftbukkit.v1_9_R2.CraftServer.dispatchCommand(CraftServer.java:645)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.PlayerConnection.handleCommand(PlayerConnection.java:1349)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.PlayerConnection.a(PlayerConnection.java:1184)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.PacketPlayInChat.a(PacketPlayInChat.java:45)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.PacketPlayInChat.a(PacketPlayInChat.java:1)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.PlayerConnectionUtils$1.run(SourceFile:13)
    [15:44:36 WARN]: at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    [15:44:36 WARN]: at java.util.concurrent.FutureTask.run(Unknown Source)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.SystemUtils.a(SourceFile:45)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.MinecraftServer.D(MinecraftServer.java:726)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.DedicatedServer.D(DedicatedServer.java:399)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.MinecraftServer.C(MinecraftServer.java:665)
    [15:44:36 WARN]: at net.minecraft.server.v1_9_R2.MinecraftServer.run(MinecraftServer.java:564)
    [15:44:36 WARN]: at java.lang.Thread.run(Unknown Source)
    [15:44:36 WARN]: Caused by: java.lang.UnsupportedClassVersionError: mineverse/Aust1n46/chat/MineverseChat : Unsupported major.minor version 52.0
    [15:44:36 WARN]: at java.lang.ClassLoader.defineClass1(Native Method)
    [15:44:36 WARN]: at java.lang.ClassLoader.defineClass(Unknown Source)
    [15:44:36 WARN]: at java.security.SecureClassLoader.defineClass(Unknown Source)
    [15:44:36 WARN]: at java.net.URLClassLoader.defineClass(Unknown Source)
    [15:44:36 WARN]: at java.net.URLClassLoader.access$100(Unknown Source)
    [15:44:36 WARN]: at java.net.URLClassLoader$1.run(Unknown Source)
    [15:44:36 WARN]: at java.net.URLClassLoader$1.run(Unknown Source)
    [15:44:36 WARN]: at java.security.AccessController.doPrivileged(Native Method)
    [15:44:36 WARN]: at java.net.URLClassLoader.findClass(Unknown Source)
    [15:44:36 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)
    [15:44:36 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)
    [15:44:36 WARN]: at java.lang.ClassLoader.loadClass(Unknown Source)
    [15:44:36 WARN]: at java.lang.ClassLoader.loadClass(Unknown Source)
    [15:44:36 WARN]: at java.lang.Class.forName0(Native Method)
    [15:44:36 WARN]: at java.lang.Class.forName(Unknown Source)
    [15:44:36 WARN]: at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64)
    [15:44:36 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131)
    [15:44:36 WARN]: ... 20 more
     
  10. @XxSpearDogxX Use Pastebin instead of spamming the entire forum with some error spam. It says to do this right on the overview page. Update to at least Java 7... Google could've solved your issue on this one as this error happens on any Java program when you try to use an outdated version of it. I would use Java 8, but 7 should work too.
     
  11. Oh thenks! the problem was java 7!
     
  12. I changed my nick using essentials but in chat it did not change
    [​IMG]
     
  13. @Rhander Set modify displayname to true in the Essentials config I'm pr etty sure.
     
  14. I've been having an issue that doesn't allow me to have 2 people on the same ip talk in game, i don't see any errors show up in console so I'm not sure what is going on, i just got a new VPS and ever since that it has been doing it, it will work some times and then sometimes it does not



    -EDIT

    possibly solved with deleting all the player/bungeeplayer files in the plugin folder. :D
     
    #5334 Matt932, May 18, 2017
    Last edited: May 18, 2017
  15. Hi I'm new to VC and so far everything is going as I want it to but I'm trying to figure out why nothing happens when I whisper/msg someone. Nothing shows in console either. I have removed Essentialschat and not sure how to turn off essentials related chat configs but when I write any commands other than changing chat channels nothing happens. IE: /w Kisaki msg, /tell Kisaki msg etc nothing happens.

    edit:So I changed the alias in vc config to these commands and get spammed in console when someone tries to msg me:
    https://pastebin.com/t3ZGAwju
    Thanks for any help :D
    Forgot to add my configs:
    Here's my VC config: https://pastebin.com/LFa2kmXc
    and Essentials: https://pastebin.com/EaNWM732
     
    #5335 Kisaki, May 20, 2017
    Last edited: May 20, 2017
  16. ventureGUI is not working if there is {factions_name} placeholder in format. Hope you can fix this :D thanks in advanced.
     
  17. when i do /venturechat this happens https://pastebin.com/M8JGP1Mn

    and i can't chat on my lobby server nothing pops up in the console it just doesn't show anything i say in game the only thing i can do is /msg and other players can chat
     
  18. does your cpu usage goes up ?
     
  19. Hello! I have a feature request that I know isn't a small one -- join messages with bungee support. There are so few decent options for this, and the few there are aren't being updated anymore. Something configurable like "Player joined the network" and "player switched to/from another server" and "Player left the network". Ideally it would have vanish support or silent join/quit. Since a lot of other chat plugins have this built in it would definitely be useful here. Thanks for the consideration!
     
  20. not that i can tell and i can talk now idk why it didn't work happens sometimes
     

Share This Page