Spigot VentureChat 3.2.2

#1 Channels Chat plugin! Spigot + Bungee. Supports PlaceholderAPI + JSON formatting. New Hex Colors!

  1. @Daphsquid I’m looking into redoing the networking externally (not using plugin messaging channels). If you know of any plugins that work with Spigot, Bungee, and Viaversion let me know so I can check out how they’re doing it.
     
    • Like Like x 1
  2. Hello!

    My server running 1.12.2 is seeming to have troubles enabling VentureChat?
    It was working fine, and then my server rebooted and now it doesn't work at all. I updated to the latest version, and I was on 2.12.2 when the crash happened, there was no effect by updating. I also updated Vault + ProtocolLib.

    Logs Here
    https://hastebin.com/episurigol.css
     
  3. @Hexical_ Delete or move the data file (Players.yml) to somewhere else and try again.
     
    • Winner Winner x 1
  4. Thank you very much, worked like a charm!
     
  5. @Daphsquid We might be getting somewhere... I just posted this on the ViaVersion page.
     
  6. Aust1n46 updated VentureChat with a new update entry:

    VentureChat 2.14.0

    Read the rest of this update entry...
     
  7. Awesome, thanks for the update!
     
  8. @Daphsquid Hoprfully the patch I pushed last night is working for your server!
     
  9. Hi There, With regards to this issue - I am using LuckPerms, VentureChat, Towny, MarriageMaster & Craftconomy. I am trying to get prefixes to show in the normal chat as well as in the hover area.

    I see placeholders for these other plugins that have %marriagemaster_{Identifier}% for example. When I edit venturechat config it hates % and throws that out yet all placeholders seem to have this. I tried removing the % or even replacing them with just { and } however it is not being displayed at all.

    In chat: {towny} - works, {group} - works, cannot get marriagemaster to work.
    In hover: {towny} - NotWorking, {group} - NotWorking, marriagemaster - NotWorking.

    https://github.com/GeorgH93/MarriageMaster/wiki/Placeholders
     
  10. @Stager83 You need to use PlaceholderAPI (It's a requirement for VentureChat) but more importantly it's where all the Placeholders come from.

    And brackets are used for chat placeholders. That's also part of PlaceholderAPI.

    You also need to download the placeholders for PlaceholderAPI.

    /papi ecloud download [plugin name]

    /papi reload
     
  11. Okay great going to give it a try now.
    One more thing /msg is not working for my players and I do not see a perm for it. Thanks for replying on Christmas day that is incredible!!

    UPDATE: So I already had PlaceHolderAPI installed, I then downloaded the placeholders for marriagemaster, it downloaded them and I reload PAPI. Was there other placeholders I was supposed to download? I put the below into format maybe I have the syntax wrong?

    format: '&f[&2G&f] {group} %marriagemaster_{Heart}% {nickname} &2»'
     
    #6531 Stager83, Dec 25, 2018
    Last edited: Dec 25, 2018
  12. @Stager83 Disable BungeeCord messaging if you're not using BungeeCord...

    You need to use bracket placeholders... no %% anywhere...
     
  13. Hey, any idea why Venturechat might say in console 'Enabled successfully' but then the very next line say 'Error enabling venturechat; are you sure it is up to date? I have downloaded the most recent version and it works just fine on my other servers connected with bungeecord, but on this server it does not enable correctly and we haven't changed anything major.

    Nevermind I followed your instructions deleted players.yml and it works, thanks!
     
    #6533 mewtong, Dec 27, 2018
    Last edited: Dec 27, 2018
  14. Hi! I love your plugin it's amazing the control you get over the flow of chat :)

    Only one issue for me, i use LuckPerms for my prefixes and have the prefixes set up to display multiple on different tracks as so:
    Code (Text):
    meta-formatting:
      prefix:
        format:
          - "highest_on_track_donor"
          - "highest_on_track_timed"
        start-spacer: "["
        middle-spacer: "|"
        end-spacer: "]"
      suffix:
        format:
          - "highest"
        start-spacer: ""
        middle-spacer: " "
        end-spacer: ""
    if i do this, the first to say anything in chat, gets his message repeated every time he or anybody else says anything in chat at all. Example:
    [​IMG]
    In that image I'm typing different messages each time. if i instead replace the "|" sign (it works as a nice spacer) with an exclamationmark like so:
    Code (Text):
    meta-formatting:
      prefix:
        format:
          - "highest_on_track_donor"
          - "highest_on_track_timed"
        start-spacer: "["
        middle-spacer: "!"
        end-spacer: "]"
      suffix:
        format:
          - "highest"
        start-spacer: ""
        middle-spacer: " "
        end-spacer: ""
    Then everything works just fine, just looks not as good, so I think something somewhere along the line breaks when you use the | sign, any ideas?
     
  15. @Demigoz It's either not a valid character or it's not escaped properly. VentureChat uses Vault and PlaceholderAPI to handle prefixes and suffixes.
     
  16. I just released a fun little plugin from our server's private plugin library!

    AustinTheEnchanter! A 1.13 port of the classic TimTheEnchanter plugin. I usually don't release any plugins from our server, but this one brings back good memories of the "good ole days"
     
  17. I'm trying to use the json text formatting. Everyone should display the same, so I am just using the default.

    Here's the relevant config setting:

    Code (YAML):
    hover_name:
    - '%player_name%'
    I have PlaceholderAPI installed and I have the player plugin for it installed. The expected behavior is that when someone mouses over a user's nickname, it should show them their real name. However, what happens instead is when they hover over the name, the following appears:

    upload_2018-12-31_1-18-42.png

    This was also observed to be the case when I had been using `{player_name}` in the config. Do you know why it's trimming the first two characters from the config item?
     
    • Agree Agree x 1
  18. I am also struggling with placeholders in the hover
     
  19. @Foxtrek_64 No where does it say to use %%. I explicitly state to always use bracket placeholders. Use a color code in the beginning to set the color. '&f' is white.

    @Stager83 Try and follow the examples in the config. Test your changes before you edit the entire config and all of a sudden it doesn't work... Every copy of the plugin ships with a working default config.