Spigot VentureChat 3.2.2

#1 Channels Chat plugin! Spigot + Bungee. Supports PlaceholderAPI + JSON formatting. New Hex Colors!

  1. @Daxxas It has to be another plugin mate... We use VentureChat on our live server and there's no double messages.

    @Stager83 Are you sure you're using VentureChat messaging? That doesn't happen on our server.
     
  2. I have a question..

    I'm trying to utilize this in a RPG server. I have it set up where /l (the default) is local chat, and at a limited radius, which works fine.
    I also have the obligatory /g (global) and /t (trade) channels, marked by color and of course global across server.
    Everything works. I hit enter, type a msg it's in local.
    I hit /g <msg here> if goes to the global 'channel' seen across the server. Yeah!
    The problem I have, is how to prevent people from hitting /g <enter> and setting channel to the global?
    The permission - ^venturechat.setchannel is not working, and allows users to switch channel anyhow. Also tried - ^venturechat.setchannel.g and - ^venturechat.setchannel.group.

    I can assign a permission within venturechat config directly with the permission node, and THEN a user cannot /g to join the channel, but they also can't SEND a message /g <msg> either!!

    How do I set this up correctly, or is something broken, or just not able to be done with this plugin?
     
  3. @Rooster There's no way to do that. And /setchannel is an admin command... I would take that perm away before players figure out they can change other players channels... :oops:

    You can set a cooldown for the global channel if you don't want people to over use it. Admins can bypass that of course!
     
  4. Alrighty, thanks for for info.
     
  5. @Rooster I'm sure you could accomplish what you want with some custom aliases, but it's just too much of a niche feature to have in the plugin by default.
     
  6. @regancali So I have a sample working, but I wanted some feedback. When the channel posts it's message to the web map, should the player prefix and name show up? If so, the players name is repeated twice:
    [​IMG]
    Or should just the text "test global map" show up?

    Everything else works fine! Just need to hook it up so it will work with BungeeCord, but other than that, it's almost finished.

    Edit: Some bad news actually... After some in depth thought, I really can't think of an easy way to get the map working for BungeeCord channels, especially if you have a different map of each server.

    Would be very difficult to relay all the messages without creating an infinite loop... the system was really designed for a recipient server to be the end of the connection; at least for chat.

    If you could PM me your server IP and show me some in game examples, it would help a lot!
     
    #6566 Aust1n46, Jan 6, 2019
    Last edited: Jan 6, 2019
  7. Is it possible to hide the message in the chat that you do not have permissions of any plugin?
     
  8. Short and simple question: Is there a way to submit to a channel without being joined? for example, sending a message to a channel from the server console or simply allowing admins to send to other channels without actually having to be joined to those channels.
     
  9. @PockyMonstrosity The terms commonly used with channels chat plugins are "listening" and "focused".

    So I'll answer using what I know to avoid confusion. If you are listening to a channel, you can see the messages sent in that channel. If you are focused in a channel, whatever you type goes into that channel.

    VentureChat has "quick chat" commands that allow sending messages to channels you're listening to, but not focused in. /g [message] will send a message into the global channel without you having to focus in the channel.

    You can only be focused in one channel at a time. You can listen to every channel at the same time (assuming you have permissions for every channel)

    @Punishkey I don't understand what you mean? VentureChat doesn't edit the messages of other plugins.
     
  10. I mean that if it is possible to silence in the chat the messages of "you do not have permissions" of the plugins. or if it is possible to pass those messages through another channel
     
  11. @Punishkey I'm still not following you... Silence the messages from what plugin? From VentureChat? Permissions messages are sent directly to the player.. not into a channel.
     
  12. ok!!, I did not know exactly what was not controlled by the chat. sorry :)
     
  13. I think dymap actually adds the user name to the map based on vault permissions there are flags in the config file, so I would not worry about that, and the bungeecord redirect is not that important just being able to have the bungee global chat send to dynmap helps a lot.
     
  14. Hi, after further testing, the double messages seems to be because we are talking in a bungeecord channel : https://imgur.com/a/SD6Y3e0
    The problem looks to be there ONLY when there is 2 players in the same spigot server, only the players in the same spigot server see the messages in double, the other players who are on other servers, (but in still the network) see the messages from the other players in the network channel as they should (there's no double messages for them)

    Here's the config : https://hastebin.com/ohozejubor.php (I kept the default channels)
     
    #6574 Daxxas, Jan 7, 2019
    Last edited: Jan 7, 2019
  15. @regancali I changed it to only send the actual chat messages to the map and not include the formatting from in game.

    And I’ll publish the add on and let you take a look at it and try it out. Once we get our dynmap figured out I’ll be using the add on on our live network as well!

    @Daxxas Whitelist “Aust1n46_Legacy” as well so I can test it myself. That’s another account of mine I use for testing on Bungee.

    And I’d like console screenshots. Is it printing twice in the console?

    Only thing I can think of is you have a plugin that’s uncancelling the chat event after I cancel it. That would cause a double message only on the sending server. Because the Bungee redirects the message to ALL servers including the senders server. So therefore, I cancel the chat event on the sending server so nothing comes through. If this event were somehow uncancelled, you would get two messages.
     
  16. After changing the values back and adding a color code, things started working again.

    As a follow-up question, is there a way with the built-in nick function to support names with spaces?

    upload_2019-1-8_4-27-37.png

    I've tried surrounding the name in quotes, but it seems to stop parsing after the first word.
     
    #6576 Foxtrek_64, Jan 8, 2019
    Last edited: Jan 8, 2019
  17. I've added the account, to the whitelist, you should be able to do /server IkkaLab and /server MainServer too so you can switch between 2 servers to test if needed :)

    EDIT: I've tested, and the console have the duplicated messages :

    Code (Text):

    21:36:19 [INFOS] MainServer > [Network] ✯Fondateur aDaxxas: test
    21:36:19 [INFOS] MainServer > [Network] ✯Fondateur aDaxxas: test
     
     
    #6577 Daxxas, Jan 8, 2019
    Last edited: Jan 8, 2019
  18. After looking at the command source code, it doesn't seem this is possible. You have it hard-coded for exactly one entry and you're basing the nick-self vs nick-other off of the count of arguments. Adding functionality would require a rebuild of the command.

    If you ever do this though, there are a few suggestions I have:

    1. /nick user name isn't always nicknaming another person. If I have permission to provide nicknames to myself, I should be able to use /nick Foxtrek_64 John and it should successfully apply a nickname to myself, however using /nick Notch John should throw an error since I don't have the appropriate permission to nick others.
    2. /nick long display name should perform a lookup for long against the list of online players. If none is found, that is counted as part of the new nickname.

      That said, to avoid frustrations, it should be limited to exact matches. I've run into a few places where I've typed /nick John Doe and it's come back and said You've changed Johnson's name to Doe. With the 1.13 suggestion system, exact names shouldn't be too bad, since you can type the first few letters and then press tab to auto-fill.
     
  19. @Foxtrek_64 Not trying to sound dismissive at all here. But the VentureChat nickname command was never intended to be very “advanced” if you will. It was designed to simply allow admins to change nicknames in chat because VentureChat can display them from other plugins. I figured I’d just toss in a simple nick command of my own.

    The original design plan was to have my nick commands overridden by other nick plugins (and they are). If you find that there are no good nickname plugins for 1.13 let me know and I’ll look into designing my own and releasing it as a separate plugin.

    Just wanted to reiterate again that I’m not trying to sound dismissive and I really do appreciate people looking for improvements in the plugins!
     
    • Like Like x 1
  20. For some reason this one account named "cisnet" chat doesnt work for it. I have no idea. I have reset the plugin so many times. Out of 100+ players the user (my account) cisnet cannot send a message. It shows nothing. Just ramps up my ram usage. All my other accounts work. No one is muted.

    I decided to try to sudo my cisnet account to chat which didnt work then got this huge error.

    Code (Text):
     --- DO NOT REPORT THIS TO PAPER - THIS IS NOT A BUG OR A CRASH - git-Paper-497 (MC: 1.13.2) ---
    [04:33:52 ERROR]: The server has not responded for 10 seconds! Creating thread dump
    [04:33:52 ERROR]: ------------------------------
    [04:33:52 ERROR]: Server thread dump (Look for plugins here before reporting to Paper!):
    [04:33:52 ERROR]: ------------------------------
    [04:33:52 ERROR]: Current Thread: Server thread
    [04:33:52 ERROR]: PID: 25 | Suspended: false | Native: false | State: RUNNABLE
    [04:33:52 ERROR]: Stack:
    [04:33:52 ERROR]: java.lang.StringBuilder.append(StringBuilder.java:136)
    [04:33:52 ERROR]: mineverse.Aust1n46.chat.utilities.Format.convertPlaceholders(Format.java:139)
    [04:33:52 ERROR]: mineverse.Aust1n46.chat.utilities.Format.convertToJson(Format.java:110)
    [04:33:52 ERROR]: mineverse.Aust1n46.chat.listeners.ChatListener.onAsyncPlayerChatEvent(ChatListener.java:690)
    [04:33:52 ERROR]: com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor302.execute(Unknown Source)
    [04:33:52 ERROR]: org.bukkit.plugin.EventExecutor$2.execute(EventExecutor.java:70)
    [04:33:52 ERROR]: co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:78)
    [04:33:52 ERROR]: org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    [04:33:52 ERROR]: org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:513)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnection.chat(PlayerConnection.java:1703)
    [04:33:52 ERROR]: org.bukkit.craftbukkit.v1_13_R2.entity.CraftPlayer.chat(CraftPlayer.java:443)
    [04:33:52 ERROR]: com.Zrips.CMI.commands.list.sudo.perform(sudo.java:54)
    [04:33:52 ERROR]: com.Zrips.CMI.commands.CommandsHandler.onCommand(CommandsHandler.java:248)
    [04:33:52 ERROR]: org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [04:33:52 ERROR]: org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149)
    [04:33:52 ERROR]: org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:732)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnection.handleCommand(PlayerConnection.java:1790)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:1598)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:45)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:5)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:13)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnectionUtils$$Lambda$2595/1717410598.run(Unknown Source)
    [04:33:52 ERROR]: java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    [04:33:52 ERROR]: java.util.concurrent.FutureTask.run(FutureTask.java:266)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.SystemUtils.a(SystemUtils.java:108)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1011)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:938)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:836)
    [04:33:52 ERROR]: java.lang.Thread.run(Thread.java:748)

    EDIT: Updated protocollib to the latest and the issue seems gone?
     
    #6580 Cisnet, Jan 10, 2019
    Last edited: Jan 10, 2019