Bukkit VentureChat 2.14.0

#1 Channels Chat plugin! Spigot + Bungee. Supports PlaceholderAPI + JSON formatting. Moderation GUI!

  1. ok!!, I did not know exactly what was not controlled by the chat. sorry :)
     
  2. I think dymap actually adds the user name to the map based on vault permissions there are flags in the config file, so I would not worry about that, and the bungeecord redirect is not that important just being able to have the bungee global chat send to dynmap helps a lot.
     
  3. Hi, after further testing, the double messages seems to be because we are talking in a bungeecord channel : https://imgur.com/a/SD6Y3e0
    The problem looks to be there ONLY when there is 2 players in the same spigot server, only the players in the same spigot server see the messages in double, the other players who are on other servers, (but in still the network) see the messages from the other players in the network channel as they should (there's no double messages for them)

    Here's the config : https://hastebin.com/ohozejubor.php (I kept the default channels)
     
    #6583 Daxxas, Jan 7, 2019
    Last edited: Jan 7, 2019
  4. @regancali I changed it to only send the actual chat messages to the map and not include the formatting from in game.

    And I’ll publish the add on and let you take a look at it and try it out. Once we get our dynmap figured out I’ll be using the add on on our live network as well!

    @Daxxas Whitelist “Aust1n46_Legacy” as well so I can test it myself. That’s another account of mine I use for testing on Bungee.

    And I’d like console screenshots. Is it printing twice in the console?

    Only thing I can think of is you have a plugin that’s uncancelling the chat event after I cancel it. That would cause a double message only on the sending server. Because the Bungee redirects the message to ALL servers including the senders server. So therefore, I cancel the chat event on the sending server so nothing comes through. If this event were somehow uncancelled, you would get two messages.
     
  5. After changing the values back and adding a color code, things started working again.

    As a follow-up question, is there a way with the built-in nick function to support names with spaces?

    upload_2019-1-8_4-27-37.png

    I've tried surrounding the name in quotes, but it seems to stop parsing after the first word.
     
    #6585 Foxtrek_64, Jan 8, 2019
    Last edited: Jan 8, 2019
  6. I've added the account, to the whitelist, you should be able to do /server IkkaLab and /server MainServer too so you can switch between 2 servers to test if needed :)

    EDIT: I've tested, and the console have the duplicated messages :

    Code (Text):

    21:36:19 [INFOS] MainServer > [Network] ✯Fondateur aDaxxas: test
    21:36:19 [INFOS] MainServer > [Network] ✯Fondateur aDaxxas: test
     
     
    #6586 Daxxas, Jan 8, 2019
    Last edited: Jan 8, 2019
  7. After looking at the command source code, it doesn't seem this is possible. You have it hard-coded for exactly one entry and you're basing the nick-self vs nick-other off of the count of arguments. Adding functionality would require a rebuild of the command.

    If you ever do this though, there are a few suggestions I have:

    1. /nick user name isn't always nicknaming another person. If I have permission to provide nicknames to myself, I should be able to use /nick Foxtrek_64 John and it should successfully apply a nickname to myself, however using /nick Notch John should throw an error since I don't have the appropriate permission to nick others.
    2. /nick long display name should perform a lookup for long against the list of online players. If none is found, that is counted as part of the new nickname.

      That said, to avoid frustrations, it should be limited to exact matches. I've run into a few places where I've typed /nick John Doe and it's come back and said You've changed Johnson's name to Doe. With the 1.13 suggestion system, exact names shouldn't be too bad, since you can type the first few letters and then press tab to auto-fill.
     
  8. @Foxtrek_64 Not trying to sound dismissive at all here. But the VentureChat nickname command was never intended to be very “advanced” if you will. It was designed to simply allow admins to change nicknames in chat because VentureChat can display them from other plugins. I figured I’d just toss in a simple nick command of my own.

    The original design plan was to have my nick commands overridden by other nick plugins (and they are). If you find that there are no good nickname plugins for 1.13 let me know and I’ll look into designing my own and releasing it as a separate plugin.

    Just wanted to reiterate again that I’m not trying to sound dismissive and I really do appreciate people looking for improvements in the plugins!
     
    • Like Like x 1
  9. For some reason this one account named "cisnet" chat doesnt work for it. I have no idea. I have reset the plugin so many times. Out of 100+ players the user (my account) cisnet cannot send a message. It shows nothing. Just ramps up my ram usage. All my other accounts work. No one is muted.

    I decided to try to sudo my cisnet account to chat which didnt work then got this huge error.

    Code (Text):
     --- DO NOT REPORT THIS TO PAPER - THIS IS NOT A BUG OR A CRASH - git-Paper-497 (MC: 1.13.2) ---
    [04:33:52 ERROR]: The server has not responded for 10 seconds! Creating thread dump
    [04:33:52 ERROR]: ------------------------------
    [04:33:52 ERROR]: Server thread dump (Look for plugins here before reporting to Paper!):
    [04:33:52 ERROR]: ------------------------------
    [04:33:52 ERROR]: Current Thread: Server thread
    [04:33:52 ERROR]: PID: 25 | Suspended: false | Native: false | State: RUNNABLE
    [04:33:52 ERROR]: Stack:
    [04:33:52 ERROR]: java.lang.StringBuilder.append(StringBuilder.java:136)
    [04:33:52 ERROR]: mineverse.Aust1n46.chat.utilities.Format.convertPlaceholders(Format.java:139)
    [04:33:52 ERROR]: mineverse.Aust1n46.chat.utilities.Format.convertToJson(Format.java:110)
    [04:33:52 ERROR]: mineverse.Aust1n46.chat.listeners.ChatListener.onAsyncPlayerChatEvent(ChatListener.java:690)
    [04:33:52 ERROR]: com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor302.execute(Unknown Source)
    [04:33:52 ERROR]: org.bukkit.plugin.EventExecutor$2.execute(EventExecutor.java:70)
    [04:33:52 ERROR]: co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:78)
    [04:33:52 ERROR]: org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    [04:33:52 ERROR]: org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:513)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnection.chat(PlayerConnection.java:1703)
    [04:33:52 ERROR]: org.bukkit.craftbukkit.v1_13_R2.entity.CraftPlayer.chat(CraftPlayer.java:443)
    [04:33:52 ERROR]: com.Zrips.CMI.commands.list.sudo.perform(sudo.java:54)
    [04:33:52 ERROR]: com.Zrips.CMI.commands.CommandsHandler.onCommand(CommandsHandler.java:248)
    [04:33:52 ERROR]: org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [04:33:52 ERROR]: org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149)
    [04:33:52 ERROR]: org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:732)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnection.handleCommand(PlayerConnection.java:1790)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:1598)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:45)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:5)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:13)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.PlayerConnectionUtils$$Lambda$2595/1717410598.run(Unknown Source)
    [04:33:52 ERROR]: java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    [04:33:52 ERROR]: java.util.concurrent.FutureTask.run(FutureTask.java:266)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.SystemUtils.a(SystemUtils.java:108)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1011)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:938)
    [04:33:52 ERROR]: net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:836)
    [04:33:52 ERROR]: java.lang.Thread.run(Thread.java:748)

    EDIT: Updated protocollib to the latest and the issue seems gone?
     
    #6589 Cisnet, Jan 10, 2019 at 9:37 AM
    Last edited: Jan 10, 2019 at 11:27 PM
  10. Question. Can I set up my Local CHannels(Local, Shout, Quiet and Whisper) to allow Roleplay Formatting? Like Text within ** is yellow and appears as an emote, and text within "" appears as a character speaking?
    If not, could I pay you to add this into an extension plugin?
     
  11. Does this plugin work with deluxe tags plugin? I cant seem to make it work. {deluxetags_tag} putting this in the chat formatting, and it still doesnt work. :/
     
  12. Good times, I was wondering how he could get the "aliases" from the commands, these give me trouble when writing other commands...
     
  13. None of the ones I found allowed spaces in names, so I ended up rolling my own as a stand-alone plugin. I wouldn't mind releasing the command class to you so that you can roll it in to VentureChat. If anything, it may give you a few ideas. All of the messages are hard-coded, so if you use any of my code, you may want to move those out to a config file somewhere. Otherwise, I may just release my nick plugin here.
     
  14. @Foxtrek_64 I'd imagine that's because Mojang usernames can't have spaces. So most if not all plugins just used those same conventions for their nicknames. Most plugins won't be able to match a nickname with a space in it, just letting you know.

    @vcmda You're going to have to rephrase. I don't understand what you're asking.

    @Sinhus I've heard it does. You just need to download the placeholder pack for DeluxeTags.
    /papi ecloud download DeluxeTags
    /papi reload

    @Flugal You can setup channels with different distances for role playing servers, but there's no way to "trigger" a message to go into a channel with like ** or something.

    You can PM me the details and I can try to make an extension. I've been playing around with making it easier to make extensions for VentureChat recently so it would be a good exercise.

    @Cisnet Probably something along those lines. Whenever I see an error with JSON, it's probably something to do with a ProtocolLib update.
     
  15. Hey, did you had time to see for my problem ? The messages are duplicated in the console too :(
     
  16. @Daxxas I did see it, but I was away from my computer all week. Since they are duplicated in the console, it's not what I expected it could be. Is there by any chance that you have two copies of VentureChat installed...? with different jar names?

    @regancali I'll push out that plugin for ya, don't worry, I didn't forget.
     
  17. Hey @Aust1n46 sorry but I just tried my "cisnet" account again and cant talk in the chat, but it detects spam if I spam on it. Is there any way to enable a debugging mode in venture chat? I enabled it with protocollib but dont see anything

    EDIT: found the debugging mode. All I see so far is

    Enabling PlaceholderAPI Hook
    [18:07:26 INFO]: [VentureChat] - Placeholders were not added to PlaceholderAPI!


    But I have placeholderapi working?

    EDIT:

    I found why my cisnet account cant talk in chat! I have no idea what this means or why since my prefix and suffix work? At least they do on my other accounts. I am recieving this message every time I enter a message!


    [18:08:40 INFO]: [VentureChat] - Prefix and / or suffix don't exist, setting to nothing.
    [18:08:46 INFO]: [VentureChat] - Prefix and / or suffix don't exist, setting to nothing.


    The problem is I don't know how to fix this. I cleared all permissions with luckperms, and removed all suffix's and prefix's


    ----------------------------------------------------------------------------------------------------------------------

    I cleared out my different channels and left global. I also removed my placeholders for suffix's and prefix's then reloaded venturechat. Received the error below:

    Code (Text):
     [18:14:14 WARN]: [VentureChat] Task #17966 for VentureChat v2.14.0 generated an exception
    java.lang.NullPointerException: null
    at mineverse.Aust1n46.chat.database.PlayerData.savePlayerData(PlayerData.java:74) ~[?:?]
    at mineverse.Aust1n46.chat.MineverseChat$1.run(MineverseChat.java:477) ~[?:?]
    at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftTask.run(CraftTask.java:82) ~[patched_1.13.2.jar:git-Paper-497]
    at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:449) ~[patched_1.13.2.jar:git-Paper-497]
    at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1003) ~[patched_1.13.2.jar:git-Paper-497]
    at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439) ~[patched_1.13.2.jar:git-Paper-497]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:938) ~[patched_1.13.2.jar:git-Paper-497]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:836) ~[patched_1.13.2.jar:git-Paper-497]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]
    [18:14:15 INFO]: ["",{"text":"","extra":[{"text":"","color":"white"},{"text":"TCC","color":"white","clickEvent":{"action":"suggest_command","value":"/msg TCC"},"hoverEvent":{"action":"show_text","value":{"text":"","extra":[{"text":"","color":"dark_red"},{"text":"Administrator{suffix}
    [18:14:15 INFO]: ","color":"dark_red","bold":"true"},{"text":"Town: ","color":"green"},{"text":"{mvdw_towny_town_name}
    [18:14:15 INFO]:
    [18:14:15 INFO]: ","color":"green"},{"text":"Rank: ","color":"gray"},{"text":"","color":"gray"},{"text":"Wanderer
    [18:14:15 INFO]: ","color":"gray","bold":"true"},{"text":"Rank Progress: ","color":"gray"},{"text":"10.0%
    [18:14:15 INFO]: ","color":"white"},{"text":"Blocks Mined: ","color":"gray"},{"text":"0
    [18:14:15 INFO]: ","color":"dark_purple"},{"text":"Gem Balance: ","color":"gray"},{"text":"Ⓖ1k
    [18:14:15 INFO]: ","color":"green"},{"text":"Ping: ","color":"gray"},{"text":"79","color":"dark_purple"},{"text":"ms","color":"gray"}]}}},{"text":" ","color":"white"},{"text":"","color":"dark_gray"},{"text":"»","color":"dark_gray","bold":"true"},{"text":"","color":"white"}]},{"text":"","color":"white"},{"text":" dfa","color":"white"}]
    [18:14:15 INFO]: END OF JSON
    [18:14:15 INFO]: END OF JSON
    [18:14:15 INFO]: END OF JSON
    [18:14:15 INFO]: END OF JSON
    [18:14:15 INFO]: END OF JSON
    [18:14:15 INFO]: 82 size bytes without json
    [18:14:15 INFO]: 1112 bytes size with json
    [18:14:15 INFO]: 1111 size on receiving end
    [18:14:15 INFO]: TCC » dfa
    [18:14:18 INFO]: [VentureChat] - Prefix and / or suffix don't exist, setting to nothing.



    Here is more information of when I join with the account TCC chat works and updates. When I join with Cisnet it shows the prefix error for everytime I type.

    Code (Text):
     [18:23:21 INFO]: [VentureChat] - Received update...
    [18:23:28 INFO]: ["",{"text":"","extra":[{"text":"","color":"white"},{"text":"TCC","color":"white","clickEvent":{"action":"suggest_command","value":"/msg TCC"},"hoverEvent":{"action":"show_text","value":{"text":"","extra":[{"text":"","color":"dark_red"},{"text":"Administrator{suffix}
    [18:23:28 INFO]: ","color":"dark_red","bold":"true"},{"text":"Town: ","color":"green"},{"text":"{mvdw_towny_town_name}
    [18:23:28 INFO]:
    [18:23:28 INFO]: ","color":"green"},{"text":"Rank: ","color":"gray"},{"text":"","color":"gray"},{"text":"Wanderer
    [18:23:28 INFO]: ","color":"gray","bold":"true"},{"text":"Rank Progress: ","color":"gray"},{"text":"10.0%
    [18:23:28 INFO]: ","color":"white"},{"text":"Blocks Mined: ","color":"gray"},{"text":"0
    [18:23:28 INFO]: ","color":"dark_purple"},{"text":"Gem Balance: ","color":"gray"},{"text":"Ⓖ1k
    [18:23:28 INFO]: ","color":"green"},{"text":"Ping: ","color":"gray"},{"text":"0","color":"dark_purple"},{"text":"ms","color":"gray"}]}}},{"text":" ","color":"white"},{"text":"","color":"dark_gray"},{"text":"»","color":"dark_gray","bold":"true"},{"text":"","color":"white"}]},{"text":"","color":"white"},{"text":" adf","color":"white"}]
    [18:23:28 INFO]: END OF JSON
    [18:23:28 INFO]: END OF JSON
    [18:23:28 INFO]: END OF JSON
    [18:23:28 INFO]: END OF JSON
    [18:23:28 INFO]: END OF JSON
    [18:23:28 INFO]: 82 size bytes without json
    [18:23:28 INFO]: 1111 bytes size with json
    [18:23:28 INFO]: 1110 size on receiving end
    [18:23:28 INFO]: TCC » adf
    [18:23:52 INFO]: UUID of player Cisnet is 707b0597-8610-47b4-a588-b8b29d9b16ae
    [18:23:52 INFO]: Cisnet[/96.48.233.229:54162] logged in with entity id 3442 at ([spawnworld]-1993.312812334983, 81.0, -1711.5489344340126)
    [18:23:52 INFO]: 71 size on receiving end
    [18:23:52 INFO]: [VentureChat] - Received update...
    [18:23:56 INFO]: [VentureChat] - Prefix and / or suffix don't exist, setting to nothing. <-- Cisnet
    [18:23:58 INFO]: [VentureChat] - Prefix and / or suffix don't exist, setting to nothing. <-- Cisnet
    [18:24:06 INFO]: [VentureChat] - Prefix and / or suffix don't exist, setting to nothing. <-- Cisnet

    Last update:

    I rebooted a few times randomly and now the cisnet account can talk once again. It does not show the prefix error. ??? Not too sure what is going on here.
     
    #6597 Cisnet, Jan 12, 2019 at 11:00 PM
    Last edited: Jan 12, 2019 at 11:30 PM
  18. Well there's 1 copy on every spigot server and 1 copy on the bungee server, but I don't have any duplicated jar in folders :(
    But it's really weird since it's only duplicating when there's more than 2 players connected, if I'm alone, the messages are sent normally with no problem
     
  19. @Cisnet You have two copies of your player data in the data file. This can happen if you run the server in both online mode and offline mode. Just delete the file or you can try and search for the duplicate entry.
     
    • Like Like x 1
  20. are you working on ConfigAssist? and what's the CapeListener?
     

Share This Page