Spigot VentureChat 3.2.2

#1 Channels Chat plugin! Spigot + Bungee. Supports PlaceholderAPI + JSON formatting. New Hex Colors!

  1. Hi,
    What i expected to see
    My server is running in offline mode which means cracked players can also join the server. Therefor if a player buys minecraft he obviously wants to use the same account he already had on the server. The point now is when he tries to connect with almost the same username something is getting messed up and he can't write anything in the chat. All that i can notice is that the cpu usage is going up to almost 100% on all cores.
    Maybe i should state that i got a bungeecord network. The behaviour occurs on one server of the network once he logged in and tries to chat. If i kill that server and let it start again, the cpu usage seems to stay fine.

    What i actually saw
    So in detail this happened:
    Player aka "test" is a cracked user that plays on my network.
    Now he decides to buy minecraft and thought of the idea to name him "TesT" as an example.
    Then he tries to get into the network again and firstly all seems fine until he tries to send a message into the chat.
    Only way to resolve that issue was to complete remove both users from the database and registering only one them again.

    Steps to reproduce
    Using a cracked account that sound very similiar like a premium minecraft account.
    The cracked account should have played some time on the server to gain data about him.
    Cracked user logs out and premium user logs in. Observe the incoming cpu load.

    I dont have much to attach because i couldn't get online in time to capture timings as it happened. Best i can give is this timings where it was like an hour into it.
    https://timings.aikar.co/?id=5fc919a331d74d4fbcdceb91b4e73294
    The version of Venturechat is not the latest. Indeed it is 2.17.2
    Did someone else encounter that issue with that version?
     
  2. @sinni1997
    Cracked servers are not officially supported. But plenty of people still use VentureChat on them.

    There's nothing in that timings report that has ANYTHING to do with VentureChat... You can literally look per plugin.

    There's no concept of a username being "close". This isn't horseshoes or hand grenades. 'test' and 'TesT' generate two different offline UUID's, and thus are different. And now you have two players in the data file with different UUID's and the same username case insensitive, which is something that can never happen on a standard server.

    Not much I can do for you because like I said above, the plugin is designed to support online authenticated servers. But your example sounds like an extreme edge case to me... not something that would happen often if at all. Every time I played on an offline mode server, I always used real player account usernames with a skin I liked, or a cape I didn't have on my personal account.

    If you can provide more information, maybe I can provide additional help. But with just "he can't chat", there isn't much I can do unfortunately.

    @aholl575 If you're using Essentials, it has a monopoly over the command. Either use /enick or make an alias /nick -> /enick. You can also edit the Essentials config to allow other plugins to change display names if you desire to use my command.
     
  3. We have just switched chat systems to yours and it is working amazingly, congrats on the plugin!

    We have been having issues with the placeholders, how can we use SimpleClan and marry placeholders on the chat for example? To show if someone is married and to show their clan.

    Also is there any way we can register aliases for channel, such as /g, so it appears tab completed and not red?

    Thank you for your attention

    UPDATE:

    I get this error for some reason when reloading the plugin. (Or starting it)
    [10:06:39 INFO]: [VentureChat] - Disabling...
    [10:06:39 INFO]: [VentureChat] - Disabled Successfully
    [10:06:40 INFO]: [VentureChat] Enabling VentureChat v2.18.4
    [10:06:40 INFO]: [VentureChat] - Initializing...
    [10:06:40 INFO]: [VentureChat] - Config found! Loading file.
    [10:06:40 INFO]: [VentureChat] - Checking for Vault...
    [10:06:40 INFO]: [VentureChat] - Enabled Successfully
    [10:06:40 INFO]: [VentureChat] - Registering Listeners
    [10:06:40 INFO]: [VentureChat] - Attaching to Executors
    [10:06:40 INFO]: [VentureChat] - Establishing BungeeCord
    [10:06:40 INFO]: [VentureChat] - Enabling PlaceholderAPI Hook
    [10:06:40 INFO]: [VentureChat] - Placeholders were not added to PlaceholderAPI!
    [10:06:40 INFO]: [VentureChat] - Loading player data
     
    #7763 dandan220, May 1, 2020
    Last edited: May 1, 2020
  4. Thanks for your help anyway @Aust1n46
    I could not find anything that is related to VentureChat except that messages he types in chat arent displayed and neither shown in console.
    I can't even find something else that that would lead me to suspect something. May i can give more information about my setup iam using.
    So i do use bungeecord to link all my servers together as i stated before and to share and logg all the messages over the network i setup the mysql database appropiately.
    Only thing i can suspect too is that the player "test" saved in the database is the same as the player "TesT" and therefore something breaks inside since i can only fix the issue when iam purging all data in the database of both players. But you also said that both players don't share the same UUID which seems now to be even more strange except venturechat or other plugins store the "normal" name instead of the UUID.
    Even more strange is that the player can do almost everything else than chatting with others. One thing the players noticed is that if they invited him to their island for example it responded that the player isn't even online. Instead /tpa did work.
    I am not quite sure what informations i should provide you more. What would help you the most?
     
  5. @sinni1997 To be totally honest with you, I would just correct the data file and remove the old data for this player and just let it be. Doesn't seem like something that would happen very often..

    @AthenaDev Yeah I fixed it a little while ago, I just never released it. Was going to combine it with a bigger update but I got caught up with some school work. I'll try to get it out soon. If not, I can send you a jar on Discord or something. Thanks for your patience.
     
    • Like Like x 1
  6. venturechat.party permission doesn't seem to be working for me
     
  7. Placeholders were not added to PlaceholderAPI!
    how to solve this, I'm sure I have installed papi
     
  8. @LikeWind What is there to solve... if you reload the plugin you will see that message. They can only be loaded once. The message doesn't really mean anything.

    If you're not seeing placeholders, you need to download the expansion packs.

    /papi ecloud download [plugin name]
    /papi ecloud download Player
    /papi reload

    @NEMO_CZ There are child permissions for the individual party components that you also need.
     
    • Informative Informative x 1
  9. well , i reload the plugin,I thought this was a mistake
     
  10. @Aust1n46 i did some more research since it appeared again with the same user and i found the reason why the cpu load raised up together with the player cannot chat.
    So first of all i updated to the latest version of venturechat. Then i did remember that venturechat saves a "chat config" of each player in a blank file in the plugin folder. Therefore i searched upon there and found the 2 usernames listed. I removed the entry from the username the player isn't using anymore on every server and everything seems fine until now. The player can now chat again and the server performance stays good too.
    Only thing i can imagine how this solved it is that the plugin searches after the player entered messages for the setting for this specific username. Which resulted in 2 possible outputs because it didn't searched for the UUID?
     
  11. I can't get /msg, /whisper, /tell to work. When I try to use them nothing happens. I get no errors.

    I am using essentials.
     
  12. @sinni1997 Player names are updated and verified when each player logs in. The system is designed for online servers. Like I said, your issue was an extreme edge case in an unsupported configuration. I don't think you have much to worry about moving forward since the odds of someone buying a previously fake username seems pretty slim..

    @NEMO_CZ Disable BungeeCord messaging if you're not using BungeeCord.
     
  13. Aust1n46 updated VentureChat with a new update entry:

    VentureChat 2.18.5

    Read the rest of this update entry...
     
  14. I've just switched to Venture chat and I'm having the following issue:

    >.... [10:08:43 INFO]: [Global] {vault_prefix} {player_displayname}: heya
    >.... [10:08:47 INFO]: [Global] {vault_prefix} {player_displayname}: just working on <-

    I can't see any errors in the console. And i have placeholder API, vault and protocol lib.

    Any ideas, have I missed something silly? Thanks!

    Also just a note, in discord I see the following:
    Owner Jamie » heya
    [11:08 AM]
    Owner Jamie » just working on <-



    EDIT:

    Fixed using these commands:

    /papi ecloud download Server

    /papi ecloud download Vault

    /papi ecloud download Player

    (I'm a dope)
     
    #7775 Jamie Tees, May 4, 2020
    Last edited: May 4, 2020
  15. @Jamie Tees Download the PlaceholderAPI expansion packs...

    /papi ecloud download Player
    /papi ecloud download Vault
    /papi reload
     
  16. As you said that I just edited my post xD Thanks for getting back quick!
     
  17. I'm using /tell now and it doesn't seem to work, or any message for that matter. Permissions are set as required. (I don't get a perm denied message)

    Have you seen this before?
     
  18. 2.18.5 can't work
    [18:46:14 ERROR]: Error occurred while enabling VentureChat v2.18.5 (Is it up to date?)
    java.lang.NoClassDefFoundError: net/minecraft/server/v1_15_R1/Packet
    at mineverse.Aust1n46.chat.MineverseChat.onEnable(MineverseChat.java:319) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:316) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:395) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:344) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:442) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:403) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:341) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:289) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:616) ~[patched_1.12.2.jar:git-Paper-1618]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_241]
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_15_R1.Packet
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:109) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:104) ~[patched_1.12.2.jar:git-Paper-1618]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_241]
    and so on
     
  19. @LikeWind It's clear you're not using 1.15. But I guess those NMS imports I used for debug mode are a no go. I've removed that debug function and will re-upload.

    @Jamie Tees Disable BungeeCord messaging if you're not using BungeeCord. I swear I said this to someone just the other day... o_O Not trying to be a dick, but please just check the configs first :)
     
    #7780 Aust1n46, May 4, 2020
    Last edited: May 4, 2020