Spigot VentureChat 3.3.2

#1 Channels Chat plugin! Spigot + Bungee. Supports PlaceholderAPI + JSON formatting. New Hex Colors!

  1. @FrostExZo It's a BungeeCord port; pretty sure you have to use legacy.

    @LSS_wwwwwww Use fewer color codes or less Json formatting, or both. You're slightly over the message size limit.
     
  2. I have an update slated for release tomorrow that is my first iteration of dynamic command registration. This will allow any command to be disabled and command aliases to be directly configured.

    Hopefully this can remain stable and I might end up releasing it as a standalone API if this test in VentureChat goes well.
     
  3. Well,I just use a little Chinese and occur this.I hope you can add a setting that I can change it.
     
  4. Only four words will block to send.......T__T
     
  5. Hey I just updated my server to 1.18, and it seems my chat is broken now because for some reason when before it had worked fine. This is the error that shows up when I try to talk:

    17.01 10:33:30 [Server] [VentureChat] Plugin VentureChat v3.2.3 generated an exception while executing task 1536849
    17.01 10:33:30 [Server] INFO java.lang.NoClassDefFoundError: me/clip/deluxetags/DeluxeTag
    17.01 10:33:30 [Server] INFO at com.extendedclip.papi.expansion.deluxetags.DeluxeTagsExpansion.onRequest(DeluxeTagsExpansion.java:88) ~[?:?]
    17.01 10:33:30 [Server] INFO at me.clip.placeholderapi.replacer.CharsReplacer.apply(CharsReplacer.java:161) ~[PlaceholderAPI-2.11.1.jar:?]
    17.01 10:33:30 [Server] INFO at me.clip.placeholderapi.PlaceholderAPI.setBracketPlaceholders(PlaceholderAPI.java:125) ~[PlaceholderAPI-2.11.1.jar:?]
    17.01 10:33:30 [Server] INFO at me.clip.placeholderapi.PlaceholderAPI.setBracketPlaceholders(PlaceholderAPI.java:153) ~[PlaceholderAPI-2.11.1.jar:?]
    17.01 10:33:30 [Server] INFO at mineverse.Aust1n46.chat.utilities.Format.convertPlaceholders(Format.java:112) ~[VentureChat-3.2.3.jar:?]
    17.01 10:33:30 [Server] INFO at mineverse.Aust1n46.chat.utilities.Format.convertToJson(Format.java:72) ~[VentureChat-3.2.3.jar:?]
    17.01 10:33:30 [Server] INFO at mineverse.Aust1n46.chat.listeners.ChatListener.handleTrueAsyncPlayerChatEvent(ChatListener.java:487) ~[VentureChat-3.2.3.jar:?]
    17.01 10:33:30 [Server] INFO at mineverse.Aust1n46.chat.listeners.ChatListener$1.run(ChatListener.java:53) ~[VentureChat-3.2.3.jar:?]
    17.01 10:33:30 [Server] INFO at org.bukkit.craftbukkit.v1_18_R1.scheduler.CraftTask.run(CraftTask.java:101) ~[purpur-1.18.1.jar:git-Purpur-1449]
    17.01 10:33:30 [Server] INFO at org.bukkit.craftbukkit.v1_18_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:57) ~[purpur-1.18.1.jar:git-Purpur-1449]
    17.01 10:33:30 [Server] INFO at com.destroystokyo.paper.ServerSchedulerReportingWrapper.run(ServerSchedulerReportingWrapper.java:22) ~[purpur-1.18.1.jar:git-Purpur-1449]
    17.01 10:33:30 [Server] INFO at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1135) ~[?:?]
    17.01 10:33:30 [Server] INFO at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635) ~[?:?]
    17.01 10:33:30 [Server] INFO at java.lang.Thread.run(Thread.java:831) ~[?:?]
    17.01 10:33:30 [Server] INFO Caused by: java.lang.ClassNotFoundException: me.clip.deluxetags.DeluxeTag
    17.01 10:33:30 [Server] INFO ... 14 more

    It seems to me it can't find deluxe tags, but there is no papi expansion for that plugin and the deluxe tag plugin itself has no errors. So is the placeholders just not compatible with venture chat when they used to work just fine.

    Here's my current config:

    https://pastebin.com/tfbXmvEk
     
  6. Code (Text):
    [13:43:28] [Server thread/ERROR]: Error occurred while enabling VentureChat v3.2.3 (Is it up to date?)
    java.lang.IllegalStateException: zip file closed
        at java.util.zip.ZipFile.ensureOpen(ZipFile.java:831) ~[?:?]
        at java.util.zip.ZipFile.getEntry(ZipFile.java:330) ~[?:?]
        at java.util.jar.JarFile.getEntry(JarFile.java:518) ~[?:?]
        at java.util.jar.JarFile.getJarEntry(JarFile.java:473) ~[?:?]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:163) ~[paper-api-1.18.1-R0.1-SNAPSHOT.jar:?]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:587) ~[?:?]
        at org.bukkit.plugin.java.PluginClassLoader.loadClass0(PluginClassLoader.java:108) ~[paper-api-1.18.1-R0.1-SNAPSHOT.jar:?]
        at org.bukkit.plugin.java.PluginClassLoader.loadClass(PluginClassLoader.java:103) ~[paper-api-1.18.1-R0.1-SNAPSHOT.jar:?]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?]
        at mineverse.Aust1n46.chat.MineverseChat.initializeConfigReaders(MineverseChat.java:244) ~[VentureChat-3.2.3.jar:?]
        at mineverse.Aust1n46.chat.MineverseChat.onEnable(MineverseChat.java:112) ~[VentureChat-3.2.3.jar:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[paper-api-1.18.1-R0.1-SNAPSHOT.jar:?]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:370) ~[paper-api-1.18.1-R0.1-SNAPSHOT.jar:?]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:500) ~[paper-api-1.18.1-R0.1-SNAPSHOT.jar:?]
        at org.bukkit.craftbukkit.v1_18_R1.CraftServer.enablePlugin(CraftServer.java:564) ~[paper-1.18.1.jar:git-Paper-141]
        at org.bukkit.craftbukkit.v1_18_R1.CraftServer.enablePlugins(CraftServer.java:478) ~[paper-1.18.1.jar:git-Paper-141]
        at net.minecraft.server.MinecraftServer.loadWorld0(MinecraftServer.java:727) ~[paper-1.18.1.jar:git-Paper-141]
        at net.minecraft.server.MinecraftServer.loadLevel(MinecraftServer.java:503) ~[paper-1.18.1.jar:git-Paper-141]
        at net.minecraft.server.dedicated.DedicatedServer.initServer(DedicatedServer.java:313) ~[paper-1.18.1.jar:git-Paper-141]
        at net.minecraft.server.MinecraftServer.runServer(MinecraftServer.java:1202) ~[paper-1.18.1.jar:git-Paper-141]
        at net.minecraft.server.MinecraftServer.lambda$spin$0(MinecraftServer.java:317) ~[paper-1.18.1.jar:git-Paper-141]
        at java.lang.Thread.run(Thread.java:833) ~[?:?]
    I'm getting this error.
     
  7. Hello, I've been struggling a lot tried to install VentureChat.
    Paper 1.18.1 git-150
    Cracked server (yes the option of cracked is enabled on plugin config)
    Latest plugin version

    On console there's nothing.

    [00:01:52 INFO]: [VentureChat] Enabling VentureChat v3.2.3
    [00:01:52 INFO]: [VentureChat] - Initializing...
    [00:01:52 INFO]: [VentureChat] - Config found! Loading file.
    [00:01:52 INFO]: [VentureChat] - Checking for Vault...
    [00:01:52 INFO]: [VentureChat] - Loading player data
    [00:01:52 INFO]: [VentureChat] - Registering Listeners
    [00:01:52 INFO]: [VentureChat] - Attaching to Executors
    [00:01:52 INFO]: [VentureChat] - Establishing BungeeCord
    [00:01:52 INFO]: [VentureChat] - Enabling PlaceholderAPI Hook
    [00:01:52 INFO]: [PlaceholderAPI] Successfully registered expansion: venturechat [3.2.3]
    [00:01:52 INFO]: [VentureChat] - Enabled Successfully


    And I have all the dependencies installed, I've tried updating all of them but nothing, the chat shows up as vanilla chat, EssX chat is disabled.
    upload_2022-1-18_0-7-15.png
    List of plugins:
    upload_2022-1-18_0-7-32.png
    Thanks and have a good day.
     
  8. @TV_Linux Sounds like you have some debugging to do then. Why not start by setting up a test environment with only VentureChat and the required dependencies to ensure you have it working properly on it's own.

    @Keopsfenks There's more above of the message above that that tells you exactly what you did wrong. I'll guess and say you're missing Vault and/or a Vault compatible permissions plugin. Which is listed in the overview.

    @_JediMaster_ Not VentureChat. You have class not found exceptions pointing right at DeluxeTags...

    And your config is way out of date by the way.

    @LSS_wwwwwww If you can't figure it out, you'll have to disable BungeeCord channels.

    Post a screenshot of one of the messages. If you're using rainbow chat or tons of colors and Json, this can happen. It's quite rare with English chat. It's a limitation of BungeeCord.
     
  9. Aust1n46 updated VentureChat with a new update entry:

    VentureChat 3.3.0

    Read the rest of this update entry...
     
  10. Found out that is the PlayerPing plugin the one that is causing VentureChat not working properly
    https://www.spigotmc.org/resources/playerping.75197/
     
  11. Heya! Does VentureChat allow specific formats for one single channel (i.e. global) per world? If not, can it be added?
     
  12. Hello, could be possible to add a simple mention system? With custom sound, color and before tag, that's all, thanks
     
  13. Appears to not work with Dynmap chat.
     
    • Winner Winner x 1
  14. Code (YAML):
    [17:22:14 ERROR]: Error occurred while enabling VentureChat v3.3.0 (Is it up to date?)
    java.lang.NullPointerException
    : Cannot invoke "org.bukkit.configuration.ConfigurationSection.getKeys(boolean)" because "cs" is null
            at mineverse.Aust1n46.chat.alias.Alias.initialize(Alias.java:29) ~[VentureChat-3.3.0.jar:?]
            at mineverse.Aust1n46.chat.MineverseChat.initializeConfigReaders(MineverseChat.java:245) ~[VentureChat-3.3.0.jar:?]
            at mineverse.Aust1n46.chat.MineverseChat.onEnable(MineverseChat.java:112) ~[VentureChat-3.3.0.jar:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:370) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:500) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.frankheijden.serverutils.bukkit.managers.BukkitPluginManager.enableOrderedPlugins(BukkitPluginManager.java:184) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at net.frankheijden.serverutils.common.managers.AbstractPluginManager.enablePlugins(AbstractPluginManager.java:105) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at net.frankheijden.serverutils.common.managers.AbstractPluginManager.reloadPlugins(AbstractPluginManager.java:219) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at net.frankheijden.serverutils.common.commands.CommandServerUtils.handleReloadPlugin(CommandServerUtils.java:235) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at net.frankheijden.serverutils.dependencies.cloud.execution.CommandExecutionHandler.executeFuture(CommandExecutionHandler.java:58) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at net.frankheijden.serverutils.dependencies.cloud.execution.CommandExecutionCoordinator$SimpleCoordinator.coordinateExecution(CommandExecutionCoordinator.java:120) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at net.frankheijden.serverutils.dependencies.cloud.CommandManager.executeCommand(CommandManager.java:177) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at net.frankheijden.serverutils.dependencies.cloud.bukkit.BukkitCommand.execute(BukkitCommand.java:110) ~[ServerUtils-Bukkit-3.3.1.jar:?]
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:172) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at org.bukkit.craftbukkit.v1_17_R1.CraftServer.dispatchCommand(CraftServer.java:869) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.server.network.ServerGamePacketListenerImpl.handleCommand(ServerGamePacketListenerImpl.java:2331) ~[app:?]
            at net.minecraft.server.network.ServerGamePacketListenerImpl.handleChat(ServerGamePacketListenerImpl.java:2142) ~[app:?]
            at net.minecraft.server.network.ServerGamePacketListenerImpl.handleChat(ServerGamePacketListenerImpl.java:2123) ~[app:?]
            at net.minecraft.network.protocol.game.ServerboundChatPacket.handle(ServerboundChatPacket.java:46) ~[app:?]
            at net.minecraft.network.protocol.game.ServerboundChatPacket.a(ServerboundChatPacket.java:6) ~[app:?]
            at net.minecraft.network.protocol.PacketUtils.lambda$ensureRunningOnSameThread$1(PacketUtils.java:56) ~[app:?]
            at net.minecraft.server.TickTask.run(TickTask.java:18) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.util.thread.BlockableEventLoop.doRunTask(BlockableEventLoop.java:149) ~[app:?]
            at net.minecraft.util.thread.ReentrantBlockableEventLoop.doRunTask(ReentrantBlockableEventLoop.java:23) ~[app:?]
            at net.minecraft.server.MinecraftServer.doRunTask(MinecraftServer.java:1443) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.server.MinecraftServer.executeTask(MinecraftServer.java:192) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.util.thread.BlockableEventLoop.pollTask(BlockableEventLoop.java:122) ~[app:?]
            at net.minecraft.server.MinecraftServer.pollTaskInternal(MinecraftServer.java:1421) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.server.MinecraftServer.pollTask(MinecraftServer.java:1414) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.util.thread.BlockableEventLoop.managedBlock(BlockableEventLoop.java:132) ~[app:?]
            at net.minecraft.server.MinecraftServer.waitUntilNextTick(MinecraftServer.java:1392) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.server.MinecraftServer.runServer(MinecraftServer.java:1303) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at net.minecraft.server.MinecraftServer.lambda$spin$1(MinecraftServer.java:323) ~[patched_1.17.1.jar:git-Pufferfish-8]
            at java.lang.Thread.run(Thread.java:831) ~[?:?]
    Any idea of why this is happening?
     
  15. Using /msg command, there is no tab completion for player name
     
  16. Hello again, could be possible to add per group chat format with permissions? Thanks
     
  17. Hey guys!
    Now I really don't know what to do, every time I want to start VC an error comes up that VC Vault cannot be found.
    I tried the plugin from spigotmc.org as well as the one from dev.bukkit.org which you linked but which hasn't been updated since 2020. I also waited for the new version (3.3.0), but it still doesn't work. The plugin sounds really good and I would really like to use it, can someone help me?

    CONSOLE:
    Code (Text):
    [21:54:56 INFO]: Preparing start region for dimension minecraft:the_end
    [21:54:56 INFO]: Time elapsed: 114 ms
    [21:54:56 INFO]: [PlaceholderAPI] Enabling PlaceholderAPI v2.10.10
    [21:54:57 INFO]: [PlaceholderAPI] Fetching available expansion information...
    [21:54:57 INFO]: [VentureChat] Enabling VentureChat v3.3.0
    [21:54:57 INFO]: [VentureChat] - Initializing...
    [21:54:57 INFO]: [VentureChat] - Config found! Loading file.
    [21:54:57 INFO]: [VentureChat] - Checking for Vault...
    [21:54:57 INFO]: [VentureChat] - Could not find Vault and/or a Vault compatible permissions plugin!
    [21:54:57 INFO]: [VentureChat] Disabling VentureChat v3.3.0
    [21:54:57 INFO]: [VentureChat] - Disabling...
    [21:54:57 INFO]: [VentureChat] - Disabled Successfully
    [21:54:57 INFO]: [Essentials] Enabling Essentials v2.19.3-dev+1-05ce11f
    [21:54:58 INFO]: [Essentials] Attempting to convert old kits in config.yml to new kits.yml
    [21:54:58 INFO]: [Essentials] No kits found to migrate.
    [21:54:58 INFO]: [Essentials] Loaded 36926 items from items.json.
    [21:54:58 INFO]: [Essentials] Using locale de_DE
    [21:54:58 INFO]: [Essentials] ServerListPingEvent: Spigot iterator API
    [21:54:58 INFO]: [Essentials] Starting Metrics. Opt-out using the global bStats config.
    [21:54:58 INFO]: [Vault] [Economy] Essentials Economy hooked.
    [21:54:58 INFO]: [Essentials] Using superperms-based permissions.
    [21:54:58 INFO]: [DiscordSRV] Enabling DiscordSRV v1.24.0
    [21:54:58 INFO]: [PlaceholderAPI] Placeholder expansion registration initializing...
    [21:54:58 INFO]: Running delayed init tasks
    [21:54:58 INFO]: [Essentials] Essentials found a compatible payment resolution method: Vault Compatibility Layer (v1.7.3-b131)!
    [21:54:58 INFO]: [Vault] Checking for Updates ...
     
  18. Hey all. I am trying to get things setup with Waterfall and paper servers. I have everything configured on the servers just fine, however when I load it on the proxy no commands show up for it in the proxy console, and the config.yml file is empty. Are there specific requirements for the proxy that I am missing?
     
  19. @goosBanny @TV_Linux One channel -> one format.

    Use PlaceholderAPI to customize channel formats per group. You can create custom placeholders if you really desire to make the entire format drastically different per group.

    @Dovkin Nope, no one has made a Dynmap expansion for VentureChat. I tried a while ago, but to be totally honest with you, since I no longer run servers, it's low down on my priority list to create. I hope someone else decides to contribute it as it would be a separate resource.

    @Agaloth Your config is either light years out of date, or you deleted the alias section and broke the config's formatting.

    You can reference the default config or move/delete your old config and let it regenerate.

    @MrChokBreadYT Do you have any other plugins that have a /msg command? Can you PM me your server version so I can investigate myself? Thanks

    @MatitoDA Do you have a Vault compatible permissions plugin such as LuckPerms? The error messages states you need both Vault AND a permissions plugin.

    @ph1lt0r There are no proxy commands or proxy configuration. The plugin is configured on the server side.