Version Incompatability

Discussion in 'Spigot Help' started by TheExus, Jun 3, 2016.

  1. I got spigot 1.9 and 1.9.2 jars. I tried both of them. When I launched up 1.9.4, it was not compatible. How do I update my launched server to 1.9 if it won't work with some of the 1.9 versions?
     
  2. MiniDigger

    Supporter

    There was a protocol bump in 1.9.3pre3. So you can use 1.9.0-1.9.2 and 1.9.3-1.9.4 on one server. 1.9.4 is not compatible with anything below 1.9.3. If you want clients with 1.9.2 to join your 1.9.4 server you need what's called a protocol hack. There are some plugins out there that can do it for you.
     
    #2 MiniDigger, Jun 3, 2016
    Last edited: Jun 3, 2016
    • Creative Creative x 1
  3. Sw4p

    Supporter

    I believe that viaversion will do what you want.