Spigot Very Dangerous Nether 2.0.0

Adds mechanics, mobs and custom structures to the Nether.

  1. KingVaboXiii submitted a new resource:

    Very Dangerous Nether - Adds mechanics, mobs and custom structures to the Nether.

    Read more about this resource...
     
  2. sup does this work with 1.14.4 if not please add support for it also pics would be nice :)
     
  3. Hye, you left a debug message ("Nooo, it wont enter the if statement, are u sure CaveEnts is true?"), please please fix that because it is spamming my console
     
    • Funny Funny x 1
    • Useful Useful x 1
  4. Nice plugin! Can I make a introduction this nice plugin to http://www.mcbbs.net/? I hope more Chinese sever owner use it:)
     
  5. Thanks! Yeah go ahead ☺️
     
  6. Hey! this works for 1.12.2? or only 1.15.2+?
     
  7. Hey, this works for 1.14.x + but check out Dangerous Nether for versions before 1.14 :)
     
    • Like Like x 1
    • Like Like x 1
  8. tbi

    tbi

    I think there are a few features of this plugin that have become broken with the latest protocollib updates...
    it would seem the wind effects still work, but I cant seem to get the lightning strikes to occur.

    which is unfortunate.

    EDIT:

    I was actually able to fix a copy for myself that seems to have fixed the lightning issue, I recompiled the source using the spigot 1.16.1 api and added added a maven dependency for the newest version of worldedit version that has been released thus far.
    I think what the issue is that the version that has been released here just doesent support the new release beta-2 of worledit, they probably changed something that fooled with things.

    eitherway thanx for the great resource!

    EDIT2:

    upon my update and further examination, it would seem lighting strikes only seem to execute upon a player movement event.
    guess maybe your rebuilding the source code and have not changed the event to something better.
    2020-08-04 21_32_14-VeryDangerousNether – nether.java Administrator.png
     
    #12 tbi, Aug 4, 2020
    Last edited: Aug 5, 2020
    • Like Like x 1
  9. hi !

    plugin work on 1.15.2 but spam error

    >.... [19:10:52 ERROR]: Could not pass event CreatureSpawnEvent to VeryDangerousNether v2.0.0
    java.lang.NoSuchFieldError: NETHER_WASTES
    at verydangerousnether.verydangerousnether.nether.mobs.SpawnHandler.spawnMobs(SpawnHandler.java:32) ~[?:?]
    at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor1528.execute(Unknown Source) ~[?:?]
    at org.bukkit.plugin.EventExecutor.lambda$create$1(EventExecutor.java:69) ~[patched_1.15.2.jar:git-Paper-387]
    at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:80) ~[patched_1.15.2.jar:git-Paper-387]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[patched_1.15.2.jar:git-Paper-387]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:607) ~[patched_1.15.2.jar:git-Paper-387]
    at org.bukkit.craftbukkit.v1_15_R1.event.CraftEventFactory.callCreatureSpawnEvent(CraftEventFactory.java:639) ~[patched_1.15.2.jar:git-Paper-387]
    at org.bukkit.craftbukkit.v1_15_R1.event.CraftEventFactory.doEntityAddEventCalling(CraftEventFactory.java:560) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.WorldServer.addEntity0(WorldServer.java:1267) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.WorldServer.addEntity(WorldServer.java:1175) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.SpawnerCreature.spawnMobs(SpawnerCreature.java:123) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.ChunkProviderServer.lambda$tickChunks$14(ChunkProviderServer.java:903) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.PlayerChunkMap.forEachVisibleChunk(PlayerChunkMap.java:620) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.ChunkProviderServer.tickChunks(ChunkProviderServer.java:835) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.ChunkProviderServer.tick(ChunkProviderServer.java:749) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.WorldServer.doTick(WorldServer.java:439) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.MinecraftServer.b(MinecraftServer.java:1328) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.DedicatedServer.b(DedicatedServer.java:431) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.MinecraftServer.a(MinecraftServer.java:1182) ~[patched_1.15.2.jar:git-Paper-387]
    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:971) ~[patched_1.15.2.jar:git-Paper-387]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_262]
     
  10. This is totally right, I'm working on a fix now but its hard being a full time student while maintaining 5 plugins xD If ur interested in joining my dev team don't hesitate to take contact ;)
     
  11. This error is because versions POST 2.x.x does only support 1.16.x
     
  12. So the 2.0.0 is only for 1.16.x?
     
  13. Correct
     
  14. Is lower support coming?
     
  15. Its a work in progress, but its gonna take a lot of time because im a solo developer across 5 plugins..
     
  16. I guess there is no support for 1.16.3? Can you guys please update it ? Thanks a lot !!!




    [ERROR] .... null

    org.bukkit.command.CommandException: Unhandled exception executing command 'vdn' in plugin VeryDangerousNether v2.0.0

    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:47) ~[patched_1.16.3.jar:git-Paper-251]

    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159) ~[patched_1.16.3.jar:git-Paper-251]

    at org.bukkit.craftbukkit.v1_16_R2.CraftServer.dispatchCommand(CraftServer.java:802) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.PlayerConnection.handleCommand(PlayerConnection.java:1918) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.PlayerConnection.a(PlayerConnection.java:1729) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.PacketPlayInChat.a(PacketPlayInChat.java:47) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.PacketPlayInChat.a(PacketPlayInChat.java:5) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.PlayerConnectionUtils.lambda$ensureMainThread$1(PlayerConnectionUtils.java:23) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.TickTask.run(SourceFile:18) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.IAsyncTaskHandler.executeTask(IAsyncTaskHandler.java:136) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.IAsyncTaskHandler.executeNext(IAsyncTaskHandler.java:109) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.MinecraftServer.ba(MinecraftServer.java:1135) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.MinecraftServer.executeNext(MinecraftServer.java:1128) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.IAsyncTaskHandler.executeAll(IAsyncTaskHandler.java:95) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.MinecraftServer.a(MinecraftServer.java:1264) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.MinecraftServer.w(MinecraftServer.java:999) ~[patched_1.16.3.jar:git-Paper-251]

    at net.minecraft.server.v1_16_R2.MinecraftServer.lambda$a$0(MinecraftServer.java:177) ~[patched_1.16.3.jar:git-Paper-251]

    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]

    Caused by: java.lang.ArrayIndexOutOfBoundsException: 1

    at verydangerousnether.verydangerousnether.nether.commands.VDN.onCommand(VDN.java:30) ~[?:?]

    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45) ~[patched_1.16.3.jar:git-Paper-251]

    ... 18 more