VERY low tps issues!

Discussion in 'Spigot Help' started by Vexius, Apr 16, 2017.

  1. Hey Spigot!

    I hope everyone is having an amazing easter :)

    I have some issues with a server of mine, its a Survival server with boss fights and more. I have had some issues for a while now, when the server have been running for about 7 hours the tps is around 13-14 and people get a very laggy experience. I cant seem to find the issue on what causes this. I tried to take some timings while the tps was at like 8-9.

    Timings:
    1. https://timings.spigotmc.org/?url=codiwuguni
    2. https://timings.spigotmc.org/?url=hepudejetu
    3. https://timings.spigotmc.org/?url=gavubikaru
    4. https://timings.spigotmc.org/?url=naxonoyipe

    The view distance is 7 atm. and its a 64GB OVH dedicated with a good CPU. I have 4 other servers running and we use like a total of 40 gb on all servers combined. So its not over used or anything and its only this one server that causes issues.

    Here is a picture of /gc and the plugins:

    1. https://gyazo.com/d3e59d51130ef73eed020cd4f803e84e
    2. https://gyazo.com/e239333e549bf17d27944dd88da0029e

    There is currently no world border, and I am not sure if that affect anything in this situation.

    I have tried to disable Citizens and that didn't help out on the lag. I hope you guys can help me out :)

    Have a good easter and thanks in advance!
     
  2. Completely remove citizens and see if that helps?

    I would even suggest restarting the server often. Currently my server restarts every 6 hours exactly and I have absolutely no issues when I restart every 6 hours.
     
  3. If you have a decent amount of players who constantly warp around and are constantly loading new chunks (ex. /wild, /rtp commands or even just exploring), and your world was not pregenerated, loading all of those chunks takes a toll on the server.
     
    • Like Like x 1
  4. Thank you a lot for the answer, I have tried to completely remove citizens twice and it didnt really help out. The issue with the auto restart is that the world is so big that it cant really handle the shutdown I think. When I set it to auto restart it takes a whole lot of time to get back up :) Do you have a good auto restart plugin?

    Thanks for your answer :) I have a decent amount of players but not something insane. The Survival is around 5-20 players and they are not teleporting around excessively :) But yeah I see your point, but do you think I need to set a world border or wont that help?
     
  5. I would suggest taking at look at investing in the React plugin made by @cyberpwn really worth it for its price
    https://www.spigotmc.org/resources/react-smart-server-performance.21057/
     
    • Like Like x 1
  6. Looks like there might be too many entities. Have you tried killing all the aggressive entities and removing ground items? Citizens might also be causing this problem.

    One other thing, what host do you use? If they oversell their servers or use bad CPU's that might cause server lag.
     
    • Like Like x 1
  7. electronicboy

    IRC Staff

    Well, Citizens has clearly pissed off timings, however the majority of your lag appears to be coming from entities on the server, I would suggest removing citizens and trying to collect a new set of timings (make sure to leave it running for a few minutes), however; overall it really looks like your server is running on a toaster


    and as a response to the comment above that swiped in while I was writing this: React is actually capable of causing more issues, especially in cases where the cause is unknown, I highly suggest against using any plugins that say that they can magically fix performance, as a fair chunk of what they do can already be configured on the server, their hacky methods of tweaking certain aspects can actually cause more lag than was ever in existence, and in general are actually a case of lag as I've noticed a lot in timings V2.
     
    • Agree Agree x 2
    • Informative Informative x 1
  8. It is a dedicated OVH https://www.ovh.com/us/dedicated-servers/details-servers-range-ENT-id-2016-SP-64.xml - So its not a overused host :) We are the only one using it :)

    And I have clearlag running trying to wipe off entities :)

    This is timings from another server I have on the same network: https://timings.spigotmc.org/?url=pomiluhota

    ''however; overall it really looks like your server is running on a toaster'' pretty funny haha, I thought the same but the reality is something else. I tried to take a timings after 1½ hour run time and here is what it looks like:
    https://timings.spigotmc.org/?url=kocolahehi

    Could it be something that messes up with the world save? It seems to cause some issues same with the Autorank plugin.

    Once again thank to everyone for helping me find the issue :)
     
  9. electronicboy

    IRC Staff

    Well, World Save being that high on such a small server is generally indicative of a slow disk, generally being an HDD or an overloaded SSD, (or something not letting chunks unload, however:) with the 2nd task on there showing issues, it really does point to the storage of the machine not really being able to keep up

    your timings samples are also really small, the idea with timings V1 is that you leave it to run for at least a few minutes over the period of lag and hope that it paints an accurate picture
     
  10. That is a lot of entities you have there. Try reducing your total entities in the world at a time.

    [​IMG]
     
    • Funny Funny x 2
  11. Real funny joke there.
     
    • Funny Funny x 1
  12. The issue is entity ticking, so reducing the amount of entities would fix the problem. I dont see why people are talking about chunks (if the view distance isnt out of control and keeping loads of mobs loaded). Plus... what else is there to say?
     
    • Agree Agree x 2
  13. electronicboy

    IRC Staff

    the original issue was caused by Citizens and its own entities, if 450 entities are enough to cause lag on your server, you have a toaster. Once citizens was removed, there was no longer any issues based on the next timings he provided from that server. which was also where my comment in regards to the disk and chunks came from, others are mostly on the "let's take random guesses as to the cause".
     
  14. electronic the timings I sent you last time was from another server on the network to prove it wasn't a toaster it is running on :)

    I have tried to disable Citizens since yesterday and the same issues persist =/
     
  15. electronicboy

    IRC Staff

    please provide a set of timings that are longer than 20 seconds, e.g. don't run /timings reset, enable timings in the configuration file of the server too, instead of using /timings on
     
  16. Did you disable citizens or did you completely remove the .jar?