Solved Very odd glitch

Discussion in 'Spigot Help' started by NIKNAIZ, May 5, 2017.

Thread Status:
Not open for further replies.
  1. Hello everyone, I just stumbled upon a strange glitch, one of my administrators has bought a ShopGUIPlus plugin, and I just installed it on my server and it works well when executed from my account, however, when I do it through an alt, the /shop command gets rewritten to /warp shop, causing unknown command. Let me show you.


    upload_2017-5-5_12-57-4.png

    Let's do the same through my alt:

    upload_2017-5-5_12-57-32.png
    upload_2017-5-5_12-57-40.png

    ??????

    The command "/shop" gets executed even if it is mentioned somewhere in the chat, for example, "use /shop to buy X item", that would cause for the command to execute. I literally run this on a fresh server, these are the plugins installed right now.
    upload_2017-5-5_12-58-47.png

    Any help is appreciated.

    EDIT: I just tried oping the alt, and still happens.
     
  2. It is strange , but it is probably a alias made in commands.yml
    Not sure though
     
  3. upload_2017-5-5_13-1-52.png
     
  4. Check spigot , change the version.
    Or delete everything except server.properties , spigot.yml and eula.txt and the plugins to pinpoint the issue
     
  5. I just installed EssentialsX and I can sudo players to do that command and it works perfectly. There's something intercepting something between the /shop command and the actual execution, but I have no plugins that do something like that.
     
Thread Status:
Not open for further replies.