Universal ViaBackwards 4.2.1

Allow older versions to connect to your Minecraft server.

  1. @Matsv fix this

     
  2. Hello, I know that it is a lot of work to do, but maybe can you give us a shot, when we can expect 1.13.1 (1.13) update?
     
    • Agree Agree x 5
    • Like Like x 1
  3. I have the plugin for bungee and in the spigot servers but when i join any it says i have the 1.0.0 version and that i should update to the latest. I can use 1.13 and everything it's just that idk why it says that i've cleared it from bungee and leaving it there wont work either apparently.
    EDIT:l Apparently when I remove it from bungee and leave it on the spigot servers it doesnt let me join them like viaversion doesnt work.
    I know you answered this already but thing is that because of this still not working (with the solutions you gave me) i can't use viabackwards. Because of those problems. If I remove viaversion from bungee people can only connect with the bungee version (im using the latest one so 1.13.1 i guess) and if I add it in bungee then it works fine but viabackwards can't be added to bungee and in spigot servers it won't work so there's clearly something happening here and I hope you can help me.
     
  4. Ok hopefully by the time i wake up someone can answer this for me and help me.

    So i decided to change my server to 1.12.2 in order to use a couple of nice plugins right. I tried using viaversion and viabackwards, tested it with 1.9 and above, works good. However ever since i update the server, i get essentials errors, even though ive updated it and downgraded it and still same thing. Whenever i execute some commands the server crashes. I also tried using viaversion and viarewind and i could connect with 1.8, but still getting that crashing problem.

    wondering how can i disable features above 1.8, like the blocks and pvp mechanics, but have the server version be 1.12.2. and can you have it be the othr way around. 1.12.2 features in a 1.8 client?

    Also let me note i have update essentials and other plugins to 1.12.2 and still same thing.

    I’m thinking now, let me know if i’m correct. If i want to use a plugin like Prodigygadget which is not compatible with 1.8. And i use 1.12.2 mc version with viaversion, backward, and rewind. Would that allow me to use 1.12.2 plugin features normally on a 1.8 client?


    Thanks for any help. i really need it!
     
    #304 Timed, Sep 10, 2018
    Last edited: Sep 10, 2018
  5. Did you try to use the dev builds of ViaVersion and ViaBackwars? Do you have it connected to or through a Bungeecord server? What are the errors? Maybe a dumb file can be handy...
     
  6. I have the same issue, I have tried dev builds of via version and backwards with bungeecord and still not working. I think, we could use some alpha build or something, but we dont have nothing what we cen use.
     
  7. It can also be that there where some changes on how ViaVersion and ViaBackwars talk together and it can be changed with the 1.13 update of ViaVersion (not sure). But if you use Bungeecord as well then you should only have ViaVersion and ViaBackwards on your Spigot server for best compatibility (so not on both). @Matsv looks kinda dead if you look at his "was last seen" time but he was really busy with helping fixing things on ViaVersion so I guess we have to wait for responds of him.
     
  8. Is the newest released version on Jenkins 1.13? Cause I tested it with 1.13 and it dosent work!
     
  9. Does ViaBackwards work on an 1.13.1 Server to allow 1.13 Users to join?
     
  10. There are no versions that works for 1.13 and higher atm.
     
  11. No i have not tried bungeecoord. Can you possibly guide me to put what plugin on which type of server. Which one goes on the bungeecoord etc.. the error is mostly essentials not being able to complete line 33 and something. I can recreate it if you need. What do you mean dumb file?
     
    #312 Timed, Sep 10, 2018
    Last edited: Sep 10, 2018
  12. Maybe read this first...
    You can make dump a with "/viaversion dump". I thought it was dumb but it is dump, sry :p
     
  13. Any information when 1.13.1 is going to be supported ?
     
    • Like Like x 2
  14. is there a way to stop this spam without using another console filter plugin?

    [​IMG]
     
  15. Spigot version 1.12
    I use bungee viaversion and bungee ViaBackwards but players fail to log in with spigot 1.9

    kick throws

    20:22:07 [INFO] [OyunKurdu_] disconnected with: Kicked whilst connecting to CakmaLobi: [OKNetwork] Surum Yanlis! Lutfen 1.12 Kullan.
     
  16. How can i customize what blocks 1.12 blocks turn into for 1.8 players
     
  17. UPDATE !

    god damn it, need allowed 1.x to 1.13.1 connect to 1.13.1 server !
     
    • Agree Agree x 1
  18. Someone just make a reborn plugin version of this please!! The developer obviously just dosent care or abandoned the project because "1.13 takes time" or in other words "i just cant be asked to upgrade it to 1.13"
     
    • Agree Agree x 1
  19. Same thing... really disappointing no version for 1.13 .
    As if the plugin pass to Premium i'll pay for, really need it . Please
     
    • Agree Agree x 2