ViaVersion + Protocol Support

Discussion in 'Spigot Discussion' started by FireFlies, Feb 2, 2017.

  1. Hey everyone,

    My goal is to have a server where players can join on any client above 1.7
    So for example 1.7,1.8,1.9,1.10 etc.

    After researching it seems that this is achievable by using both ViaVersion and Protocol Support on a 1.8 server.

    After doing multiple tests I can't seem to have this work with bungeecord, I've tried many different versions of both bungeecord and spigot but have had no luck.

    What I'm asking is what combination of versions of spigot and bungeecord work to be able to do this?

    Thanks for your time!

  2. 1. Create a newest spigot 1.11.2 server with newest protocolsupport and blockversion plugin (without viaversion) and configure blockversion

    2. Original Bungeecord doesn't support 1.7, so you'll have to use its forks like "Hexacord" or "Waterfall with travertine"
    • Agree Agree x 1
  3. Thank you for your reply, by using the option you suggested, will I be able to use 1.7/1.8 plugins?
  4. If your main server will be a server like factions/sb etc., then no, you'll need 1.11 plugins. I would suggest to use a lobby
  5. ProtocolSupport with Viaversion broke recently for me and other users. Also you can try it but you need to put a ProtocolSupport on your servers NOT bungee
  6. I have done setups like this, it's not too hard.
  7. You can also use 1.11.2 + ProtocolSupport, which is better if you need to support 1.7 since ProtocolSupport for 1.8 is NOT maintained anymore. (So, if you have any issues with ProtocolSupport on 1.8, you are out of luck because you won't get any fixes)

    ProtocolSupport on 1.11.2 runs fine, way better than ProtocolSupport on 1.8.
    • Agree Agree x 1
  8. Well duh. But it begins too irritate players due to the wrong versions being enabled on the server
  9. Care to explain in detail?..
    1. Use HexaCord instead of BungeeCord
    2. Add ProtocolSupport + ViaVersion on every server (not on BungeeCord, needs to be on EVERY, SINGLE, SERVER)
    3. Done!
    Not too hard.
    • Agree Agree x 1
  10. And all that using spigot 1.11+?
  11. Oh... If you want to use Spigot 1.11.2:
    1. Use HexaCord instead of BungeeCord
    2. Add ProtocolSupport on every server (not on BungeeCord, needs to be on EVERY, SINGLE, SERVER)
    3. Done!
    If you are using 1.11.2 you don't need ViaVersion. (Also, you cannot support 1.4.7 - 1.6 if you are going to use BungeeCord/HexaCord, if that matters to you)
  12. The thing I'm worrying about is the new blocks affecting the players playing on older versions. Is there a plugin that disables completely the new blocks in world generation? Is this something that can be changed in server settings?
  13. You will need to create a custom plugin for that.

    But if you want to know what happens when a older client views a new block/item: ProtocolSupport changes it to another block/item.
    • Agree Agree x 1
  14. Ah right that's fine then. In the first steps when you said to use ViaVersion, what version of spigot would work? What would be best for me is a server based in 1.8, but 1.7 and 1.9+ clients can still join (so all the plugins are 1.8).
  15. 1.8.8, however I tried using ProtocolSupport + ViaVersion in 1.8.8 and ProtocolSupport was having too many issues (disconnecting all 1.7 clients, etc) so now I don't use ProtocolSupport on my 1.8.8 server anymore. (and because 1.7 is already obsolete at this point)
  16. Yeah I also tried using 1.8.8 but ProtocolSupport was stopping the server as soon as it started. 1.7.10 is still on the top 5 most used version for servers, I only play on 1.7.10. I will try to use 1.11 with plugins to have the 1.7 feel but if too many problems come up I will just use 1.7-1.8 protocol hack. Thanks for the help guys!
  17. If you want to know why ProtocolSupport is stopping your server: You downloaded ProtocolSupport for some other version that isn't 1.8.8

    This is the ProtocolSupport build for 1.8.8:
  18. Yes I know but that link doesn't work anymore, and I haven't been able to find it.
  19. I think @Shevchik deleted his Jenkins and created a new one... (probably he bought a new machine and created a new Jenkins there)

    So... yeah, that's bad, you need to compile ProtocolSupport from the source (and git revert to that commit) if you want 1.8.8.

    I still have this ProtocolSupport JAR file on my dedicated server, I think it is the 1.8.8 version but I didn't test it: