Universal ViaVersion 3.2.1

Allow newer versions to connect, why lose players while waiting after a Minecraft update?

  1. FormallyMyles

    Supporter

    Packet is better if you have more netty threads / multi-core. World can be good memory wise but we've seen it cause server crashes.
     
  2. I use 'world' and it's been working fine.
     
  3. I'm currently having issues with ViaVersion causing HolographicDisplays not to be clickable while using Touchscreen Holograms on 1.12.2. If I use a 1.14.4 client, it works. If i use a 1.12.2 client it doesn't. If I remove ViaVersion entirely, then 1.12.2 clients can click the holograms as expected.

    Server is on 1.12.2 Spigot.

    Anyone have any idea why it does not work on 1.12.2 clients but works with 1.14.4 clients?

    EDIT: I seem to get this console error when I get within about 20 blocks of the Holo Display
    [Netty Epoll Server IO #3/ERROR]: [ViaVersion] Could not find type id -1 isObject=false
     
    #4143 marckskl, Nov 9, 2019
    Last edited: Nov 10, 2019
  4. Hello, I have a server 1.12.2 players who want to connect sometimes stuck on the server and immediately crashes them and something like [ViaVersion] Ignoring plugin channel in outgoing appears REGISTER: WECU how to fix it?
     
  5. To Author:
    FormallyMyles
    Was using / testing DEV build 376 and it was working fine for three days with mc1.15.pre3 - until yesterdays release of mc1.15.pre4.
    Now errors as "Outdated server! Im still on (0)"
    Ie next test version required - thanks for a fantastic plugin ............
     
    #4145 DaDMaR777, Dec 4, 2019
    Last edited: Dec 4, 2019
  6. Not updated for 1.15 yet, never mind snapshots.
     
    • Agree Agree x 1
    • Winner Winner x 1
  7. FormallyMyles

    Supporter

    -DEV branch is for snapshots and it was updated yesterday, not sure how build 376 would work for you
     
    • Friendly Friendly x 1
  8. Hi, I have such a problem how to make it possible for people to enter my server only with version 1.14.x - my server is paper spigot on 1.14.4, what I need to use and what to block so that only 1.14.x clients can be accessed
     
  9. Andre_601

    Supporter

    Run the server on 1.14.4 itself.
    ViaVersion is for allowing people with versions higher than 1.8.x to join the server, nothing else.
     
    • Agree Agree x 1
    • Informative Informative x 1
  10. So what should I do? I mean i have paper-spigot 1.14.4 and players can't join on 1.14 or 1.14.X, how to do that they could?
     
  11. Andre_601

    Supporter

    If they can't join then they either don't use 1.14, or your server doesn't run 1.14. It's that simple.
     
  12. I think you misunderstand the purpose of ViaVersion. VV allows newer client versions to connect to older server versions. So if you're running a 1.14.4 server, only 1.14.4 and newer clients would be able to connect.

    Perhaps you can better explain what you want to do, and maybe someone will have a solution.

    To allow older clients and control which client versions can connect, see:
    https://www.spigotmc.org/resources/protocolsupport.7201/
    https://www.spigotmc.org/resources/blockversion-for-protocolsupport.21202/
     
    #4152 Bobcat00, Dec 6, 2019
    Last edited: Dec 6, 2019
    • Agree Agree x 1
  13. To Author:
    FormallyMyles
    Sorry did not explain well previous post am running spigot mc1.14.4 with lots of plugins for testing usually dev builds were possible.
    On a mc1.14.4 bungeecord server - but was using 1.15.pre3 client to join - was ok 3 days til the latest (then) 1.15.pre4 was used by the launcher as the latest snapshot
    So now will get latest dev build and test with 1.15.pre6 .... as i said thanks for the hard work put in to keep this plugin future current .. thank you.
     
    • Like Like x 1
  14. FormallyMyles

    Supporter

    Hi!

    Thought I'd make a quick post ahead of tomorrow since 1.15 is coming out. Usually, ViaVersion is on the ball and releases almost (5-30 minutes) after the update. I'm away during the majority of tomorrow (I'm honestly surprised this has never happened during an update before, considering how many we've supported). This means ViaVersion will publish the stable release at 9:30 PM GMT after I've looked through to ensure everything is good to go (considering 1000s of servers use ViaVersion and we want to publish the best first release we can).

    The majority of this update has already been made, our awesome contributors have been working as the releases are published to ensure we don't get behind on the update. If you're a risk-taking person, modifying our builds to use the 1.15 protocol number would be sufficient to support this release. However, it is suggested to wait until the official release so that we can ensure there are minimal bugs.

    If you would like to be notified when the release is final, joining https://viaversion.com/discord is highly recommended as we'll tag you when the release is done.

    Thanks for continuing to use ViaVersion, consider donating to support the project.
     
    • Like Like x 2
    • Winner Winner x 2
  15. FormallyMyles

    Supporter

    #4155 FormallyMyles, Dec 10, 2019
    Last edited: Dec 10, 2019
    • Like Like x 1
  16. Thank you, I was just able to connect with 1.15 fresh vanilla download through ViaVersion to my 1.13.2 Spigot server :)

    woot woot, the first step has been taken.
     
    • Agree Agree x 2
    • Like Like x 1
  17. Small question - is there a 1.15 compatible Bungee version out yet?
     
  18. FormallyMyles

    Supporter

  19. I think the version/update reporting isn't working. Says I have a newer version than is released, and didn't tell me about the 2.2.1 version.
     
    • Agree Agree x 1
  20. Error when i try to join in 1.8.9 client to 1.12.2 server:

    Code (Text):
    disconnected with: EncoderException : java.util.NoSuchElementException: us.myles.ViaVersion.protocols.protocol1_11to1_10.Protocol1_11To1_10 @ io.netty.handler.codec.MessageToMessageEncoder:107