Universal ViaVersion 2.2.3

Allow newer versions to connect, why lose players while waiting after a Minecraft update?

    • Agree Agree x 1
  1. I am undergoing extensive testing, so expect more posts from me with similar theme
    BUG REPORT: 1.8.9 clients appear to be holding whatever is in their boots spot in their off hand.

    From a 1.9 client perspective, when someone is wearing boots, they do not appear on their feet, instead they appear on their off hand
    [​IMG]

    BUG REPORT: 1.9 client crash when rendering Item frame
    Simply creating an item frame anywhere the 1.9 client can render it caused this crash, only for the 1.9 client however. could not reproduce with 1.8.9 client
    bug report:
    http://pastebin.com/ZJfN1RzF

    BUG REPORT: Server kick when rendering minecart commandblock
    same as previous bug report, except this wasn't a crash, it was more like a kick.
    pulled from logs: http://pastebin.com/bBGdMD7R

    IMPORTANT EDIT: It seems there are a lot of trouble with entities (I am assuming why this is the cause of the spawn eggs not working. Probably because the entities have been changed so much and considering the error is varying by what entity causes it, wouldn't surprise me if that was the case) I suggest you go through all entities in the game and port their behavior according to expected by the 1.9 client. EDIT2: I was able to create a skeleton using a mob spawner, error was lag. I don't know where the source comes from as I don't have 2 separate computers to test this with, but it is very noticeable, specially when looking at the skeleton from either client
     
    #42 PabloDons, Feb 29, 2016
    Last edited: Feb 29, 2016
  2. FormallyMyles

    Supporter

    Thanks for these kind of reports, they're amazing. I've already patched the armour issue reported. (A version 0.4 will be coming when I gather enough bug fixes).

    These issues occur due to the way data about them is set, not a lot of this data is published. If MCP or what becomes available soon and people still want this updated it will instantly be solved as we'll know them but until then it's a bit hit and miss.
     
  3. FormallyMyles

    Supporter

    Mylescomputer updated ViaVersion with a new update entry:

    Sign Fixes & Armour Display Fixes

    Read the rest of this update entry...
     
  4. Nuu! Don't go to sleep. Almost all of my servers are using Protocollib :(
     
    • Agree Agree x 1
  5. FormallyMyles

    Supporter

    I have been poking at it, some of the code needs quite a bit of work so we can slot around it and have no issues. So not all hope is lost.

    anyway, zzZzzz.
     
  6. I couldn't find a donation link on the plugin overview. Can you add one for me? :p
    EDIT: I sent him $5, salty @GGhost
     
    #49 Terrobility, Mar 1, 2016
    Last edited: Mar 5, 2016
    • Optimistic Optimistic x 1
  7. Great plugin. Hope to see some nice updates! Sorry I know little about packets, otherwise I would be happy to help. I'll definitely donate a fair amount if this plugin is updated to flawlessly support both 1.9 and 1.8.
     
  8. FormallyMyles

    Supporter

    Mylescomputer updated ViaVersion with a new update entry:

    Sound & ArmorStand Fix

    Read the rest of this update entry...
     
  9. Bungee dose support 1.9 and 1.8
     
    • Like Like x 1
  10. I got this error on login, I know you are aware of some json errors but ill just report it here anyway: http://imgur.com/v1wuOga
    No errors in console.
     
  11. @Mylescomputer I would LOVE to use this plugin, but all of my plugins require ProtocolLib. How long do you think it would take to add support for ProtocolLib?
     
    • Agree Agree x 1
  12. Ayuda no funciona. No me deja conectarme en la 1.9 a mi server 1.8.8
     
  13. FormallyMyles

    Supporter

    Mylescomputer updated ViaVersion with a new update entry:

    Entity & Sound Fixes, Including some entity riding

    Read the rest of this update entry...
     
  14. Let me know when this works with protocol lib, I can't wait to use it!
     
    • Agree Agree x 1