Universal ViaVersion 2.2.3

Allow newer versions to connect, why lose players while waiting after a Minecraft update?

  1. I will only use this plugin when it supports Protocollib, i hope it will support protocollib this week :)
     
  2. Same, hopefully today ;)
     
  3. Blabla, are you also using ProtocolSupport? I got the same message with that.
     
  4. Alout of people are getting that message, in like an half hour im disable all my plugins to see which one is doing it, same happen with my bungeecord server and it was caused by some plugin
     
  5. [​IMG]
    When attempting to connect through bungee to the lobby server, when I remove this plugin that msg goes away.
     
    • Agree Agree x 1
  6. No. I removed ProtocolLib plugin.
     
  7. FormallyMyles

    Supporter

  8. Work in Spigot 1.8.8 R.01?
     
  9. Waiting for ProtocolLib support ayy
     
  10. me 2..
     
  11. Tryed in 1.8.8R1 and in 1.8 and always the same error:

    01.03 16:49:25 [Server] INFO [ViaVersion] Enabling ViaVersion v0.3.4 01.03 16:49:25 [Server] INFO ViaVersion enabled, injecting. (Allows 1.8 to be accessed via 1.9) 01.03 16:49:25 [Server] INFO Unable to inject handlers, are you on 1.8? 01.03 16:49:25 [Server] WARN java.lang.NoSuchFieldException: childHandler 01.03 16:49:25 [Server] WARN at java.lang.Class.getDeclaredField(Unknown Source) 01.03 16:49:25 [Server] WARN at us.myles.ViaVersion.ReflectionUtil.get(ReflectionUtil.java:31) 01.03 16:49:25 [Server] WARN at us.myles.ViaVersion.Core.injectPacketHandler(Core.java:48) 01.03 16:49:25 [Server] WARN at us.myles.ViaVersion.Core.onEnable(Core.java:25) 01.03 16:49:25 [Server] WARN at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) 01.03 16:49:25 [Server] WARN at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) 01.03 16:49:25 [Server] WARN at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) 01.03 16:49:25 [Server] WARN at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) 01.03 16:49:25 [Server] WARN at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) 01.03 16:49:25 [Server] WARN at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) 01.03 16:49:25 [Server] WARN at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) 01.03 16:49:25 [Server] WARN at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) 01.03 16:49:25 [Server] WARN at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) 01.03 16:49:25 [Server] WARN at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) 01.03 16:49:25 [Server] WARN at java.lang.Thread.run(Unknown Source)
    [


    Plugins:

    upload_2016-3-1_18-51-31.png
     
  12. Just one thing, "NeedsUpdate", is that my plugin?
     
  13. FormallyMyles

    Supporter

    NametagEdit possibly
     
  14. Removed it and restarted (not reload, stop and start again) and the error is the same
     
  15. ProtocolLib soon??
     
  16. When i connect to my server through bungeecord i have this error (i spawn on a flat map with nothing on it so i think it is related with the chat): upload_2016-3-1_20-6-10.png