Universal ViaVersion 4.0.1

Allow newer versions to connect, why lose players after a Minecraft update?

  1. This may seem like a weird question, but is there a way to run this on a server, and have it only support 1.9.2/3/4? I would like to add compatibility for 1.9.2/3/4 but not 1.9 because as far as I know, there is no moddable client that is 1.9.2. If not, that's fine, just wondering. :D
     
  2. It just says "Disconnected"




    23.05 02:08:16 [Server] INFO UUID of player Goatii is -------------------------------------------- 23.05
    02:08:16 [Connect] User Goatii, IP -----------
    23.05 02:08:16 [Multicraft] Goatii ran command Message of the Day
    23.05 02:08:16 [Server] WARN Failed to transform chunk bulk
    23.05 02:08:16 [Server] INFO java.lang.NullPointerException
    23.05 02:08:16 [Server] INFO at us.myles.ViaVersion.util.ReflectionUtil$ClassReflection.getFieldValue(ReflectionUtil.java:126) ~[ViaVersion-0.8.2.jar:?]
    23.05 02:08:16 [Server] INFO at us.myles.ViaVersion.protocols.protocol1_9to1_8.storage.ClientChunks.transformMapChunkBulk(ClientChunks.java:55) [ViaVersion-0.8.2.jar:?] 23.05 02:08:16 [Server] INFO at us.myles.ViaVersion.protocols.protocol1_9to1_8.Protocol1_9TO1_8.filterPacket(Protocol1_9TO1_8.java:120) [ViaVersion-0.8.2.jar:?]
    23.05 02:08:16 [Server] INFO at us.myles.ViaVersion.api.protocol.ProtocolPipeline.filter(ProtocolPipeline.java:155) [ViaVersion-0.8.2.jar:?]
    23.05 02:08:16 [Server] INFO at us.myles.ViaVersion.handlers.ViaPacketHandler.encode(ViaPacketHandler.java:27) [ViaVersion-0.8.2.jar:?]
    23.05 02:08:16 [Server] INFO at io.netty.handler.codec.MessageToMessageEncoder.write(MessageToMessageEncoder.java:89) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.channel.AbstractChannelHandlerContext.invokeWrite(AbstractChannelHandlerContext.java:658) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.channel.AbstractChannelHandlerContext.write(AbstractChannelHandlerContext.java:716) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.channel.AbstractChannelHandlerContext.writeAndFlush(AbstractChannelHandlerContext.java:706) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.channel.AbstractChannelHandlerContext.writeAndFlush(AbstractChannelHandlerContext.java:741) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.channel.DefaultChannelPipeline.writeAndFlush(DefaultChannelPipeline.java:895) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.channel.AbstractChannel.writeAndFlush(AbstractChannel.java:240) [craftbukkit45.jar:git-Bukkit-12698ea] 23.05 02:08:16 [Server] INFO at net.minecraft.server.v1_8_R3.NetworkManager$4.run(NetworkManager.java:189) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:380) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.channel.epoll.EpollEventLoop.run(EpollEventLoop.java:268) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:116) [craftbukkit45.jar:git-Bukkit-12698ea]
    23.05 02:08:16 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66]
    23.05 02:08:16 [Disconnect] User Goatii has disconnected, reason: Internal Exception: io.netty.handler.codec.EncoderException: ViaPacketHandler must produce at least one message.
     
  3. It's at the moment not possible to disallow a certain version.

    Update to the latest version
     
  4. Can you include some little auto message when player join or some, to "per client message" because i want add ONLY TO 1.9.+ clients some message.
     
  5. FormallyMyles

    Supporter

    Just use our API and code something, ViaVersion.getInstance().getProtocolVersion(Player); :)
     
    • Agree Agree x 1
  6. Just,.. iam not a programator omg..
     
  7. Legoman99573

    Supporter

    Out of curiousity, could you make this plugin auto-updateable. I kindof don't want to always come back and download the update, nothing wrong with that as its worth it. It can be opt-out of ;)
     
  8. FormallyMyles

    Supporter

    As said a billion times:

    The reasons which I'm currently against this:
    • If we deploy a bad build by accident, servers will instantly upgrade to it.
    • This is a protocol modification, reloads are not good. It would require a reboot.
    • Owners become less aware of changes / incompatibilities that could happen to their server.

    You can integrate a wget into your server start script if you wanted, url is in main post.
     
    • Like Like x 1
  9. Legoman99573

    Supporter

    ill try that out.
     
  10. So when I join on 1.9 it works fine. When i join on 1.8 I crash. Any thoughts

    Plugins: HiveJumpPa
     
  11. Thank you a million for this :)
     
    • Like Like x 1
    • Friendly Friendly x 1
  12. Legoman99573

    Supporter

    If this plugin becomes inactive, I'm slapping you with a Guardian. Just reminding as friendly advice :)
     
  13. We are not modifying anything for 1.8 users (If you are on a 1.8-1.8.8 server). Could you post your console log when you crash?
     
  14. FormallyMyles

    Supporter

    Mylescomputer updated ViaVersion with a new update entry:

    Metadata/Crash fixes, and new Build Server!

    Read the rest of this update entry...
     
  15. When I log in to a 1.9 client in 1.8's server I have a cooldown striking . Possible to disable this?
     
  16. This is client-sided. There is an option in the minecraft settings to disable it
     
  17. Thanks for this plugin

    Just one thing
    I i run my server in 1.9.2, clients with 1.9.4 can connect (good)
    Now i want to update my server to 1.9.4 but clients with 1.9.2 can't connect anymore (bad)

    Do you know why ?

    My idea is to put your plugin on all my servers, and update to 1.9.4 step by step
    But if i can't upgrade my hub to 1.9.4 without forcing people to upgrade their client is not good :)

    Thanks
     
  18. Strange! It should work
    Could you post your plugins, spigot version (/ver), and ViaVersion version (/viaver), and if there is any error in the console, could you also post that one? :)
     
  19. Hum, i just try again and it's ok ...

    Don't know if it's needed to make 2 reboots to update configuration or something like that, or if i'm just stupid, but it seems ok now ...

    Sorry
     
  20. Good to hear that :)
     
    • Winner Winner x 1