Spigot Villager Shop GUI 1.10

Shops made easy!

  1. example menu is just a random shop generated to create the menus folder just go to menus and delete it
     
  2. Is there a way to change the skin of the Villager to any Minecraft Player Skin??
     
  3. so like NPC :/ im sorry but no I dont have an option like that and Im too busy to add maybe later :D
     
  4. Kk, all good. If I knew how to code I would do it myself. Can't wait to see if you do it or not. I see another plugin matching the requirements but not wanting to spend $5USD on it. Too poor to buy Plugins ;(
     
  5. love the plugin! i was wondering if there was a way to customize the actual villager? say i wanted a 'blacksmith' villager and i wanted it to wear the stonesmith/toolsmith etc. accessories from 1.14, or a 'farmer' villager and for it to wear a straw hat... is there a way to do that?
     
  6. are you able to make it so the npc's look at the nearest player, so they arent just stuick in one position? I feel like this could be a nice addition to an already great plugin.
     
  7. Hi,
    Plugin is working fine.
    1 issue : If I restart the Server sometimes the Villager disappear. The config is still working but noone can use the buy/sell function.
    To test i had create a new Villager but they don't appear.
    Is ther any possibility to fix this bug by my own?
    Please Help.
     
  8. I dont charge for plugin and so i dont have time to do such things for free for 1 person sorry
     
  9. Worldguard prevents it from spawning if the region it is in has mob-spawning set to false
     
  10. Please update the plugin for 1.15
     
  11. Hi, i've just downloaded and i'm getting this error

    Could not load 'plugins\VillagerShopGUI.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: Unsupported API version 1.15

    I'm running 1.14.4 Spiggot. Is there any 1.14 version?

    Ty for this plugin i really want this on my server :D
     
  12. I'm releasing a new premium version of this plugin with the ability to use citizens plugin and change their mobtype, and also make a trade shop as well, it will more compatiable with 1.14 and its less laggy
     
  13. I absolutely love this plugin, but for some reason the prices all read "buy 1 for $10" and "sell 1 for $5 no matter what I do. When the items are purchased, they're purchased at the right price. Is this an error on my end?
     
  14. I'm confused you can edit the prices to any way you want
     
  15. Yes, I can. But even when I edit the prices, the GUI still shows the wrong price. These are all $0. Every shop I have created and edited the price for all read like this.
     

    Attached Files:

  16. Are you using the latest update? or how about deleting your messages.yml or it could be that your not using the latest update. if you tried all these things and the problem continues then you'll have to wait till the release of the premium version of this plugin
     
  17. It looks like based on the "{10} that you have messed up your messages.yml as it is not supposed to include the "{}"
     
  18. Awesome, thanks! Now the villager won't show up when I create a shop though lol.
     
  19. very likely that you're trying to spawn the villager in a worldguard region where the flag has "mob spawning = false" make a smaller region inside that region with a higher priority and set the mob-spawning to true so that they may spawn