Voting System

Discussion in 'Systems Administration' started by Scorpion, May 15, 2015.

  1. [15-05 14:12:42 ] [Server] WARN java.net.ConnectException: Connection refused
    [15-05 14:12:42 ] [Server] WARN at java.net.PlainSocketImpl.socketConnect(Native Method)
    [15-05 14:12:42 ] [Server] WARN at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
    [15-05 14:12:42 ] [Server] WARN at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
    [15-05 14:12:42 ] [Server] WARN at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
    [15-05 14:12:42 ] [Server] WARN at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    [15-05 14:12:42 ] [Server] WARN at java.net.Socket.connect(Socket.java:579)
    [15-05 14:12:42 ] [Server] WARN at com.swifteh.VoteSend$1.run(VoteSend.java:153)
    [15-05 14:12:42 ] [Server] WARN at org.bukkit.craftbukkit.v1_8_R2.scheduler.CraftTask.run(CraftTask.java:71)
    [15-05 14:12:42 ] [Server] WARN at org.bukkit.craftbukkit.v1_8_R2.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    [15-05 14:12:42 ] [Server] WARN at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    [15-05 14:12:42 ] [Server] WARN at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    [15-05 14:12:42 ] [Server] WARN at java.lang.Thread.run(Thread.java:745)
    [15-05 14:12:42 ] [Server] [Informatie] Vote -> [email protected]*******: Vote (from:SERVERPACTTEST username:Sniffer address:*.*.*.* timeStamp:1431698834)

    I checked for a 1.8.3 votesend but last update was 2013 or...should i try updating votifier 43rd time o_O

    Some votes go through and most dont(out of 10 only 2 work). This is the hub error which has a 62 ip while other servers on our network have a 193(survival) code. idk what the error is, ive switched the port ending with 2 to 3 and tested got errors i tested by changing 62 to 193 in the hub got no error but all end results and changes got to the point where it just did not sent it to the server voted in.
     
  2. anyone got any idea?
     
  3. Is this your own plugin?
     
  4. The "connection refused" error means that wherever it's sending the vote is not responding. Do you have a firewall blocking the port votifier (on those servers) is listening on?
     
  5. votifier and votesend havent had an update in ages(@NickMD) and @FatherSouth how do i check for a "firewall" o_O its not run on my computer so would be within the host(provider of the ram) and the settings i reckon.

    Edit: also 2 links do go through thats why i find it so weird..

    A website 1 of em indeed states: Firewall should be checked, but where o_O
     
    #5 Scorpion, May 17, 2015
    Last edited: May 17, 2015
  6. [17-05 12:24:30 ] [Server] WARN Unable to decrypt vote record. Make sure that that your public key
    [17-05 12:24:30 ] [Server] WARN matches the one you gave the server list.
    [17-05 12:24:30 ] [Server] [Informatie] javax.crypto.BadPaddingException: Decryption error
    [17-05 12:24:30 ] [Server] [Informatie] at sun.security.rsa.RSAPadding.unpadV15(RSAPadding.java:380) ~[?:1.7.0_75]
    [17-05 12:24:30 ] [Server] [Informatie] at sun.security.rsa.RSAPadding.unpad(RSAPadding.java:291) ~[?:1.7.0_75]
    [17-05 12:24:30 ] [Server] [Informatie] at com.sun.crypto.provider.RSACipher.doFinal(RSACipher.java:365) ~[sunjce_provider.jar:1.7.0_75]
    [17-05 12:24:30 ] [Server] [Informatie] at com.sun.crypto.provider.RSACipher.engineDoFinal(RSACipher.java:391) ~[sunjce_provider.jar:1.7.0_75]
    [17-05 12:24:30 ] [Server] [Informatie] at javax.crypto.Cipher.doFinal(Cipher.java:1922) ~[?:1.7.0_75]
    [17-05 12:24:30 ] [Server] [Informatie] at com.vexsoftware.votifier.crypto.RSA.decrypt(RSA.java:65) ~[Votifier.jar:?]
    [17-05 12:24:30 ] [Server] [Informatie] at com.vexsoftware.votifier.net.VoteReceiver.run(VoteReceiver.java:130) [Votifier.jar:?]

    I added the correct public key and everything o_O deleted a few plugins that we dont need updated those that were able to be updated..

    Edit: Redone the settings new ports etc. used the hubs ip which has votesend to send it to the survival server but...nothing comes through..no errors nothing.
     
    #6 Scorpion, May 17, 2015
    Last edited: May 17, 2015
  7. You need GAL and Votitifier
     
  8. i have GAL Votifier AND votesend...
     
  9. Why did you paste an ad for your server in that post?
     
  10. What is your votifier config look like and what does your votesend config look like?
     
  11. host: 62.141.**.***
    port: 8192
    debug: false
    listener_folder: plugins/Votifier/listeners

    servers:
    server1:
    IP: '193.111.***.***'
    Port: 8192
    Key: (A very Long Key)
    Custom: ''
    server2:
    IP: '193.111***.***'
    Port: 8193
    Key: (A very Long Key)
    Custom: ''
    server3:
    IP: '193.111.***.***'
    Port: 8192
    Key: (A very Long Key)
    Custom: ''
     
  12. Leave your host ip in votifier config as 0.0.0.0 and try other ports.

    Your Votesend looks fine though i never tried it but according to the config guide it looks fine. Turn debug to true on votifier. Leave the listeners.
     
  13. if i use the regular with 8192 port i get no console errors other ports or ip i get major errors...and the key never changes either..
     
  14. Why not use 8192 then?
     
  15. because using 0.0.0.0 is invalid and using the old with taht port gives an error and 9000 aswell.
     
  16. I was told by a vid tutorial and by multicraft to leave it alone as 0.0.0.0
     
  17. change the “port” from 8192 to any 4 digit number above 1024

    I got this from mcprohosting's knowledgebase. You have to guess a number that hasnt been taken yet, so follow that =P
     
  18. cant get the error back but few times i got the same error followed by the vote itself, in console, saying something in the lines of who voted from where the timestamp followed by a LOONNNGG number. Trying to get that line back now..

    Edit: And.....[22-05 08:41:57 ] [Server] WARN Protocol error. Ignoring packet - Connection reset
     
    #18 Scorpion, May 22, 2015
    Last edited: May 22, 2015
  19. This is aiming at your protocol lib being out of date. Update it to the correct build from http://ci.shadowvolt.com/job/ProtocolLib/ restart and see if that fixes the issue.
     
  20. yea updated it but still getting errors this is just plainly frustrating...