Spigot VoxelSniperRegions 3.3.2

VoxelSniper area restrictions and brush cooldowns. Supports: WorldGuard, PlotSquared, (7 more)

  1. Reserved
     
    #1 Empire92, May 6, 2015
    Last edited: May 6, 2015
  2. I'm deciding to move it over from Bukkit. Spigot is a much nicer community ;)
     
  3. Useful plugin! Thanks for making this! :)
     
  4. PhanaticD

    Patron

  5. Works wonderfully. The only issue, is very recently (last couple of days), my console has been getting spammed with a "Could Not pass event PlayerMoveEvent to VoxelSniperRegions v3.2.0".

    WorldGuard is updated to most recent version. Come to think of it, the only thing that I updated around the time this error showed up was PlotSquared.

    Error is here: http://pastebin.com/AgieLdEd
     
  6. I'm getting the same problem, the error is so often that I can not see anything else in consoles/logs.
     
  7. @Aberzhulan @d1m0a1n
    Sorry, update VSR. I accidentally compiled it against an older version of WG.
     
  8. Is it possible to add it so users can use v/s in other vanilla worlds? because when they're in the vanilla world without plots, it says "You have no current VoxelSniper Region" if not, maybe that's something you could look at doing in the near future?
     
  9. Give them the bypass permission in that world (most permission plugins support per world perms). Or just add them to the global worldguard region for that world and give them vsr.worldguard
     
  10. ok thanks!
     
  11. Code (Text):
    [13:38:09] [Server thread/ERROR]: Could not pass event PlayerMoveEvent to VoxelSniperRegions v3.2.16
    org.bukkit.event.EventException
            at com.massivecraft.massivelag.inject.event.MassiveLagEventExecutor.execute(MassiveLagEventExecutor.java:77) ~[?:?]
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:270) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.PacketPlayInFlying.a(SourceFile:126) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.PacketPlayInFlying$PacketPlayInPosition.a(SourceFile:57) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_71]
            at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_71]
            at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
            at java.lang.Thread.run(Thread.java:745) [?:1.8.0_71]
    Caused by: java.lang.NoSuchMethodError: com.intellectualcrafters.plot.object.Plot.getRegions()Ljava/util/Set;
            at com.empcraft.vsr.PlotSquaredFeature.getMask(PlotSquaredFeature.java:43) ~[?:?]
            at com.empcraft.vsr.VoxelSniperRegions$7.getMask(VoxelSniperRegions.java:265) ~[?:?]
            at com.empcraft.vsr.VoxelSniperRegions.updateMask(VoxelSniperRegions.java:519) ~[?:?]
            at com.empcraft.vsr.VoxelSniperRegions.onPlayerMove(VoxelSniperRegions.java:451) ~[?:?]
            at sun.reflect.GeneratedMethodAccessor21.invoke(Unknown Source) ~[?:?]
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_71]
            at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_71]
            at com.massivecraft.massivelag.inject.event.MassiveLagEventExecutor.execute(MassiveLagEventExecutor.java:67) ~[?:?]
            ... 15 more
     
    Lastest version both plotsquared & VSR & Voxel......
     
  12. Not Running on Spigot 1.9

    [07:52:16] [Server thread/ERROR]: Error occurred while enabling VoxelSniperRegions v3.2.4 (Is it up to date?)
    java.lang.NoSuchMethodError: org.bukkit.Bukkit.getOnlinePlayers()[Lorg/bukkit/entity/Player;
    at com.empcraft.vsr.VoxelSniperRegions.onEnable(VoxelSniperRegions.java:300) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:291) ~[spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at org.bukkit.craftbukkit.v1_9_R1.CraftServer.loadPlugin(CraftServer.java:361) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at org.bukkit.craftbukkit.v1_9_R1.CraftServer.enablePlugins(CraftServer.java:321) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at net.minecraft.server.v1_9_R1.MinecraftServer.t(MinecraftServer.java:411) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at net.minecraft.server.v1_9_R1.MinecraftServer.l(MinecraftServer.java:376) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at net.minecraft.server.v1_9_R1.MinecraftServer.a(MinecraftServer.java:331) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at net.minecraft.server.v1_9_R1.DedicatedServer.init(DedicatedServer.java:269) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:527) [spigot.jar:git-Spigot-87e2f47-ef13ca4]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_40]

    It's undo-ing everything that a user did
     
  13. Sorry if this is a stupid question but I keep getting "You have no current Voxelsniper region" when trying to snipe in my own plot. I'm using Spigot 1.8.8 with PlotSquared 3.2.26.
    These permissions have been added: voxelsniper.sniper, vsr.notify.greeting, vsr.notify.farewell, vsr.plotsquared
     
    • Agree Agree x 1
  14. You can use VoxelSniper on anyone's plot when using Left hand. Some of my users reported this.
    Could you take a look?

    Thanks!
     
    • Agree Agree x 1
  15. Are you standing in the plot?

    Will do.
     
  16. Yes I am standing on the plot when I receive this error.