Weird problem

Discussion in 'Spigot Help' started by Magicgive, Jul 12, 2018.

  1. Okay, so I'm updating the most current stable build for my server, I do everything I did the first time, it goes well, but I end up with an error (I didn't' get a picture of it because I can't reproduce it). So I try the process again, which gives me this https://ibb.co/np0zST I disabled a lot of security measures, tried running it as administrator, and even reinstalled build tools no beans, at this point I'm half asleep, and I know I'm going to wake up in the morning to some angry people from my server, so I thought I'd pass this on to you wonderful fellows. Any clue

    Also, that error thing is the only piece of info I have pertaining to the thing that's going on, everything else I explained in the post.

    Now I must bid thee goodnight and hit the button to post this before I end up posting it from falling asleep on my keyboard. I'll check this in the morning...
     
  2. Are you using Git Bash? It doesn't look like it from what I can tell.
     
  3. I tried using gitbash, I got this

    [email protected] MINGW64 /c/_Minecraft_/Panik 1.12
    $ java -jar BuildTools.jar
    Loading BuildTools version: git-BuildTools-d729b3d-73 (#73)
    git version 2.18.0.windows.1
    BuildTools
    [email protected]
    Attempting to build version: 'latest' use --rev <version> to override
    Found version
    {
    "name": "1573",
    "description": "Jenkins build 1573",
    "refs": {
    "BuildData": "be360cc298a06b5355ecd057f5b1feb894a73f0f",
    "Bukkit": "bdd0eda71f87cb8ca3b1842bd9bbd43bba5a08bd",
    "CraftBukkit": "57ab4cfc6f4ff526d44319d9b8c79f6848db2de7",
    "Spigot": "642f6d2288b830f41347e8c0a162fbc0584e1579"
    },
    "toolsVersion": 47
    }

    Pulling updates for C:\_Minecraft_\Panik 1.12\BuildData\.git
    Successfully fetched updates!
    Checked out: be360cc298a06b5355ecd057f5b1feb894a73f0f
    Pulling updates for C:\_Minecraft_\Panik 1.12\Bukkit\.git
    Exception in thread "main" org.eclipse.jgit.api.errors.JGitInternalException: Exception caught during execution of reset command. Cannot lock C:\_Minecraft_\Panik 1.12\Bukkit\.git\index
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:234)
    at org.spigotmc.builder.Builder.pull(Builder.java:570)
    at org.spigotmc.builder.Builder.main(Builder.java:287)
    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)
    Caused by: org.eclipse.jgit.errors.LockFailedException: Cannot lock C:\_Minecraft_\Panik 1.12\Bukkit\.git\index
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:250)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:327)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:293)
    at org.eclipse.jgit.lib.Repository.lockDirCache(Repository.java:1183)
    at org.eclipse.jgit.api.ResetCommand.checkoutIndex(ResetCommand.java:404)
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:207)
    ... 3 more

    [email protected] MINGW64 /c/_Minecraft_/Panik 1.12
    $
     
  4. Bump..? I have some pretty angry people rn ;w;
     
  5. md_5

    Administrator Developer

    We suggsted some things on IRC, try moving to a new folder
     
  6. Strahan

    Benefactor

    That or open an administrative command prompt and type:

    Code (Text):
    echo y|rd C:\_Minecraft_\Panik 1.12\Bukkit /s
    cacls C:\_Minecraft_\Panik 1.12 /e /g everyone:f /t
    ...assuming C:\_Minecraft_\Panik 1.12 is just a folder where you are holding BuildTools. If it's the actual server, don't run that cacls part. But then, if it's the server you shouldn't be launching BuildTools from that folder anyway.
     

Share This Page