What is going on?!?

Discussion in 'Performance Tweaking' started by BoomScoom, May 13, 2015.

  1. So I join my server and my ping is -98888 with no bars or 1 bar of connection. I then relog and my ping goes back to normal and same with my connection. I just recently updated to 1.8.3 so what is causing this and how can I fix it?
     
  2. I have had this problem before also. I'm not too sure what caused it but it eventually stopped. Have you tried checking your server tps because my tps would get around 15 when this happened.
     
  3. My TPS don't drop below 19.90 and I have 0 lag. So I don't know what is happening.
     
  4. Hm, I'm not too sure. Maybe someone will come by and help us :D
     
  5. Yeah :D
     
  6. I've seen that before, it appears to be caused by a packet loss. The ping (craftplayer.ping) appears to be like this.
    However this is not confirmed, but I've seen a lot of this before.
     
  7. So How do I fix?
     
  8. Well, you don't.
    Instead, I will fix that ping plugin, making it showing "?" while the value is negative or seemingly incorrect. Because this will be gone in like 20 seconds actually.
     
  9. So you will make a plugin to fix it?
     
  10. NONONO, it cannot be fixed. My ping plugin will detect when the value is not correct, and if it is not correct, it will return a "?" instead of a huge negative value.
     
  11. By the way... I've seen a ping plugin that sends the client a keepalive packet instead of using craftplayer.ping. Maybe that should be a alternative solution, but far more complicated.
     
  12. But it doesnt just affect the ping, it affects the player bar connection as well. It shows a red X
     
  13. Well.... :(
     
  14. ?
     
  15. I use titlemanager for the ping thing
     
  16. I use (and wrote) TabListDeluxe for my ping :D
    But it won't solve your 1 bar / X bar thingy :(
     
  17. The 1 bar X bar thing happened when I upgraded to the latest 1.8.3 spigot build