What is the best version to use for a server?

Discussion in 'Minecraft Discussion' started by Garrett1199, Jun 23, 2016.

?

What version?

  1. 1.8

    64.7%
  2. 1.9

    7.8%
  3. 1.10

    27.5%
Thread Status:
Not open for further replies.
  1. I am currently in the progress of making hub that will have prison, factions, survival, and modded. Now that 1.10 and 1.9 are out I am kinda stuck on which version to use. Should I use 1.9 or 1.10 or go to 1.8?
     
  2. Go to the one that will actually be getting regular updates and bugfixes from the spigot team. 1.10 at the moment, 1.11 about a week after it comes out (Give time for bugfixes) Same going into the future
     
  3. But for prison and factions, the new 1.9 pvp a lot of people don't like. Is there a plugin that disables that and changes it back to 1.8 pvp?
     
  4. There are plugins that can be found that can change the way the PvP works in 1.9+.
     
  5. Do you know if it's possible to have it where someone can connect will all of these versions? Like hypixel does
     
  6. If you want stability and access to new plugins and features (like all the new holo-GUIs), go with the latest stable version that has been out for a couple weeks.

    The only reason to use an older version is if a critically important plugin has not been updated, and has no alternatives.

    Plugins exist to modify small things changed by updates, although honestly, the 1.9 pvp is way better to anyone coming from real pvp games.. old pvp is just spamming. Maybe have different gamemodes or arenas for each type?
     
    • Agree Agree x 2
  7. Prepare your self for a flame war with pvpers :)
     
    • Optimistic Optimistic x 1
  8. You're probably right. I like the new changes but most don't
     
  9. I honestly hate every single version that is above 1.7.10 mainly because of the following reasons:

    Developing some plugins is literly impossible on 1.8 or above without having to look every second to how stuff changed.
    Pvp is in my opinion just garbage at 1.8 and above
     
  10. I play the retardedly fast-paced, imbalanced, elite god 720 n0skope-filled midair PvP in warframe, minecraft autoclicker skurbs can line up to cry. Or something. Whatever skurbs do.

    Developing some plugins is literly impossible on 1.8 or above without having to look every second to how stuff changed.
    Solution? dont use NMS/craftbukkit if you are inexperienced.
    Pvp is in my opinion just garbage at 1.8 and above
    Nothing was changed in pvp between 1.7 and 1.8..
     
  11. Yeah the only debate right now is 1.8 or 1.10. I'm still thinking about which one lol
     
  12. If i had to choose between those 1.8
     
  13. Thanks everyone for the feedback :)
     
    #13 Garrett1199, Jun 23, 2016
    Last edited: Jun 23, 2016
  14. Also if anyone knows a good name for a network that would be great. I dont have one yet...
     
  15. asdfghcraft
     
  16. Great name lol
     
  17. I want something unique that doesn't have the word "craft" like every other server, no offense if your server name has "craft"
     
  18. EzPzLemonSqueezy
     
  19. Just dont use PvP or Craft or Network in the name, then it will be good! :D
     
    • Agree Agree x 1
    • Winner Winner x 1
    • Useful Useful x 1
    • Winner Winner x 1
    • Informative Informative x 1
Thread Status:
Not open for further replies.