When players login to my server, lost items

Discussion in 'Spigot Help' started by HrustakvCZ, Jan 12, 2020.

  1. Hello, I have problem with logging-in to my server. I think it's these plugin: FastLogin or UltraAuth. I have the Lobby Compass plugin, when players join, the compass appears and after it writes: Auto logined, the compass disappears.

    I using Spigot 1.8

    PLEASE HELP ME

    PS:sorry for my english
     
  2. Hey,

    Check your UltraAuth config and see if there's something related to the inventory. Most of auth plugins are protecting the inventory until the player is logged.

    But be careful, If the player have the compass logging in, he may join an other server on your network ( if you use bungee ) without logging in.
     
  3. This is my UltraAuth setting:

    # ANTIBOT IS IN BETA. USE AT YOUR OWN RISK. PLEASE REPORT ANY #BUGS. MAX ACCOUNTS IS NOT DONE. IT WILL NOT WORK. THANK YOU
    settings:
    antibot: true
    maxaccounts:
    amount: 2
    kickonwrongpassword: true
    cmd: none
    min_len: 4
    max_len: 10
     
  4. When I start the server, server has been automaticly stopped
     
  5. [13:09:07 INFO]: [AuthMe] Enabling AuthMe v5.6.0-beta1-b2226
    [13:09:07 INFO]: [AuthMe] SQLite Setup finished
    [13:09:07 INFO]: [AuthMe] Hooked into PermissionsEx!
    [13:09:07 WARN]: [AuthMe] Aborting initialization of AuthMe: [InjectorReflectionException]: Could not invoke constructor of class 'class fr.xephi.authme.command.CommandHandler'
    [13:09:07 WARN]: [AuthMe] THE SERVER IS GOING TO SHUT DOWN AS DEFINED IN THE CONFIGURATION!
    [13:09:07 INFO]: [AuthMe] Waiting for 0 tasks to finish
    [13:09:07 INFO]: [AuthMe] AuthMe 5.6.0-beta1-b2226 disabled!
     
  6. Are you using the latest version of spigot 1.8.8?
     
  7. I am using spigot 1.8
     
  8. Mh, you should use the latest 1.8.8 jar, the plugin isn't loading because of that I think.

    You can found a spigot jar here: https://serverjars.com/view/spigot

    Scroll down and take the 1.8.8 jar file.
     
  9. I have a 30 plugins on 1.8, I try download CrazyLogin plugin
     
  10. FastLogin cant found CrazyLogin. I try
    BungeeAuth
     
  11. Did you look in the configuration like AuthMe stared to?
     
  12. You're using a very old version of spigot. Spigot 1.8 & Spigot 1.8.8 are the same, but 1.8.8 have a lot of bug fixes.

    If you're not able to understand that, then, i will not help you anymore.
     
    • Agree Agree x 1
  13. I found working AuthMe for my version. Now its working, thanks:)
     
  14. Please use 1.8.8. There is no reason not to do as it is the same version, but with bug fixes. Normally your plugins should all work on 1.8.8 if they work on 1.8
     
  15. And it will work when I have some plugins on CB 1.7.9-R0.2 ?
     
  16. Why would you even want to use that version?
     
  17. Because some plugins not for for version 1.8
     
  18. 1.7.9 plugins are mostly not optimized & 5 years old. Only thing u will have by using these plugins is a lot of problems who will never be solved.