Why are some people still in 1.8 or 1.7?

Discussion in 'Spigot Discussion' started by AmirehGamer, Apr 17, 2017.

  1. Hey,

    Just like what the title says, why are some servers still running 1.8 or 1.7? Heck, I’ve even seen some servers in 1.6 Why not just be in the latest version (just like me)? Is it because of a new update that no one likes?

    Thanks
     
    #1 AmirehGamer, Apr 17, 2017
    Last edited: Feb 3, 2019
    • Like Like x 2
  2. Gaxan

    Supporter

    1.8 is about PvP, 1.8 PvP is click as fast as you can to win. I find it boring but most people are used to it and that's what they prefer.

    1.7 I'm not really sure unless it has something to do with really bad computers and not able to run newer clients.
     
    • Funny Funny x 4
    • Like Like x 2
    • Agree Agree x 1
  3. After 1.8 they made some huge changes to pvp, a lot of people disagree with or don't like the changes. That's the main reason I think people are still running 1.8
     
    • Agree Agree x 2
    • Like Like x 1
  4. You are correct. In 1.8 they chanted some pvp stuff so now the "good pvpers" only play on 1.7 because it has the "good pvp".
     
    • Like Like x 1
    • Agree Agree x 1
  5. I don't really mind the new PvP.
     
    #5 AmirehGamer, Apr 17, 2017
    Last edited: Jan 3, 2018
    • Agree Agree x 4
    • Like Like x 3
    • Funny Funny x 1
  6. In my opinion, new PVP is terrible. It's just so different, which I don't like. I'm not saying change is bad, but Minecraft really isn't Minecraft anymore.
     
    • Agree x 15
    • Funny x 3
    • Like x 1
    • Informative x 1
    • Optimistic x 1
  7. latiku

    Supporter

    1.8+ pvp is just not the same
     
    • Agree Agree x 4
    • Like Like x 1
  8. EDIT: Removed to prevent people from dying of laughter. Appearently this was way too funny for people to handle.

    [​IMG]
     
    #8 Spoch, Apr 17, 2017
    Last edited: Apr 21, 2017
    • Funny Funny x 9
    • Like Like x 1
    • Winner Winner x 1
    • Optimistic Optimistic x 1
  9. 1.7 & 1.8 have the same PVP mechanics - just sword blocking looks different. Players won't update past 1.9 because they don't like the combat changes even though the mechanics can be reverted on servers. I see no other reason for players not to update.

    People have had the last year to learn the new mechanics but still haven't bothered to update.
     
    • Agree Agree x 5
  10. They also changed block designs for glass panes and iron bars which messed up parkour.
     
    • Agree Agree x 5
    • Funny Funny x 2
    • Like Like x 1
  11. What a reason.
     
    #11 AmirehGamer, Apr 17, 2017
    Last edited: Feb 3, 2019
    • Agree Agree x 1
  12. I still run my servers on 1.7.10 because that's the LOTRMod version.
     
    • Like Like x 1
  13. Why can't you? If you run 1.8.x, ViaVersions will let users using any version of client 1.8 or + to join your server.
     
    • Like Like x 1
    • Agree Agree x 1
  14. That's what I'm confused about. I want my server to have all the 1.11 features, but if I make my server 1.11, I won't have a lot of players. Plus ViaVersion causes a lot of issues with other plugins.
     
    • Like Like x 1
  15. Choco

    Moderator

    This is my most favourite image in the entire Minecraft community
    [​IMG]
    Note how 1.11 and 1.11.2 have 7769 servers (69.6%) are using 1.9+, whereas only 3413 servers (30.5%) are using 1.8 and below. Granted, these aren't all the severs in the world, but Dinnerbone also confirmed a while back on Twitter that the statistics showed that 1.8 users are in the minority. It's finally dying out, and I cannot wait to finally kill it off

    This is also shown more prominently in my VeinMiner statistics which supports versions 1.8.0 -> 1.11.2. Nearly 75% of servers use this version, and it's both amazing and relieving to see this statistic
    [​IMG]

    It's absolute hell once you try to maintain 5 versions. Nearly impossible to do for both developers and server owners without looking and feeling like absolute crap.
     
    #15 Choco, Apr 17, 2017
    Last edited: Apr 17, 2017
    • Like Like x 6
    • Agree Agree x 2
    • Funny Funny x 1
    • Informative Informative x 1
  16. Celebrimbor

    Patron

    1.8 because the mega minigame servers draw the hordes of kids that can't comprehend strategy (need spam click pvp and the best ping and FPS wins) and 1.7 because if the server is spam click pvp, 1.7 clients have an advantage over 1.8 clients. 1.7 holdouts quite literally hold the server owner hostage with their activity because they NEED that advantage, so if it goes away, they go find the next server trying to host every color under the rainbow with both forwards and backwards compatibility via protocol hacks.

    The day the mega servers move on (maybe never?) is the day 1.7 and 1.8 die. Until then, it's a slow death with features casting shadows on spam click pvp.

    New blocks, new dragon, new end, new mobs, new mansions, new items, elytra, shulker box, etc etc....how many features does it take to eclipse 1.8 spam click pvp? We are almost to 1.12...so let's find out. :)

    @2008Choco Where is that graph sourced? Is that current (updated regularly)?
     
    • Agree Agree x 2
  17. Celebrimbor

    Patron

    Java 8 vs Java 7
     
    • Agree Agree x 3
  18. Choco

    Moderator

    1st graph, bottom right, "minecraft-statistic.net". It's kept up to date constantly. Again, it's not all servers, but it's a good representation of what people are playing on most often. As for the second graph, it's VeinMiner's MCStats page
     
  19. omg i'ma post this on badlion forums.
     
    • Funny Funny x 1
  20. Celebrimbor

    Patron

    Oh? Should I increase my security? Will it offend a massive network of kiddies? ;)
     
    • Like Like x 1
    • Friendly Friendly x 1