Solved Why can't people join my server?

Discussion in 'Spigot Help' started by luismayme, Aug 29, 2020.

Thread Status:
Not open for further replies.
  1. Hello, so I'm trying to set up a server to play with friends (spigot 1.16.2 lastest build) and I have everything setup. In server properties the server ip is on my private ip4 adress, I have the windows firewall deactivated and I have DMZ host setup for my ipv4. No antivirus active... I don't know why people is still not able to join through my public ipv4
     
  2. You don't provide enough information, is it hosted on your pc (i think it)? But did you give them the ip they are supposed to join? Btw use Papermc, its more optimized than spigot.
     
  3. Yes, my computer is hosting it and I think I did give them the ip adress they need. The one that whatismyipadress provides. And I don't know what is papermc tbh.

    UPDATE: tried papermc and same thing happens, I can't reach the server from the public ip
     
    #3 luismayme, Aug 29, 2020
    Last edited: Aug 29, 2020
  4. Make sure your friends are connecting using a port that you've configured to be forwarded in your network. The default for Minecraft is 25565. If you don't know how to port forward, it's usually very dependent on the router you use, so google it with your router type specified.
     
  5. The port is forwarded on the router for both TDP and UDP and yet nothing, I also setup the DMZ host and forwarded the ports on my firewall as well. Even tried disabling completely the firewall, still nothing... I've setup some servers before, but for some reason this one doesn't work. I can't even reach the server from the public ip either.
     
  6. Usually in a situation like that it's some tiny obscure issue that takes forever to hunt down. My advice is that you try from scratch using a different port and see what you can do.
     
  7. I'm checking ports with https://canyouseeme.org/ and it appears they are not visible to external souces. But still I don't get it. The DMZ by itself should fix this, but I also have the port forwarded at the same time. I've tried a lot of ports and they are all unreachable from a external host... I don't get why.
     
    • Agree Agree x 1
  8. Strahan

    Benefactor

    The Windows firewall should not be disabled, just poke a hole in it for 25565. Disabling it can cause problems. Also be sure your internet device's firewall has a rule to allow 25565. You don't need UDP unless you use query. It's best to leave server.ip blank in server properties btw, but it isn't the cause of your issue.
     
  9. I was actually surprised that it's actually not in that range, for some reason it starts with 217.xxx.xxx.x does that mean something? I'm not using any proxy. I would say my issue is related with my ISP, I'm trying to contact them, but nothing for now. Do you know of any fix I can do manually?
     
  10. Both the router firewall and my computer's have an exception for the 25565 port.
     
  11. I really don't know as that was just the specific problem that I had.
    Hopefully your ISP or someone else will be able to help you.
     
    • Agree Agree x 1
  12. if you haven't figured it out you can always call me on Discord Soul#0455
     
  13. Okay, I'm going to put this thread as solved. As Vendo just said it had to do with my ISP. They gave me a private ipv4 by default because there are just a few public ipv4 remaining, they changed it and it's solved. Thanks for the help to everyone who replied.
     
Thread Status:
Not open for further replies.