Spigot Wilderness-Tp 3.15.2

Teleports to random location with sounds cost and cooldown along with GUI

  1. Code (Text):
    [19:45:00 ERROR]: Could not pass event PlayerInteractEvent to Wild v3.8.2
    org.bukkit.event.EventException
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at org.bukkit.craftbukkit.v1_11_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:232) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.PlayerConnection.a(PlayerConnection.java:949) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.PacketPlayInBlockPlace.a(PacketPlayInBlockPlace.java:26) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.PacketPlayInBlockPlace.a(PacketPlayInBlockPlace.java:1) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_111]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_111]
    at net.minecraft.server.v1_11_R1.SystemUtils.a(SourceFile:46) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.MinecraftServer.D(MinecraftServer.java:747) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.DedicatedServer.D(DedicatedServer.java:399) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot-R0.1-47414001a02-a1d3777d890-50702e72bc0.jar:git-Spigot-4741400-a1d3777]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_111]
    Caused by: java.lang.NullPointerException
    Keep getting this error in console. Latest Spigot build.
     
  2. @Qball yes when asked to enter the min and max if you write some some it will output that...

    Are you using the Conversation API for spigot?
    If not I woulld recommend doing that :)
     
  3. I use the AsyncPlayerChatEvent and I do not take into consideration the thought of someone not putting a number b/c I feel it is unneeded; but I will add a check to make sure it is only numbers for the min and max. You are talking about setting it thru the GUI right?
     
    #483 Qball, Feb 5, 2017
    Last edited: Feb 6, 2017
  4. Please in the future use a pasting site like hastebin or pastebin, but is that all there is to this error again there is no line number so it will take some time to fix.


    Update:
    @Shilofax Please update your version of the plugin it is outdated.
    @Unlimited Same goes for you
     
    #484 Qball, Feb 5, 2017
    Last edited: Feb 5, 2017
  5. I have a question.
    When you do a command it says Command can not be used in this world, but I want to be able to use the command in the Factions World but when doing /wild it sends you to the default world, you have to add the world (I know), but can you do /wild in Factions and get sent to the default world (world) without the messenge command can not be used in this world.
     
  6. Are you using FBasics?
     
  7. Do you have FBasics true in the config?
     
  8. then for now use /rtp
     
  9. Qball updated Wilderness-Tp with a new update entry:

    Recode One of Many Needed

    Read the rest of this update entry...
     
  10. Is there a way to have a portal in one world to TP to another world randomly?

    Also, I create a portal using /wildtp wand, selecting the corners and doing /wildtp create test & it works, but in my portals file there is nothing there. Please help.

    Edit :
    Once I restarted the server it showed up. Still not seeing an option to randomly tp to a different world, however... :/
     
  11. To allow that you need the addon for this plugin here is a link to it https://www.spigotmc.org/resources/wildaddon.30861/. Once you setup the addon it should take you from world A to world B.
     
  12. This worked, thanks a ton! :) I didn't know this existed, sorry for the stupid question hehe.
     
  13. It wasn't a stupid question, but anyway no problem
     
  14. Now I seem to have an issue where if I use the portal, it displays the message twice. Any known fix?
     
  15. Thats on my end so I will fix that
     
    • Winner Winner x 1
  16. Let me know when it is fixed, looking forward to it!