Will plugin made on api-version 1.16 work on 1.14 and 1.15?

Discussion in 'Spigot Plugin Help' started by szym402pl, Jun 18, 2021.

Thread Status:
Not open for further replies.
  1. So, I made some plugins. Although my friend told me they work on 1.14 and 1.15, I'm not 100% sure. If I set api-version: 1.16, will my plugins work on 1.14 and 1.15?
     
  2. You can set an api-version to 1.13, it will works on 1.13, 1.14, 1.15, and so on.
    The reverse is not true: setting an 1.14 api version on 1.13 will not work.
     
    #2 Andross, Jun 18, 2021
    Last edited: Jun 18, 2021
  3. If you set api-version to 1.16, versions below 1.16 will not work.
     
  4. For a slightly more information:

    The above is taken from https://www.spigotmc.org/wiki/plugin-yml/.
     
  5. A great way to keep server owners current is by stopping support for grossly outdated versions. Nothing wrong with 1.16. If enough developers do this then server owners who dont want to upgrade can keep using old jars, and those who stay current have the latest greatest.
     
    • Agree Agree x 1
  6. Alright, I'm closing the thread.
     
Thread Status:
Not open for further replies.