World Guard ERROR

Discussion in 'Spigot Plugin Help' started by PixelationYT, Jun 5, 2018.

  1. Spigot Version: git-Spigot-db6de12-18fbb24 (MC: 1.8.8)
    World Guard Version: WorldGuard 6.2.1;84bc322


    Error:
    [12:26:25 WARN]: [WorldGuard] WorldGuard encountered an unexpected error
    java.lang.NoSuchMethodError: com.google.common.base.Preconditions.checkState(ZLjava/lang/String;Ljava/lang/Object;)V
    at com.sk89q.worldguard.internal.guava.util.concurrent.Futures.getDone(Futures.java:1170) ~[WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.Futures$4.run(Futures.java:1121) [WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:435) [WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.AbstractFuture.executeListener(AbstractFuture.java:900) [WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.AbstractFuture.complete(AbstractFuture.java:811) [WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.AbstractFuture.set(AbstractFuture.java:653) [WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.TrustedListenableFutureTask$TrustedFutureInterruptibleTask.runInterruptibly(TrustedListenableFutureTask.java:111) [WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.InterruptibleTask.run(InterruptibleTask.java:58) [WorldGuard.jar:?]
    at com.sk89q.worldguard.internal.guava.util.concurrent.TrustedListenableFutureTask.run(TrustedListenableFutureTask.java:75) [WorldGuard.jar:?]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_131]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_131]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_131]
    [12:26:25 INFO]: Failed to fetch region list: WorldGuard: An unexpected error occurred! Please see the server console.


    Thanks!
     
  2. Can you give some information about what you did to cause the error?
     
    • Useful Useful x 1
  3. All commands of worldguard print this error :/
     
  4. /rg define /rg create /rg list.... All
     
  5. You need to use WorldGuard 6.1.2
     
  6. Why I cant use 6.2.1? Bugged?
     
  7. It said on the worldguard page for 6.2.1 that its 1.12-1.12.2 only
     
    • Agree Agree x 1