World guard wont start

Discussion in 'Performance Tweaking' started by Jackkx_x, May 20, 2016.

  1. I have world guard and world edit installed, And for some reason world guard wont start here is what console says on startup. If anyone could help with this it would be much appreciated

    [12:41:01] [Server thread/ERROR]: Could not load 'plugins/worldguard-6.1.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/Injector
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:275) [spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at org.bukkit.craftbukkit.v1_9_R1.CraftServer.loadPlugins(CraftServer.java:296) [spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at net.minecraft.server.v1_9_R1.DedicatedServer.init(DedicatedServer.java:201) [spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:527) [spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72-internal]
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/Injector
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_72-internal]
    at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_72-internal]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    ... 6 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.Injector
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381) ~[?:1.8.0_72-internal]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_72-internal]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_72-internal]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_72-internal]
    at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_72-internal]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-e6f93f4-ed60c01]
    ... 6 more
     
  2. you have to install WorldEdit
     
  3. i have world edit installed
     
  4. Are you sure you have the latest version of both WG and WE? Which version of Spigot are you using? If you're on 1.9.x, I believe you'll need to get a development version of WG.