World PvP Disable

Discussion in 'Spigot Discussion' started by BitCash, Dec 4, 2018.

  1. So basically pvp in a specific world is disabled. All other worlds created w/multiverse have pvp enabled.

    Yes I have enabled PvP in my worldguard region
    Yes I have made the PvP regions highest priority
    No pvp is not disabled in Multiverse
    No pvp is not disabled in server.properties
    No pvp is not disabled in Essentials
    No there is no spawn-protection limit in server.properties
    Yes I've checked plugin configs
    Yes I've re installed WorldGuard, WorldEdit, Multiverse and their configs

    I've tried everything to try and enable it, here is my plugins list:
    Plugins (63): PlaceholderAPI, DeluxeJoin, PlugMan, NametagEdit, DeluxeTags, RandomTeleport, ViaVersion, Tablist, HideStream, LuckPerms, ClearLag, ViaRewind-Legacy-Support, WorldBorder, Votifier, EasyBackup, Multiverse-Core, VoidSpawn, ProtocolLib, GuiRedeemMCMMO, MVdWPlaceholderAPI, FastAsyncWorldEdit, IPWhitelist, 2FA, DeluxeMenus, FeatherBoard, mcMMO, BitCashVouchers, Vault, GAListener, DailyRewards, ViaRewind, BlockParticles, CrazyCrates, UltraCosmetics, FastAsyncVoxelSniper, SimpleRename, MoneyPouch, HolographicDisplays, AuctionHouse, ChatItem, VoxelSniper, MyCommand, EZRanksPro, CustomPayloadFixer, ShopGUIPlus, WorldEdit, Essentials, BuycraftX, DeluxeChat, Citizens, DiscordSRV, HolographicExtension, CrazyEnvoy, WorldGuard, Quests, CommandNPC, EssentialsSpawn, PremiumVanish, Jobs, GriefPrevention, PluginLibrary, TitleManager, VoidGenerator

    Any help would be much appreciated, thanks.
     
  2. enterih

    Patron

    which mcversion are you using?
     
  3. 1.8.8 Spigot, and I would prefer not to move to 1.13.2 due to custom plugins being built for 1.8-1.7 API
     
  4. enterih

    Patron

    i just wanna recommend to use essentialsX instead of the spigotessentials
     
    • Agree Agree x 2
  5. I am using EssentialsX latest build
     
  6. Perhaps you should check over WorldGuard and it's configuration.
    I think that you can use a command like
    Code (Text):
    /region info world myworldname
    The 'world' file could be damaged for some reason.
     
  7. godmod or spawnprotection ?
     
  8. GriefPrevention did you look, mycommand(maybe you do dont give damage to op), mcMMO, randomteleport
    I don't know maybe this plugins is not doing but look.
    And look spigot.yml , bukkit.yml
     
  9. Issue resolved by deleting the world
     
  10. go into the Multiverse configuration for all the words and turn PVP off
     
  11. Or visit the separate worlds and do /rg flag __global__ pvp deny
     
  12. He fixed problem, so problem solved.
     

Share This Page