Solved WorldEdit NoClassDefFoundError

Discussion in 'Spigot Plugin Development' started by xlightx, Aug 2, 2020 at 6:23 PM.

  1. Hi. I don't really understand what is the problem with my plugin.

    I did put WorldEdit and FAWE depend on plugin.yml . I also put WorldEdit 6.0.0 and FAWE to pom.xml

    But it still not working for some reason. The code is just:

    Code (Text):
    ClipboardFormat format = ClipboardFormats.findByFile(file);
    pom.xml


    Log:

     
  2. Check what version of worldedit or fawe you have installed on your server.
    From what i remember worldedit versions 5.6 & below dont have clipboard & schematics support
     
    • Like Like x 1
  3. Thank you. I will check it tomorrow! The thing is I mainly use FAWE and it automatically install the WorldEdit jar to my plugins folder.

    Doesnt Fawe not recommend you to install WE and let it do the job?
     
  4. FAWE is built over worldedit. meaning that almost all of worldedit libraries & methods are present in it. So yeah you only need either FAWE or worldedit. Having both can cause problems.
    also its the same for FAWE as well older versions dont have clipboard
     
  5. Thanks. FAWE is downloading WE version v6.1.7. This version doesn't have clipboard or something? I'm still getting the same error.....and I don't understand why

     
    #5 xlightx, Aug 3, 2020 at 2:02 AM
    Last edited: Aug 3, 2020 at 2:10 AM
  6. So okay. I have fixed my problem again...Took me 2 hours

    First of all, the structure of my file somehow messes up because ????. I have to flush my .m2 folder and reimport again (maybe it is not that important)

    What more important is, when I type ClipboardFormats, the IntelliSense shows it exists but, in fact, it's not.

    ClipboardFormats.findByFile only works with WE7.

    If you're using WE6, you have to use ClipboardFormat.findByFile (without the plural). Therefore you cannot use FaweAPI.load().paste()