Spigot WorldEditSelectionVisualizer [1.7.10-1.17] 2.1.0

Visualize your WorldEdit selection with particles and without any mod.

  1. Has this plugin updated to 1.10? The last update I saw was in March, and since it is version dependent I doubt it will work. Give the author some time, remember, they are doing this for free.
     
  2. Legoman99573

    Supporter

    True, they didn't have to bring a plugin back from the dead. People just show alot of disrespect towards Developers these days.

    Plus it does stay stuck on loading the plugin. No errors, just freezing on loading.
     
  3. Well that kinda sucks, this was one of the most useful plugins i've ever seen. I wish the creators of worldedit could build in such a system into worldedit. Or maybe the creator of AsyncWorldedit can add something similar to this plugin.
     
  4. Legoman99573

    Supporter

    I wonder if there is an API for the StructureBlocks highlight method, it seems quite useful once there is a toggle command or config option, then it would kind of make a little sense.
     
  5. hi =)


    can you update for spigot 1.10 ?

    don't works for me :)
     
    • Agree Agree x 1
  6. I thought the makers of WorldEdit doesn't give a damn what we like or not, especially when a dependent plugin like WorldEdit starts to lose its grip and flaws fill the console, and your screen, (doors, beds, signs, and others)
    A pity those problems are no priority, and i do not understand why Mojang doesn't buy the rights for such essential plugin and integrate it in the server...... Would be nice, but hey, i guess they all sit on a sandy beach sipping pina colada and watch the sun tanned assesments of beach babes over the ridge of their screen of their laptop, playing volleyball. lol!
     
    • Funny Funny x 2
    • Agree Agree x 1
  7. I am also having trouble with this plugin on Spigot 1.10.

    The plugin loads initially but I see no visualization of region in the game after enabling with /wesv. Game shows "Your visualizer has been enabled".


    Code (Text):
    [23:03:14 WARN]: [WorldEditSelectionVisualizer] Task #6 for WorldEditSelectionVisualizer v1.4.3 generated an exception
    com.darkblade12.particleeffect.ParticleEffect$ParticlePacket$VersionIncompatibleException: Your current bukkit version seems to be incompatible with this library
    at com.darkblade12.particleeffect.ParticleEffect$ParticlePacket.initialize(ParticleEffect.java:378) ~[?:?]
    at com.darkblade12.particleeffect.ParticleEffect$ParticlePacket.<init>(ParticleEffect.java:337) ~[?:?]
    at com.darkblade12.particleeffect.ParticleEffect.display(ParticleEffect.java:176) ~[?:?]
    at com.darkblade12.particleeffect.ParticleEffect.display(ParticleEffect.java:180) ~[?:?]
    at com.rojel.wesv.ParticleSender$1.run(ParticleSender.java:75) ~[?:?]
    at org.bukkit.craftbukkit.v1_10_R1.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at org.bukkit.craftbukkit.v1_10_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350) [spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at net.minecraft.server.v1_10_R1.MinecraftServer.D(MinecraftServer.java:741) [spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at net.minecraft.server.v1_10_R1.DedicatedServer.D(DedicatedServer.java:399) [spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at net.minecraft.server.v1_10_R1.MinecraftServer.C(MinecraftServer.java:672) [spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:571) [spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_91]
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_10_R1.Packet63WorldParticles
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-R0.1-c55900f7285-63839165bc6-eb9f4ee387c.jar:git-Spigot-c55900f-9856d8a]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_91]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_91]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_91]
    at java.lang.Class.forName(Class.java:264) ~[?:1.8.0_91]
    at com.darkblade12.particleeffect.ReflectionUtils$PackageType.getClass(ReflectionUtils.java:244) ~[?:?]
    at com.darkblade12.particleeffect.ParticleEffect$ParticlePacket.initialize(ParticleEffect.java:371) ~[?:?]
    ... 11 more

    I am happy to test or provide more info as needed.
     
  8. Mister, i have respect for those pluginmakers, believe me, if i could make a plugin, i would done it already. That's not the issue, there is a large group of serveradmins that yern for better control of their servers, and the more plugins they use, the more can go wrong. The time the developers use to make, update and refine a plugin is in my opinion a fraction of maintenance on a server with thousands users nagging that this and that does not work, ever heard any serveradmin complain about that? So, please, developers of plugins, please make those plugins available for the latest MC/Spigot/Bukkit/ETC...
     
    • Agree Agree x 1
  9. I'm running Spigot 1.10 and 1.10.2 and running worldguard-legacy-6.1.3-SNAPSHOT-dist-#1679, worldedit-bukkit-6.1.4-SNAPSHOT-dist-#3572 when I make a selection my logs get spammed with this error:

    Code (Text):
    [07:00:05] [Server thread/WARN]: [WorldEditSelectionVisualizer] Task #33 for WorldEditSelectionVisualizer v1.4.3 generated an exception
    com.darkblade12.particleeffect.ParticleEffect$ParticlePacket$VersionIncompatibleException: Your current bukkit version seems to be incompatible with this library
        at com.darkblade12.particleeffect.ParticleEffect$ParticlePacket.initialize(ParticleEffect.java:378) ~[?:?]
        at com.darkblade12.particleeffect.ParticleEffect$ParticlePacket.<init>(ParticleEffect.java:337) ~[?:?]
        at com.darkblade12.particleeffect.ParticleEffect.display(ParticleEffect.java:176) ~[?:?]
        at com.darkblade12.particleeffect.ParticleEffect.display(ParticleEffect.java:180) ~[?:?]
        at com.rojel.wesv.ParticleSender$1.run(ParticleSender.java:75) ~[?:?]
        at org.bukkit.craftbukkit.v1_10_R1.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at org.bukkit.craftbukkit.v1_10_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350) [spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at net.minecraft.server.v1_10_R1.MinecraftServer.D(MinecraftServer.java:741) [spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at net.minecraft.server.v1_10_R1.DedicatedServer.D(DedicatedServer.java:399) [spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at net.minecraft.server.v1_10_R1.MinecraftServer.C(MinecraftServer.java:672) [spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:571) [spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72-internal]
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_10_R1.Packet63WorldParticles
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.10.jar:git-Spigot-c3e4052-1953f52]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_72-internal]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_72-internal]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_72-internal]
        at java.lang.Class.forName(Class.java:264) ~[?:1.8.0_72-internal]
        at com.darkblade12.particleeffect.ReflectionUtils$PackageType.getClass(ReflectionUtils.java:244) ~[?:?]
        at com.darkblade12.particleeffect.ParticleEffect$ParticlePacket.initialize(ParticleEffect.java:371) ~[?:?]
        ... 11 more
     
     
    #29 Ironic_8b49, Jul 5, 2016
    Last edited: Jul 5, 2016
  10. "Your current bukkit version seems to be incompatible with this library" WorldEditSelectionVisualizer has not updated to 1.10 yet.
     
    • Like Like x 1
  11. thanks for the update, I removed this plugin when it stopped working, glad you took the time to update it
     
  12. been trying to figure out what I have set wrong or is it a bug? The redstone effect show up but they never go away no matter how I sett things in the config
     
  13. It's been a while I used the plugin myself, but according to the documentation:

     
    • Like Like x 1
  14. Well it works fine if I use a wooden_axe as the wand, but I use a stick since the wooden axe is used in game play. when I changed it back to stick and tested one more time it now works go figure
     
    • Like Like x 1
    • Funny Funny x 1
  15. MY Review Quote
    "Working fantastic.... was / still am - using Lightloader cui - lol - both working at the same time ...unnecessary but easier - when doing co-op projects - thanks for mantaining this great pluging.
    Please be ready for mc1.11 or is it mc1.12 lol lol.............Llama Llama.!"
    (4min reply time - spigot first lol lol)

    Am using v1.4.4 for mc1.10.2 - changed particle to green type..."happyVillager" and set spacing to equal 1 block wide ( so it looks like green tile spacers...lol.
    Found the red particle effect animaton to slow and distracting.

    See below link for pictures...of types particles you can use......
    http://minecraft.gamepedia.com/Particles
    Thanks again for maintaining this plugin.
    2016-11-04_23.03.16.png
     
    #37 DaDMaR777, Nov 4, 2016
    Last edited: Nov 4, 2016
    • Useful Useful x 1
  16. 1.4.4 version boots with no errors in 1.11 and works for the settings i use.
     
    • Winner Winner x 1
  17. That's quite a useful piece of information, thank you Sir :)
     
  18. Ever since the update, it causes my builders to lagg out?