WorldGuard 1.8 Spigot Causing Lag

Discussion in 'Spigot Plugin Help' started by MineGamer69, Jul 13, 2018.

  1. 13.07 02:53:51 [Server] WARN WorldGuard encountered an unexpected error
    13.07 02:53:51 [Server] INFO java.lang.NoSuchMethodError: com.google.common.base.Preconditions.checkState(ZLjava/lang/String;Ljava/lang/Object;)V
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.Futures.getDone(Futures.java:1170) ~[worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.Futures$4.run(Futures.java:1121) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:435) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.AbstractFuture.executeListener(AbstractFuture.java:900) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.AbstractFuture.complete(AbstractFuture.java:811) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.AbstractFuture.set(AbstractFuture.java:653) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.TrustedListenableFutureTask$TrustedFutureInterruptibleTask.runInterruptibly(TrustedListenableFutureTask.java:111) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.InterruptibleTask.run(InterruptibleTask.java:58) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at com.sk89q.worldguard.internal.guava.util.concurrent.TrustedListenableFutureTask.run(TrustedListenableFutureTask.java:75) [worldguard-6.2.1.jar:?]
    13.07 02:53:51 [Server] INFO at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_144]
    13.07 02:53:51 [Server] INFO at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_144]
    13.07 02:53:51 [Server] INFO at java.lang.Thread.run(Unknown Source) [?:1.8.0_144]
    13.07 02:53:54 [Multicraft] Skipped 30 lines due to rate limit (30/s)
    Can any one help me fix this!!
     
  2. md_5

    Administrator Developer

    Update to 1.12.2
     
    • Agree Agree x 2
    • Like Like x 1
    • Winner Winner x 1
    • Informative Informative x 1
  3. i cant our server is 1.8.8 based plugins you should make a update to 1.8.8 version @md_5
     
    • Optimistic Optimistic x 2
  4. MiniDigger

    Supporter

    I am pretty sure that most of your plugins would still work on 1.12 or that there are proper replacements for 1.12. that's not an excuse to run ancient software.
     
    • Agree Agree x 1
  5. If you want to use an old version of the server software, at least make sure you use the right version of plugins. 6.2.1 is not compatible with 1.8. 6.2 is for MC up to 1.11. It's right there on the release page. It's crazy how often this comes up in the forums and issue tracker.
     

Share This Page