WorldGuard does not work on MC 1.12. x

Discussion in 'Server & Community Management' started by EliteMx, Mar 6, 2018.

Thread Status:
Not open for further replies.
  1. Good day, group I contacted you because I am looking for a solution to my problem.

    I have already changed the Spigot, Multiverse Core, WorlEdit and WorldGuard versions.
    When I run it locally everything works fine, but when I upload it to the hosting it fails

    The spigot version I use is 1.12.2

    The plugins I have are these:
    Code (Text):
    Revenge, PlaceholderAPI, PerWorldPlugins, EasySetSpawn, NametagEdit, LoginAuthentication, CustomRecipes, SuperTrails, SimpleSpawners, DropProtect, ViaVersion, Tablist, ViaBackwards, GreatKits, ClearLag, ArmorStandEditor, Scoreboard, ActionHealth, ProtocolLib, EnhancedBalTop, FastAsyncWorldEdit, OreGen, PermissionsEx, PTweaks, CS-CoreLib, Vault, ServerListPlus, ViaRewind, EpicRename, Announcer, ASkyBlock, ChatItem, WorldEdit, Essentials, Multiverse-Core, BannerMaker, DiscordSRV, EssentialsChat, TimeIsMoney, Multiverse-Portals, HolographicDisplays, WorldGuard, SkinsRestorer, Slimefun, Multiverse-Inventories, EssentialsSpawn, MultiWorldMoney, RedProtect, SlimefunLuckyBlocks, HolographicExtension, SlimefunOres
    I add the console log to see if you find it in error.

    WorldGuard Error:

    Code (Text):
    [14:22:41] [Server thread/ERROR]: Error occurred while enabling WorldGuard v6.1 (Is it up to date?) java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService; at com.sk89q.worldguard.internal.guava.cache.LocalCache.<clinit>(LocalCache.java:77) ~[?:?] at com.sk89q.worldguard.internal.guava.cache.LocalCache$LocalLoadingCache.<init>(LocalCache.java:4798) ~[?:?] at com.sk89q.worldguard.internal.guava.cache.CacheBuilder.build(CacheBuilder.java:793) ~[?:?] at com.sk89q.worldguard.session.SessionManager.<init>(SessionManager.java:56) ~[?:?] at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:135) ~[?:?] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[spigot.jar:git-Spigot-d21162c-61e0c69] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot.jar:git-Spigot-d21162c-61e0c69] at us.Myles.PWP.TransparentListeners.PerWorldPluginLoader.enablePlugin(PerWorldPluginLoader.java:145) [PerWorldPlugins.jar:?] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403) [spigot.jar:git-Spigot-d21162c-61e0c69] at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:384) [spigot.jar:git-Spigot-d21162c-61e0c69] at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:333) [spigot.jar:git-Spigot-d21162c-61e0c69] at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422) [spigot.jar:git-Spigot-d21162c-61e0c69] at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383) [spigot.jar:git-Spigot-d21162c-61e0c69] at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338) [spigot.jar:git-Spigot-d21162c-61e0c69] at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272) [spigot.jar:git-Spigot-d21162c-61e0c69] at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545) [spigot.jar:git-Spigot-d21162c-61e0c69] at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]
    I speak little English, sorry.
    I hope you can help me.

    An apology if I commit a foul with my post.
     
    #1 EliteMx, Mar 6, 2018
    Last edited: Mar 9, 2018
  2. Maybe try one of these official builds?
    http://www.enginehub.org/worldguard#downloads

    You can try a stable first, but there's a dev build from a week ago that might fix your bug.

    These work with my 1.12.2 setup.

    Make sure of course that Worldedit is also up to date first.
    (http://www.enginehub.org/worldedit#downloads , make sure you use the bukkit one)

    In regards to essentials, if you recently upgraded, perhaps consider using EssentialsX if you're on 1.12.2
     
    • Agree Agree x 2
  3. If you really want to get that fixed, try to have no plugin installed unless WorldGuard and WorldEdit. If that still doesn't work, try updating everything to the latest version. The Spigot, WorldGuard, WorldEdit.
     
  4. Thank you very much for your answers, I will try your solutions.
     
  5. Updating
    I already tried everything they recommended and nothing that works.
    I cleaned up all the plugin and put the basics

    [00:34:16] [Server thread/INFO]: Starting minecraft server version 1.12
    [00:34:16] [Server thread/INFO]: Loading properties
    [00:34:16] [Server thread/INFO]: Default game type: SURVIVAL
    [00:34:16] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-596221b-9a1fc1e (MC: 1.12) (Implementing API version 1.12-R0.1-SNAPSHOT)
    [00:34:16] [Server thread/INFO]: Debug logging is disabled
    [00:34:16] [Server thread/INFO]: Server Ping Player Sample Count: 12
    [00:34:16] [Server thread/INFO]: Using 4 threads for Netty based IO
    [00:34:16] [Server thread/INFO]: Generating keypair
    [00:34:16] [Server thread/INFO]: Starting Minecraft server on 149.56.32.80:857
    [00:34:16] [Server thread/INFO]: Using default channel type
    [00:34:16] [Server thread/ERROR]: Could not load 'plugins/RamMonitor(DONOTDELETE).jar' in folder 'plugins': uses the space-character (0x20) in its name
    [00:34:16] [Server thread/INFO]: Set PluginClassLoader as parallel capable
    [00:34:16] [Server thread/INFO]: [WorldEdit] Loading WorldEdit v6.1.9-SNAPSHOT;3709-354045a
    [00:34:16] [Server thread/INFO]: [WorldGuard] Loading WorldGuard v6.2.2-SNAPSHOT;1713-d2c52f7
    [00:34:16] [Server thread/INFO]: [Multiverse-Core] Loading Multiverse-Core v2.6.0-SNAPSHOT-b737
    [00:34:16] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
    [00:34:16] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
    [00:34:16] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    [00:34:16] [Server thread/WARN]: To change this, set "online-mode" to "true" in the server.properties file.
    [00:34:16] [Server thread/INFO]: **** Beginning UUID conversion, this may take A LONG time ****
    [00:34:16] [Server thread/INFO]: Preparing level "world"
    [00:34:16] [Server thread/INFO]: -------- World Settings For [world] --------
    [00:34:17] [Server thread/INFO]: -------- World Settings For [world_nether] --------
    [00:34:17] [Server thread/INFO]: -------- World Settings For [world_the_end] --------
    [00:34:17] [Server thread/INFO]: Preparing start region for level 0 (Seed: -1994011774404427321)
    [00:34:18] [Server thread/INFO]: Preparing spawn area: 70%
    [00:34:18] [Server thread/INFO]: Preparing start region for level 1 (Seed: -1994011774404427321)
    [00:34:19] [Server thread/INFO]: Preparing start region for level 2 (Seed: -1994011774404427321)
    [00:34:19] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v6.1.9-SNAPSHOT;3709-354045a
    [00:34:19] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
    [00:34:19] [Server thread/INFO]: [WorldEdit] Using com.sk89q.worldedit.bukkit.adapter.impl.Spigot_v1_12_R1 as the Bukkit adapter
    [00:34:19] [Server thread/INFO]: [WorldGuard] Enabling WorldGuard v6.2.2-SNAPSHOT;1713-d2c52f7
    [00:34:19] [Server thread/WARN]: /tmp/sqlite-3.18.0-a7510311-d26f-44a4-b849-7b29282184c3-libsqlitejdbc.so (No space left on device)
    [00:34:19] [Server thread/ERROR]: Error occurred while enabling WorldGuard v6.2.2-SNAPSHOT;1713-d2c52f7 (Is it up to date?)
    java.lang.UnsatisfiedLinkError: org.sqlite.core.NativeDB._open_utf8([BI)V
    at org.sqlite.core.NativeDB._open_utf8(Native Method) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.core.NativeDB._open(NativeDB.java:71) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.core.DB.open(DB.java:174) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.core.CoreConnection.open(CoreConnection.java:220) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.core.CoreConnection.(CoreConnection.java:76) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.jdbc3.JDBC3Connection.(JDBC3Connection.java:26) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.jdbc4.JDBC4Connection.(JDBC4Connection.java:24) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.SQLiteConnection.(SQLiteConnection.java:45) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.JDBC.createConnection(JDBC.java:114) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.sqlite.JDBC.connect(JDBC.java:88) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at java.sql.DriverManager.getConnection(DriverManager.java:664) ~[?:1.8.0_101]
    at java.sql.DriverManager.getConnection(DriverManager.java:270) ~[?:1.8.0_101]
    at com.sk89q.worldguard.util.profile.cache.SQLiteCache.(SQLiteCache.java:63) ~[?:?]
    at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:187) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:402) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:374) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:323) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:421) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:382) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:337) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:544) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]
    [00:34:19] [Server thread/INFO]: [Multiverse-Core] Enabling Multiverse-Core v2.6.0-SNAPSHOT-b737
    [00:34:19] [Server thread/INFO]: [Multiverse-Core] 3 - World(s) loaded.
    [00:34:19] [Server thread/INFO]: [Multiverse-Core] Version 2.6.0-SNAPSHOT-b737 (API v21) Enabled - By Rigby, fernferret, lithium3141, main-- and dumptruckman
    [00:34:19] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [00:34:20] [Server thread/INFO]: Done (3.338s)! For help, type "help" or "?"
    [00:34:20] [Server thread/INFO]: Starting GS4 status listener
    [00:34:20] [Server thread/INFO]: Starting remote control listener
    [00:34:20] [Server thread/INFO]: Unknown command. Type "/help" for help.[m

    I have installed the plugins of Enginehub and the plugins of the official pages.

    Any plugins similar to WorldGuard???
     
  6. "I am not looking for a solution to my problem."
    you should really fix this
     
  7. Thank you very much, I hadn't seen my mistake. My English is bad use as a translator to communicate.
     
    • Agree Agree x 1
  8. have you tried updating java? try latest java 8
     
  9. "The spigot version I use is 1.12.2"

    Does Spigot 1.12.2 even compile with java7?
     
  10. I don't know because I don't use java 7 for a few years now, just said that as a possibility to this magical problem
     
    #10 Govindas, Mar 9, 2018
    Last edited: Mar 9, 2018
Thread Status:
Not open for further replies.