Solved WorldGuard falldamage flag not working.

Discussion in 'Spigot Plugin Help' started by PatrickMSM, Feb 8, 2020.

  1. So I was working on a bungee network, and in my kit server, I wanted no fall damage. I entered the command: /rg flag __global__ fall-damage deny, and it didn't work. This problem also appeared on my spawn server. Without putting invincible allow, it doesn't work. Reply ASAP as my players keep dying when they dropdown. It's a 1.12.2 server.

    Screenshot of my kitpvp plugins: https://prnt.sc/qzq34e.

    <!> I FIXED IT BY UPDATING WORLDGUARD <!>
     
    #1 PatrickMSM, Feb 8, 2020
    Last edited: Feb 12, 2020
  2. We can't help you without the knowledge about your installed plugins. And if it doesn't you cloud try to code it by yourself.
     
  3. You have to do it in every world. Global applies to all areas in that one world. You must do that same command in your pvp world, spawn, plots whatever worlds you have have to have that flag.
     
  4. I have only one world.
     
  5. It's aslo bungeecord so i have seperate sevrer for all games.
     
  6. What's your server version ?
     
  7. 1.12.2
     
  8. Try make a region for the maps and deny fall damage there
    If that doesn’t work I can code a plugin that disables fall damage completely
     
  9. Please note that regions are separate from __global__.
    Meaning if you put fall-damage in global but not in ur region, your region won't have any flags
     
    • Agree Agree x 1
  10. that doesn't work either.
     
  11. i tried but it didnt wok
     
  12. <!> I FIXED IT BY UPDATING WORLDGUARD <!>