WorldGuard Permissions

Discussion in 'Spigot Plugin Help' started by YordiYVE, Jul 13, 2021.

  1. I'm trying to make it so people can only place stone, so I enabled build permissions in WG's config and added the permission "worldguard.build.block.place.stone". But people can't place stone, or any other block. There are no regions setup.
     
  2. Use this addon for WorldGuard (WorldGuard 6.1.2 or lower no supported)

    Use the flag "allow-block-place"
    /rg [region] flag allow-block-place STONE
     
  3. That flag from that plugin only works with WorldGuard 6, which is no longer supported.
     
  4. Maybe u should add the id of the block not the name.. maybe.
     
  5. Hm, I have a region on my server where people can only use signs and wallsigns.

    I realised it with regular build permissions and flags. There's this deny-blocks and allow-blocks flag. Deny-Blocks is set to air and allow-blocks is set to oak_wall_sign etc.

    BUT: The flags needed a restart to work properly.

    Maybe it helps...