Writting twice on server chat

Discussion in 'Spigot Plugin Help' started by FuraBolos, May 26, 2017.

  1. This is what happens when I type something:
    [​IMG]
    I use LegendChat only.
     
    #1 FuraBolos, May 26, 2017
    Last edited: May 27, 2017
  2. The image link doesnť work... can you post list of all your plugins?
     
  3. Hmm, the same thing did Factions on my server, but you don't have that.
    Can you fix the image link, so we can see, what's going on?
    EDIT: Thanks
    EDIT02: Did you configure it correctly? If you have "log-to-file" enabled, you can check, what messages are saved to the file (if just once, or twice).
     
  4. The Image Link It's working now
     
  5. Or have you installed EssentialsCHat.jar ? Maybe you forgot to uninstall it, because the format <nick> text is the same as it is in essentials' config.yml:
    Code (Text):
     format: '<{DISPLAYNAME}> {MESSAGE}'
      #format: '&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}'
     
  6. I had EssentialsChat installed but I uninstalled it already, the format used on Essentials is the same used on "Default" Servers isn't it?
    (I changed the format the color of the Text on Essentials config and nothing changed, I also put an "#" before the "format: '<{DISPLAYNAME}> {MESSAGE}'" and still remains the same.
     
  7. Yes it is, but I can't find any other "thing", which is doing that. WHat about the LegendChat log?
     
  8. I Used PlugMan and Disabled all plugins then I proceded to Enable LegendCHat only and it worked...
    [​IMG]
     
  9. Enable plugins one by one until the issue occurs. Then you can isolate it to a plugin.
     
  10. Yup.. that's what I am doing
     
  11. omg..... Nothing
    I can't enable iDisguise, protocollib or furniturelib.
    Any of the plugins that I enabled made the message appear twice
     
    #11 FuraBolos, May 27, 2017
    Last edited: May 27, 2017
  12. I have another problem now...
    The name of the world im currently on appears before my name..
    [​IMG]
     
  13. Do you have multiverse installed?
     
  14. Yes I do have multiverse and multiverse-portals installed
     
  15. go into ur multiverse config and disable world prefix
     
  16. Ok Problem solved (For any other users with the same problem who might be watching this thread it is necessary that you Close the Server and then proceed to change the config file on Multiverse).
    Anyway...
    I still got the main problem
     
    #16 FuraBolos, May 27, 2017
    Last edited: May 27, 2017
  17. Note: When I disable all plugins and enable them again on Plugman seems like the problem stops happening
    When I reload thought its still there
     
  18. New: When I type /g a (Channel, message) this is what happens:
    [​IMG]
     
  19. I Really need some help.. did you guys discovered something?
     
  20. MassiveCore is causing the problem.. dont know why