Spigot 1.14 Plugin Compatibility List - Historical

Applied By MineManiacsBR: May 30, 2019 at 11:32 AM

Spigot 1.14 Plugin Compatibility List

Spigot 1.14 Plugin Compatibility List

Lists of plugins that are compatible, semi-compatible, no longer supported, and for those with no compatibility for Spigot/Bukkit 1.14. With 1.14, it is likely that a majority of plugins will need to be updated.



The hub page for each plugin compatibility list is here.

The compatibility list by version is here. Any additions? Edit this page. This list is sortable by plugin, release, owner, URL

Place plugins in the appropriate categories.

Format:
See under each section. Alphabetical order is appreciated.


No Longer Supported(top)

Preferred Format: Plugin Name <Version Number> - <Possible replacement plugin>

No Compatibility/Broken(top)

Preferred Format: Plugin Name <Version Number> - <Errors/Notes/Dependencies>

  • BuildersUtilities (v1.2.9) - Depends on FAWE
  • ChatFeelings (v3.7.3-BETA) - Crashes server
  • Dynmap (v3.0-beta-3) - Error initializing dynmap - bukkit version incompatible / There is a working build on github
  • VentureChat (v2.14.3) - Fails to pass AsyncChatEvent

Semi-Compatible/Sorta Works(top)

Preferred Format: Plugin Name <Version Number> - <Errors/Notes>

  • Cannons (v2.5.3) - Works, but gives errors about invalid blocks
  • EssentialsX (v2.16.1) - Works, but errors about consistently
  • Multiverse-Core (v3.0.0 SNAPSHOT *with some errors*)
  • GemsEconomy (v4.7.5) - Works, but gives an error about unsupported spigot version.

Compatible/Working(top)

Preferred Format: Plugin Name (with link to plugin) <Version Number> <Dependencies/Other Details>