SpigotMC Compatible Plugins By Release

Aug 26, 2017
SpigotMC Compatible Plugins By Release
  • Spigot Compatible Plugins By Release

    One huge list of plugins that shows compatibility from 1.8.x -1.12.x!




    This page will provide you with all the details you need to pick the right plugin for your server. There are some basic assumptions I would expect you to know & understand.

    1. I am not the developer or owner of any plugins listed
    2. I do not warranty any part of the plugin and its implied features
    3. You know what you are doing before you download the plugin
    4. You follow the plugin owners policy for reporting issues. Read the Overview Tab carefully, or you may not get the answers you seek.
    5. Your first response is NOT to report a bug, but to investigate what you did to cause the bug to be seen.
    6. You report ALL FACTS related to your server setup to help the developer identify where the problem is. If you don't provide the server type (Spigot, Paper Spigot, Bungee, Forge, etc.) along with its version and the version of the plugin you are using, you may not get the answers you seek.
    7. Do not assume the developer or anyone helping you understands or has knowledge about your server setup. Only you have that information so withholding it only hurts your chances of getting help.
    8. Finally, read this again and pay attention to the Overview Tab for each plugin and what the policy is for reporting issues and getting the support you need.
    Overview
    This page provides you (server owner/admin/manager), with a list of all the known plugins that are supported or not supported from Minecraft 1.8 through the (now) current Minecraft 1.12 Servers in a very simple spreadsheet to help you find what it is you need.

    Columns of Data
    [​IMG]

    1. Each row of plugin names are sorted by Name (Column A) by default
    2. Column A (hover over with mouse pointer), provides a summary of what the plugin does. This information in most cases came from the plugin owners page.
    3. The Author of the plugin or current developer is provided with a link (if known) to their profile page
    4. The URL for getting access to the plugin owners page to download the latest (or desired) version
    5. Columns 1.12.1, 1.12.x, 1.11.x, 1.10.x, 1.9.x and 1.8.x show when this plugin started to support a particular Minecraft Release. It is up to YOU, to visit their site periodically for any updated versions you should download.
    Sorting of Data
    The entire spreadsheet is open for sorting any way you prefer. Just click on the icon shown below to open the properties panel for that column. You can sort from A to Z or Z to A, Filter by condition, Filter by values and search for a value in the column of your choosing.
    [​IMG]

    Everyone has READ ONLY access to this spreadsheet. As I am made aware of new plugins or existing ones being added or supported in the latest release, I will add similar data to the spreadsheet. If anyone has recommendations for what they find hard to find about a plugin which is not provided here, do send me a Private Message (PM) via Spigot and I will consider it.

    There are two other pages I spent considerable time on keeping updated. Going forward though, this is the page I will spend my time on as it provides greater value than the individual Spigot Compatible Plugin pages for 1.11.x and 1.12.x releases. There are just too many to try to keep those pages updated when active development work is in-play. All these updates do take time, just like developing the plugin itself. This document is designed to grow as the products grow.

    Should you appreciate the time and effort I put into this document,
    consider sending a donation my way. Your choice as to what you can afford and what value it brings to you for me to monitor over 400 plugins for updates and adding new ones! :)


    Thank you all!
    -Steve
    PM smmmadden
  • Loading...
  • Loading...